E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Car Care & Detailing

Car Care & Detailing
Get detailing answers and tips here

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 12-30-2005, 02:43 PM   #1
Hoyshel
Registered User
 
Join Date: Dec 2004
Location: United States
Posts: 135
My Ride: 330ci
Klasse AIO removing paint off of Roundel emblem

I put a coat of Klasse AIO on my car a few days ago and today I noticed that the paint on the roundel emblem was all gone. It's straight silver now. Has anybody else had this happen or does anyone else think that klasse would do that? I always go over the emblem when I wax my car with regular wax and have never had a problem.
Hoyshel is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 12-30-2005, 06:25 PM   #2
kpeng
Banned User
 
Join Date: Jan 2004
Location: Gainesville, FL
Posts: 25,675
My Ride: E46 330 and E30 325
Uh, can't say it has happened to me, but you really shouldn't be putting wax all over your emblem in the first place.

-Ken
kpeng is offline   Reply With Quote
Old 12-30-2005, 09:15 PM   #3
Hoyshel
Registered User
 
Join Date: Dec 2004
Location: United States
Posts: 135
My Ride: 330ci
i didn't put it all over the emblem...i just applied it like i did the rest of the car. I've waxed my car atleast 20 times and have never gone around it and it's never happened before, but i've never used Klasse AIO before so I was just wondering if that could be the reason.
Hoyshel is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 12:58 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use