E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > DIY: Do It Yourself

DIY: Do It Yourself
Post here to share or improve your wrench turning skills! All BMW E46 DIY tips, tales, and projects discussed inside. Learn to work on your car and know the right BMW parts you will need!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 11-11-2005, 03:19 PM   #1
sconroy325
Registered User
 
Join Date: Mar 2005
Location: lowell, ma
Posts: 52
My Ride: '01 325xi
Coolant Light???

My coolant light keeps comming on when I start to drive. When I stop at light or start the car, there is no light. I checked the fluid, and the dipstick says full. I'm just curious if any one might have any ideas as to why this is happening.
thanks
sconroy325 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 11-11-2005, 03:24 PM   #2
deutsch325
Registered User
 
Join Date: Oct 2005
Location: SF bay area
Posts: 452
My Ride: xi
Quote:
Originally Posted by sconroy325
My coolant light keeps comming on when I start to drive. When I stop at light or start the car, there is no light. I checked the fluid, and the dipstick says full. I'm just curious if any one might have any ideas as to why this is happening.
thanks
Maybe you need a new radiator cap? The cooling system needs to be under high pressure, if the cap is not functioning properly, that could be the cause. Have you ever had your water pump replaced? e46 water pumps have a bad reputation for failing early.. I think it has to do with the use of plastic impellers that degrade over time
__________________
deutsch325 is offline   Reply With Quote
Old 01-18-2006, 06:32 PM   #3
1edyson
Yoda Rocks!
 
Join Date: Dec 2004
Location: Sacramento
Posts: 400
My Ride: 325CI
Send a message via AIM to 1edyson
this sounds exactly like the problem im having...risking sounding like a noob, where exactly is the coolant resevoir? nm just found a thread on it.
__________________
2004 325Ci 2004 - current
2002 B5.5 1.8T 2001-2005


Last edited by 1edyson; 01-18-2006 at 06:34 PM.
1edyson is offline   Reply With Quote
Old 01-18-2006, 10:09 PM   #4
nEVERCLEAR
Registered User
 
Join Date: Oct 2003
Location: SC
Posts: 702
My Ride: 323
Drivers side US spec cars, it is the thing with the cap on top that has the floating rod inside to tell you if it is full.

Have you checked your coolant level?
__________________
Thinking about a Honda or VW Dont buy from East Coast Honda - VW Read about my experience here

Some people dream of speed-others create a damn jet powered shopping cart.
Curious about VoIP and Vonage click here
nEVERCLEAR is offline   Reply With Quote
Old 01-18-2006, 11:21 PM   #5
kevmo
Registered User
 
kevmo's Avatar
 
Join Date: Jun 2003
Location: MD (Ft. Meade)/MA
Posts: 13,478
My Ride: vDubDizzle
Send a message via AIM to kevmo
i had that happen to me a few days ago... havn't seen it since... kinda scared... been keeping my eye on the temperature gauge....
__________________


kevmo is offline   Reply With Quote
Old 01-19-2006, 11:02 AM   #6
hummer
Registered User
 
Join Date: Apr 2003
Location: Haverhill, MA
Posts: 3,323
My Ride: 2001 330CI
If you're sure the level is good, it's most likely the sensor that turns the light on. Probably on it's way out.
hummer is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 03:14 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use