E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Lighting Forum

Lighting Forum
Angel Eyes, DDEs, lighted rings, Clear Turn Signals, LEDs, Xenon, HID, or Bi-Xenon. If it lights up and you want to discuss it, post here!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 10-08-2006, 12:26 AM   #1
italianish
Registered User
 
Join Date: Mar 2006
Location: phoenix
Posts: 67
My Ride: 2000 bmw 323i
dde predator chroms

ok looks gusy.. ive had my chromiums installed for 8 months.. is anybody else experiencing the clear filmish backing of the rings coming unglued, or coming off? my lights still work perfectly, but it looks like the backing is falling off.. plus xanax and percocet is good!
__________________
italianish is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 10-08-2006, 12:37 AM   #2
Tyler@UniqueDesign
Car Junky
 
Join Date: Apr 2006
Location: Gainesville, Florida
Posts: 1,791
My Ride: has a torn subframe
Send a message via AIM to Tyler@UniqueDesign
I think Alec had the same thing happen.

The glue gets heat cycled after time and the rings come apart. I've seen it happen on the pred chromiums and the titniums, waiting to see if its something the raptors will have happen too.

I'm sure its easily fixed as well btw.
Tyler@UniqueDesign is offline   Reply With Quote
Old 10-08-2006, 12:43 AM   #3
italianish
Registered User
 
Join Date: Mar 2006
Location: phoenix
Posts: 67
My Ride: 2000 bmw 323i
its really fkn irritating, the fact that i have to take apart my light fixures all over again
__________________
italianish is offline   Reply With Quote
Old 10-08-2006, 02:04 AM   #4
Jrob1
Registered User
 
Join Date: May 2006
Location: Wichita, KS
Posts: 531
My Ride: 2003 BMW 330i
Happened to me too, seems like the glue just heats up and gives way or something....very unfortunate.
Jrob1 is offline   Reply With Quote
Old 10-08-2006, 03:28 AM   #5
XeroMajin
Registered User
 
Join Date: Jun 2005
Location: Reno
Posts: 124
My Ride: xi
yup its happened to me but it doesnt really bother me too much
__________________
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 03:54 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use