E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Lighting Forum

Lighting Forum
Angel Eyes, DDEs, lighted rings, Clear Turn Signals, LEDs, Xenon, HID, or Bi-Xenon. If it lights up and you want to discuss it, post here!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 11-07-2007, 07:35 PM   #1
FrontlinexBMW
Registered User
 
Join Date: Jun 2006
Location: Boston, Mass
Posts: 136
My Ride: 2003 BMW 330i
Umnitza Predator Chromiums Help!!!

I ordered my P46's from Umnitza last Monday and he told me that it was going to arrive Friday. However, it reached my door on Thursday so for Umnitza for quick responses and shipment. After installing the headlights I tested out the projectors first since I didn't know where to wire the trigger wire at first. To this point, everything looks great!!! But after putting in the trigger wire, the Predator Chromiums came on and were awesome but one was out. The lights out indicator in my car showed the same side as the angel eye that wasn't working. The other side is perfectly fine. I'm hearing from other fanatics that this is the cause of the ballast for the angel eyes. Matt has told me that it's the ring and might have been damaged because of shipping. Anyone with a diagnostic for this or what I should do? Please help!!! I personally don't think changing a ring from a pre-installed unit would be a good idea unless I send it back to Matt.
__________________

Under Construction
FrontlinexBMW is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 11-07-2007, 07:50 PM   #2
Edison@JleviSW
1.888.JLEVISW
 
Edison@JleviSW's Avatar
 
Join Date: Apr 2002
Location: Santa Clara
Posts: 28,332
My Ride: BMW Duh
Send a message via AIM to Edison@JleviSW
You can confirm by swapping the angel eye ballast inside the headlight. It's the little black box that you can reach through the high beam and is attached to the white wires for the rings. Swap it with the working side and see if the problem switches sides. If not, it's a ring issue.

You can just have Matt send out a replacement ring and install it yourself, it's not too bad.
Edison@JleviSW is offline   Reply With Quote
Old 11-07-2007, 10:54 PM   #3
M3R1
Registered User
 
Join Date: Sep 2007
Location: Oceanside, CA
Posts: 22
My Ride: Silver 04 M3
That happened to me I diagnosed it to be the ring and sure enough the ring was cracked from the manufacturer. It was covered under warranty, but I still had to pay $10 for shipping plus had to buy heat resistant glue So far they look great
M3R1 is offline   Reply With Quote
Old 11-08-2007, 06:56 PM   #4
C M3 FLY
Banned
 
Join Date: Sep 2007
Location: Chicago, Illinois
Posts: 433
My Ride: 2002 Alpine White M3
Same, i had a problem angel eye as well (possibly 2 as i am getting one replaced as well) but i got them fixed for free from the the shop that put em in!

Good luck, and they do look good when they are working right!
C M3 FLY is offline   Reply With Quote
Old 11-08-2007, 09:37 PM   #5
FrontlinexBMW
Registered User
 
Join Date: Jun 2006
Location: Boston, Mass
Posts: 136
My Ride: 2003 BMW 330i
think Matt and I found what the prob was and gonna try fixing it tomorrow...hopefully get some pix...btw..I got ur setup C M3 FLY!!!
__________________

Under Construction
FrontlinexBMW is offline   Reply With Quote
Old 01-10-2008, 04:26 PM   #6
vit325
smooth criminal
 
Join Date: Dec 1969
Location: miami, fl
Posts: 361
My Ride: 2001 325i
Send a message via AIM to vit325
i also narrowed down my problem to a ring issue, and umnitza sent me 2 replacements...problem is i dont have a clue how to swap them out

please help!
__________________
vit325 is offline   Reply With Quote
Old 01-10-2008, 06:26 PM   #7
M0nk3y
Banned
 
Join Date: Nov 2007
Location: Cleveland, Ohio
Posts: 2,065
My Ride: 2002 325xi
Search.........DIYs

http://www.fastm.com/m3/angeleyes.html
M0nk3y is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 12:26 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use