E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 04-27-2008, 08:41 PM   #1
xcelr8dbmw
Registered User
 
Join Date: Nov 2004
Location: maryland, usa
Posts: 457
My Ride: 2007 X5 4.8
Bilstein Pss9 problem

I have had this setup for about a year now. Yesterday i was under the car cus i was going to raise it a bit in the rear cus it was too noisy. It was making alot of clunking sounds and i think i read somewhere that if the perches are too low then that happens. Well when i got underneath i saw the blot that hold the shock in at the bottom was inside the rubber bushing. Well it took me 2 hours to beat it with a rubber mallet (didnt want to damage the shock) to get the bushing to slide back into place. my question is...is there something wrong with this shock? the guy at the tirerack.com said this sometimes happens. Should i call bilstein? I raised the rear perches 1/8" and the cluncking sound is gone and the car handles waaay better. sorry the pic. is upside down.
Attached Thumbnails
Click image for larger version

Name:	IMG_0061.jpg
Views:	86
Size:	100.8 KB
ID:	268976  
__________________


Cyanide & Happiness @ Explosm.net
xcelr8dbmw is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 04-27-2008, 09:59 PM   #2
djnekkon
Registered User
 
Join Date: Oct 2006
Location: Paterson, New Jersey / Orlando Florida
Posts: 15,922
My Ride: MB3ci Regensburg Bav
you're not alone....
djnekkon is offline   Reply With Quote
Old 04-27-2008, 10:13 PM   #3
jeremysmith1967
a.k.a. Norton
 
Join Date: Mar 2006
Location: Gainesville, FL
Posts: 2,035
My Ride: 00 328ci & 67 stang
Send a message via AIM to jeremysmith1967
just put a washer on the bolt. Problem solved

I had the issue along with 2 of my buddies.
__________________
jeremysmith1967 is offline   Reply With Quote
Old 04-28-2008, 01:34 AM   #4
BlackChrome
No more E46 :(
 
BlackChrome's Avatar
 
Join Date: Jul 2003
Location: Seattle, WA
Posts: 2,673
My Ride: 2001 3.0L Ci
Quote:
Originally Posted by jeremysmith1967 View Post
just put a washer on the bolt. Problem solved

I had the issue along with 2 of my buddies.
Sane thing happened to me 2 years ago.

Here is a thread that should help. PSS9 Popped Out
__________________
BlackChrome is offline   Reply With Quote
Old 04-28-2008, 01:52 AM   #5
deafboy
Registered User
 
Join Date: Sep 2005
Location: Blaine, WA
Posts: 26,609
My Ride: 2000 323Ci
common issue...

just get a couple big washers from your local hardware store... easy fix.
__________________
-Cole aka bigtall*****

Quote:
Originally Posted by Owtlaw333 View Post
You'll always be pretty in my eyes, Cole :luv:
Quote:
Originally Posted by Chrissspyy View Post
i was like passed out while she's shoving the entire bar in my mouth. :rofl: :rofl:
deafboy is offline   Reply With Quote
Old 04-28-2008, 01:58 AM   #6
keith_m3-4
Registered User
 
Join Date: Feb 2006
Location: Bay Area, CA USA
Posts: 792
My Ride: 02 325iT
Common.. the newer kits comes wtih the fix.. large washer as everyone mentioned,
keith_m3-4 is offline   Reply With Quote
Old 04-28-2008, 06:38 AM   #7
xcelr8dbmw
Registered User
 
Join Date: Nov 2004
Location: maryland, usa
Posts: 457
My Ride: 2007 X5 4.8
thanks guys. i just wanted to make sure it was not a problem with the bushing. Ill get the big washer and install them this week. Ps my kit i got last year did not come with the washers
__________________


Cyanide & Happiness @ Explosm.net
xcelr8dbmw is offline   Reply With Quote
Old 04-28-2008, 08:36 AM   #8
tzh
Banned
 
Join Date: Apr 2008
Location: KL
Posts: 12
My Ride: E46 2000'
Quote:
Originally Posted by djnekkon View Post
you're not alone....
This sentence is classicallly
tzh is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 10:10 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use