E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > New Member Introductions

New Member Introductions
New members check-in, introduce yourselves, and post a picture of your BMW here!

Reply
 
Thread Tools Search this Thread Display Modes
Old 04-30-2008, 03:34 AM   #1
SteveWiles
Registered User
 
Join Date: Apr 2008
Location: south wales, GB
Posts: 2
My Ride: 1999 328 CI
newbie, 1999 328 coupe

Hi everyone, iv'e just joined the forum after a google search about some electrical problems with my coupe. After looking on here i think i have found the problem
SteveWiles is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 04-30-2008, 05:21 AM   #2
Breyton-BMW
Registered User
 
Breyton-BMW's Avatar
 
Join Date: May 2007
Location: Philippines
Posts: 4,394
My Ride: Ti
Send a message via AIM to Breyton-BMW Send a message via Yahoo to Breyton-BMW
. This forum has a lot of valuable info to the E46 owner which can save you a lot of dough and also make you spend a lot as well.
__________________




Breyton-BMW is offline   Reply With Quote
Old 04-30-2008, 10:26 AM   #3
XPLCTBMW
Registered User
 
Join Date: May 2007
Location: Sanataria Springs NY
Posts: 837
My Ride: is soldddd
Send a message via AIM to XPLCTBMW
welcome!!!!
__________________
XPLCTBMW is offline   Reply With Quote
Old 04-30-2008, 11:19 AM   #4
jboucher
Registered User
 
Join Date: Feb 2008
Location: Vancouver, BC
Posts: 118
My Ride: 2006 550
Thumbs Up great e46 resource

Hi Steven, I found this site because of a tail light error code that kept coming on even though the bulb was fine. I have since bought new rims, black grill, smoked sides and corners, black roundels, and placed an order yesterday for smoked rear lights! As soon as I find a good local shop, I am putting on some sport suspension.

Like Breyton said, wealth of information can be found here, but watch out, the mod bug is always lurking, ready to bite

Oh yeah, welcome from another noob
__________________
jboucher is offline   Reply With Quote
Old 04-30-2008, 01:09 PM   #5
hotspy1
Registered User
 
Join Date: Feb 2008
Location: here
Posts: 590
My Ride: King monkey's cloud
Send a message via MSN to hotspy1
Welcome
Let the mod addiction begin
__________________
Irish Bimmer forum bmw-driver.net
hotspy1 is offline   Reply With Quote
Old 04-30-2008, 05:31 PM   #6
SteveWiles
Registered User
 
Join Date: Apr 2008
Location: south wales, GB
Posts: 2
My Ride: 1999 328 CI
Cheers People, i changed the ignition switch today and all the problems have gone except im left with the airbag light still on.
I'm thinking of buying some black kidney grills soon, will go look on ebay now
SteveWiles is offline   Reply With Quote
Old 05-06-2008, 10:58 AM   #7
drifting328ci
Registered User
 
Join Date: Apr 2008
Location: St Louis
Posts: 18
My Ride: 2000 328CI
Hi Fellow E46 Fanatics,

I am a proud new owner of a used 2000 328CI. Everything seems to work on the car with the exception for the cruise control switch which seems to have died on me.

Any ideas what could be wrong? I tried to look for the fuse in the glove comparment but there isn't any. What else could be the problem?

Thanks in advance for any advise.
drifting328ci is offline   Reply With Quote
Old 05-06-2008, 11:21 AM   #8
taghirap
Registered User
 
Join Date: Jun 2004
Location: Hasbrouck Hts, NJ
Posts: 358
My Ride: tricycle...
Send a message via Yahoo to taghirap
welcome!
taghirap is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 01:41 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use