E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 05-08-2008, 06:20 PM   #1
mankit
Registered User
 
Join Date: Mar 2005
Location: Canada
Posts: 31
My Ride: Year2000 323i
Exclamation Transmission Light On/Off like this ([!]) HELP

[E46 Year2000 323i / Steptronic]

Hi, I really wanna get some comment and help right here. My car is in 96053k right now. When I was driving it last week, my Transmission light is turned on in the dash board which contain in the small square of the transmission box. It comes out with a sign beside the "D" < like this ([!]). Also, after that sign is on, my car just keep my speed to the "3 & 4 gear speed". When I try to shut down the car and wait abt 2 minutes..then start the car again, the ([!]) is off. I bring my car to my local BMW dealer and they helped me to check the code and stuff...end up, they told me to bring back my OEM CD player and they try to take my alpine out and install my oem back and install my alpine back when i pick up my car. End up in the invoice said they have checked the problem....light turn off didn't come out again, can't check fault. that su!Ks! that mean they do nothing!

Yesterday, When I was driving it out at the night time, the ([!]) is come out again. This make me crazyyyyy...did anyone have the same problem? What is going on!!

My dealer charge me for the checking cost $205.64 for the labor + gst&pst
mankit is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 05-08-2008, 06:43 PM   #2
wasp9166
ima touching member
 
wasp9166's Avatar
 
Join Date: Dec 2007
Location: straight out da bronx
Posts: 4,884
My Ride: 04 330i jet black
Send a message via Yahoo to wasp9166
the dealer says your tranny goes into limp mode cuz of your aftermarket head? this has to take the cake
__________________

"if polarity comes from protons, does morality come from morons?"

Quote:
Originally Posted by russ330 View Post
"Mommy and Daddy are getting a divorce now because wasp9166 had to piitb with Mom."
wasp9166 is offline   Reply With Quote
Old 05-08-2008, 06:45 PM   #3
aggieE46
Keep it clean
 
aggieE46's Avatar
 
Join Date: Aug 2006
Location: Royse City
Posts: 8,030
My Ride: 03 Evo, 07 Passat
Send a message via AIM to aggieE46
Actually, it's not the first time I've seen that.

Quote:
Originally Posted by wasp9166 View Post
the dealer says your tranny goes into limp mode cuz of your aftermarket head? this has to take the cake
__________________
aggieE46 is offline   Reply With Quote
Old 05-08-2008, 06:49 PM   #4
mankit
Registered User
 
Join Date: Mar 2005
Location: Canada
Posts: 31
My Ride: Year2000 323i
Any idea what is it, I already so headach of that! Did any one fix that problem? HELP HELP HELP
mankit is offline   Reply With Quote
Old 05-08-2008, 06:50 PM   #5
neil1138
Registered User
 
Join Date: Jan 2008
Posts: 4,240
That mean your tranny is going into limp home mode. Thats not good... might be time to get a new tranny. Or sell the car "as is no warranty"
neil1138 is offline   Reply With Quote
Old 05-08-2008, 06:51 PM   #6
aggieE46
Keep it clean
 
aggieE46's Avatar
 
Join Date: Aug 2006
Location: Royse City
Posts: 8,030
My Ride: 03 Evo, 07 Passat
Send a message via AIM to aggieE46
I'm assuming the symbol you're making is the DSC symbol, right? Have you checked out your battery lately? I think the first thing to start giving you issues will be your DSC if the battery is getting weak.
__________________
aggieE46 is offline   Reply With Quote
Old 05-08-2008, 06:56 PM   #7
mankit
Registered User
 
Join Date: Mar 2005
Location: Canada
Posts: 31
My Ride: Year2000 323i
Yaa.....my car battery is dead and I have already changed a new battery on the April middle time!
mankit is offline   Reply With Quote
Old 05-08-2008, 07:03 PM   #8
mankit
Registered User
 
Join Date: Mar 2005
Location: Canada
Posts: 31
My Ride: Year2000 323i
This thing come to me very bad, Iam ready to do a clean change (INSP 2)for my car. But now I wanna fix this problem first before I do the change!

K&N clean Kit for my 57 series intake
Cabin microfilter
Oil Change 5w30 motul
Mann Oil Filter
NGK laser plantium spark plug
Clamp
WWF Kit
E32 XX Gaskest Ring
Fuel Filter
Fuel System Cleaner
mankit is offline   Reply With Quote
Old 05-08-2008, 07:10 PM   #9
SteveX82
Registered User
 
Join Date: Feb 2007
Location: Glendora, New Jersey
Posts: 881
My Ride: 2001 325i
Quote:
Originally Posted by mankit View Post
Yaa.....my car battery is dead and I have already changed a new battery on the April middle time!
Has anybody bothered to check the KOER voltage to ensure the alternator is charging? Low system voltage will cause the ECU to begin shutting down systems in an effort to conserve battery capacity.
SteveX82 is offline   Reply With Quote
Old 05-08-2008, 07:24 PM   #10
mankit
Registered User
 
Join Date: Mar 2005
Location: Canada
Posts: 31
My Ride: Year2000 323i
=( what do you mean? "SteveX82"
mankit is offline   Reply With Quote
Old 05-08-2008, 07:33 PM   #11
aggieE46
Keep it clean
 
aggieE46's Avatar
 
Join Date: Aug 2006
Location: Royse City
Posts: 8,030
My Ride: 03 Evo, 07 Passat
Send a message via AIM to aggieE46
Make sure the alternator isn't crapping out.
__________________
aggieE46 is offline   Reply With Quote
Old 05-08-2008, 07:41 PM   #12
SteveX82
Registered User
 
Join Date: Feb 2007
Location: Glendora, New Jersey
Posts: 881
My Ride: 2001 325i
Put a voltmeter across your battery terminals while the engine is running, and make sure that the voltage reads at least 13.5-14.0volts. If it doesn't, then that means your alternator isn't charging and that everybody at your BMW dealership should be fired for incompetence.
SteveX82 is offline   Reply With Quote
Old 05-08-2008, 07:44 PM   #13
mankit
Registered User
 
Join Date: Mar 2005
Location: Canada
Posts: 31
My Ride: Year2000 323i
I don't think it's the alternator problem. If it is that problem, last time I pick up my car, they will told me that i think! =(
mankit is offline   Reply With Quote
Old 05-08-2008, 08:10 PM   #14
mankit
Registered User
 
Join Date: Mar 2005
Location: Canada
Posts: 31
My Ride: Year2000 323i
Unhappy

The Light is light this! But mine is only pop up when the car is running "D" not "P"
Attached Thumbnails
Click image for larger version

Name:	DSC00185.jpg
Views:	517
Size:	13.2 KB
ID:	270479  
mankit is offline   Reply With Quote
Old 05-08-2008, 08:25 PM   #15
tradingflare
Registered User
 
Join Date: Nov 2007
Location: USA
Posts: 797
My Ride: needs a mechanic
It's your transmission light...what on God's green earth that has to do with your cd player, only $205.64 will know.
tradingflare is offline   Reply With Quote
Old 05-08-2008, 08:30 PM   #16
mankit
Registered User
 
Join Date: Mar 2005
Location: Canada
Posts: 31
My Ride: Year2000 323i
The dealer is devil man, they always kill our $$!
mankit is offline   Reply With Quote
Old 05-08-2008, 08:32 PM   #17
tradingflare
Registered User
 
Join Date: Nov 2007
Location: USA
Posts: 797
My Ride: needs a mechanic
Quote:
Originally Posted by mankit View Post
The dealer is devil man, they always kill our $$!

Well, you kind of set yourself up for that one. No offense, but your owner's manual would have showed you what that light is, and you could've stopped your dealer from yanking your cd-player out. Unless they were searching for something electrical, that would be a different story. As far as I'm concerned, this is a mechanical issue.

Sell the car, now, as is.
tradingflare is offline   Reply With Quote
Old 05-08-2008, 08:32 PM   #18
djnekkon
Registered User
 
Join Date: Oct 2006
Location: Paterson, New Jersey / Orlando Florida
Posts: 15,926
My Ride: MB3ci Regensburg Bav
take it back to them......get your money back. Those Stupid son of a biatches. Your tranny can be fixed with sum $$$ and be like new. There are replacement (metal) part to correct that already on the street. Even if it is the whole transmision, nobody is going to buy it unless u fix it anyway. So take your time on it, maybe is nothing major

Last edited by djnekkon; 05-08-2008 at 08:37 PM.
djnekkon is offline   Reply With Quote
Old 05-08-2008, 08:32 PM   #19
SteveX82
Registered User
 
Join Date: Feb 2007
Location: Glendora, New Jersey
Posts: 881
My Ride: 2001 325i
Quote:
Originally Posted by mankit View Post
I don't think it's the alternator problem. If it is that problem, last time I pick up my car, they will told me that i think! =(
The fact that they blamed the problem on your head unit shows that they are incompetent, and incompetent people are extraordinarily capable of making mistakes such as overlooking an alternator charging problem.

If you have a voltmeter, do yourself a favor and check the voltage yourself. It should literally take you 1 minute. The fact that your battery failed just a few weeks ago suggests that you might have had other electrical issues at the time.
SteveX82 is offline   Reply With Quote
Old 05-08-2008, 08:35 PM   #20
mankit
Registered User
 
Join Date: Mar 2005
Location: Canada
Posts: 31
My Ride: Year2000 323i
I will bring my car to the dealer tomorrow, cuz they said if the light is poping out again, they can check it for me for no cost.
mankit is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 05:44 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use