E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > DIY: Do It Yourself

DIY: Do It Yourself
Post here to share or improve your wrench turning skills! All BMW E46 DIY tips, tales, and projects discussed inside. Learn to work on your car and know the right BMW parts you will need!

Reply
 
Thread Tools Search this Thread Rating: Thread Rating: 22 votes, 5.00 average. Display Modes
Old 07-16-2008, 05:26 PM   #1
TKC
Registered User
 
Join Date: Nov 2005
Location: San Jose, CA & Dallas, TX
Posts: 20,233
My Ride: 330cic & R6
Send a message via AIM to TKC
Replaced both Fuel Level Sensor/Sending Units. DIY with pics....

Fuel sending units & level sensors replacement

Here are the symptoms my car had that prompted me to replace my fuel sending units & level sensors:

1) Car died on the freeway even though CPU said I had 45 miles till empty.
2) Then it did it again even though CPU said I had 75 miles till empty a week later.
3) Car stutters while accelerating at full throttle, even in straight line.
4) Rough idle. When taking car out of gear coming to a stop, needle would dip below idle, sputter, rev itself back up, only to dip again and eventually die sometimes. I could fire it right back up, but just ANNOYING.
5) Poor MPG.

SO, I decided to replace both sending units/level sensors. I also replaced the fuel filter.

Fuel sending units & level sensors replacement:
NOTES: I AM NOT RESPONSIBLE FOR ANY DAMAGE. THIS IS SIMPLY WHAT I DID. WORK ON YOUR OWN CAR AT YOUR OWN RISK.
That being said, I had about 3/4 tank of gas in my car at the time. It's suggested that you wait till you are basically empty before you do this job.
HAVE A FIRE EXTINGUSHER HANDY. Although if my gas tank caught, I don't know what good the tiny extinguisher would have done. And finally, use your brain. You're working with fuel here, so don't smoke, don't use a working lamp that gets hot, etc.
Again, I am responsible for nothing, this is just documents of what I did.

1) Disconnect battery.
2) Open your gas cap.
3) Remove rear seat bottom by pulling up on the front edge of them and then lift the whole bench up and out. In the first pic, you can see the sliver tab on the driver side where it was holding the seat in. Just lift at that spot and it will pop off.
4) Lets start with the passenger side.


5) Lift the rubber grommet that seals everything up.



6) Now lift the big rubber flap covering the access panel. Remove the 4 nuts holding the plate in place.


7) Unplug the electrical harness. It's a sliding lock harness.

8) FIRST (1 on the pic), remove the hose clamp. This thing was annoying so I shoved a small flathead in the loop, pried it loose, and used a needle nose plier and just ripped it off. SOME gas will spill from this hose, so be ready with towels. I shoved a big bolt in the hose to keep it plugged while I worked. Replace the old hose clamp later with a standard, flathead-screw-closing hose clamp.
9) SECOND, (2) remove the ring that secures the fuel sending unit in place. To do this, place a flathead screwdriver on the raised ridge on the ring, and if you want, have a buddy do the same thing on the opposite side, and at the same time, both tap the screwdrivers with a small hammer. It will take a few good whacks to get this sucker loose. It only takes about half a turn to get this ring off. Turn in COUNTER CLOCKWISE direction to remove.


10) Once the ring is off, you will have to give the unit a good pull, but it will pop off. Stand by with a bucket to put this in as it's covered in gas.



There will be a rubber gasket that comes off. Replace it with the one that comes with your new pump.

11) Put the rubber gasket in place first. Then slide the new fuel unit in place. Push it in so it's all sealed and in tight. Replace the ring to seal it and hammer it back in place, opposite of how you took it off.


12) Re-connect the hose using a new hose clamp.
13) Re-connect the electrical plug.
14) Put the plate back, bolt it back up
15) Put the rubber flap back.
16) Put the rubber grommet back.
17) DONE. Move on to the other side. Drink a beer here. DON'T SMOKE anywhere near by.

OTHER SIDE (Driver's side)
Basically, everything is the same EXCEPT there is a connector on the bottom side of the unit that you have to pry off the old one and plug into the new one. Here are the pictures:
1)

2)

3)

4)

5)

6)

7) OK, here is the part that was connected to the UNDER side of the sending unit. You have to pry it off (one push tab connector and then used a flat head to pry it off. It's one piece)


8) Here's the new unit installed. Re-install the electric harness, the hose to the connector with a new hose clamp again, and finally the ring to secure everything.


9) Put the black top back and bolt it down, cover it all back up, put your seat back in place and you're done! Don't forget to put your fuel cap back on, re-connect your battery, and make sure everything is all cleaned up.

10) Time for a test drive!

Just so everyone knows, ALL of the symptoms I listed at the beginning of this post are now gone in my car. No more rough/dying idle, no more sputtering, just a smooth power band, and finally, I drove the car to 15 miles to empty and it was still running fine! I have not run it down to zero yet, but I'm just happy the way it is.

Thanks and good luck everyone.

-Toby.
__________________
EUROPROJEKTZ - Director, NorCal Chapter

Last edited by TKC; 07-16-2008 at 05:31 PM.
TKC is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 07-16-2008, 05:42 PM   #2
Arrows
Registered User
 
Join Date: May 2006
Location: Santa Clara, CA
Posts: 42,099
My Ride: 2000 323i.
Send a message via AIM to Arrows Send a message via MSN to Arrows
your on a role today. ill need to do this soon
__________________
Arrows is offline   Reply With Quote
Old 07-16-2008, 05:43 PM   #3
prznskillz
Registered User
 
Join Date: Nov 2007
Location: Los Angeles/CSUN
Posts: 439
My Ride: 2001 JetBlack 330ci
Send a message via AIM to prznskillz
nice writeup!

how long did it take? how much? any special tools?
prznskillz is offline   Reply With Quote
Old 07-16-2008, 06:06 PM   #4
TKC
Registered User
 
Join Date: Nov 2005
Location: San Jose, CA & Dallas, TX
Posts: 20,233
My Ride: 330cic & R6
Send a message via AIM to TKC
Took about 45 minutes for the first side just cause I had no idea how to get that ring off. After that, the other side took no more thank half hour.

No special tools required. Screwdrivers, hammer, socket set....that's about it.

Good luck!
__________________
EUROPROJEKTZ - Director, NorCal Chapter
TKC is offline   Reply With Quote
Old 07-16-2008, 06:13 PM   #5
FRANCO
Masterdebator
 
Join Date: Jul 2002
Location: Southern California
Posts: 1,605
My Ride: Your Mom
hey, thanks for telling me about this DIY...My symptoms are exactly what your car was going through.

How much are all the parts?
__________________

Mods:p46 6000K Headlights,M3 Steering Wheel,LED Taillights,M Footrest,Smoked Turn Signals,Smoked Sidemarkers,MTech II kit,CS Splitters,Gray Instrument Panel, Red Marker DIY,Ion Yellow Foglights/High Beams,Akebono Brake Pads, Smart Chrome/Leather Gear Selector,18" Staggered CSLs

Future Mods:,H&R Sport Springs,Tint,ECIS Intake,M Lip Spoiler,OEM Aluminum Pedal Set,OEM M3 Mirrors
FRANCO is offline   Reply With Quote
Old 07-16-2008, 06:20 PM   #6
TKC
Registered User
 
Join Date: Nov 2005
Location: San Jose, CA & Dallas, TX
Posts: 20,233
My Ride: 330cic & R6
Send a message via AIM to TKC
Quote:
Originally Posted by FRANCO View Post
hey, thanks for telling me about this DIY...My symptoms are exactly what your car was going through.

How much are all the parts?
Glad my write up shed some light for you. I hope you get your problems resolved.

I got my parts through from a friend in high places..... So I'm not sure how much the parts will run you. Hope it's not too bad!
__________________
EUROPROJEKTZ - Director, NorCal Chapter
TKC is offline   Reply With Quote
Old 08-02-2008, 06:40 PM   #7
Twin_Guns18
Registered User
 
Join Date: Apr 2007
Location: Orange County
Posts: 185
My Ride: 2000 328i
Ok so you replaced...

Fuel Filter. Part # 13 32 1 740 985 KAYSER
Fuel Tank Sending Unit Left Side. Part # 16 11 6 768 788
Fuel Tank Suction Device Right with Main Fuel Pump and Level Sensor. Part# : 16 14 6 766 942

Did you use any o rings or additional seals?
Twin_Guns18 is offline   Reply With Quote
Old 08-02-2008, 06:41 PM   #8
TKC
Registered User
 
Join Date: Nov 2005
Location: San Jose, CA & Dallas, TX
Posts: 20,233
My Ride: 330cic & R6
Send a message via AIM to TKC
Nope, there is only really 1 gasket per side and they could have been re-used, but regardless, the new units came with the o-rings.
__________________
EUROPROJEKTZ - Director, NorCal Chapter
TKC is offline   Reply With Quote
Old 08-02-2008, 06:44 PM   #9
Twin_Guns18
Registered User
 
Join Date: Apr 2007
Location: Orange County
Posts: 185
My Ride: 2000 328i
Quote:
Originally Posted by TKC View Post
Nope, there is only really 1 gasket per side and they could have been re-used, but regardless, the new units came with the o-rings.
So then the list I have is what you used? Around 350 in parts?
Twin_Guns18 is offline   Reply With Quote
Old 08-02-2008, 06:52 PM   #10
TKC
Registered User
 
Join Date: Nov 2005
Location: San Jose, CA & Dallas, TX
Posts: 20,233
My Ride: 330cic & R6
Send a message via AIM to TKC
And some new hose clamps. Yep, that would do it.

Price I'm not sure about....I got a hook up on them so not sure what retail is.
__________________
EUROPROJEKTZ - Director, NorCal Chapter
TKC is offline   Reply With Quote
Old 08-02-2008, 06:52 PM   #11
Snik
OEM ///Member
 
Snik's Avatar
 
Join Date: Dec 2007
Location: Around SJ AFB, NC
Posts: 20,774
My Ride: IR M3 Vert.
My diagnostic thingy gives a error from the sender unit ocassionally, and until I cleared it I was having crappy gas mileage, and while I was in neutral idling, I'd watch my avg mpg drop.
So far its been ok. I don't have the stalling issue. I think I might just replace the sender one of these days.

Great write up. Good pics. This should be added to the DIY collection thread for sure. As a lot of early E46s have this problem.
__________________
Quote:
Originally Posted by rohde88 View Post
^^^ do you spend all your free time on two wheels?
______________________________________
The Snikster posted sexy wiminz here
Do you ride a sportbike?
Do you have a question about Jamaica? Ask?
Snik is offline   Reply With Quote
Old 08-02-2008, 07:49 PM   #12
petscan
Registered User
 
Join Date: Jan 2008
Location: Oklahoma
Posts: 49
My Ride: all over
was the fuel filter in there somewhere? if so at what step or is it all one piece?
petscan is offline   Reply With Quote
Old 08-02-2008, 08:47 PM   #13
Twin_Guns18
Registered User
 
Join Date: Apr 2007
Location: Orange County
Posts: 185
My Ride: 2000 328i
Quote:
Originally Posted by petscan View Post
was the fuel filter in there somewhere? if so at what step or is it all one piece?
Fuel filter is under the car. He did not provide pictures for those steps
Twin_Guns18 is offline   Reply With Quote
Old 08-03-2008, 09:45 AM   #14
petscan
Registered User
 
Join Date: Jan 2008
Location: Oklahoma
Posts: 49
My Ride: all over
ok i read all the steps and thought is it me or am i just missing it. was thinking of changing mine out but did a search and didnt find a diy on it
petscan is offline   Reply With Quote
Old 08-08-2008, 01:45 PM   #15
TKC
Registered User
 
Join Date: Nov 2005
Location: San Jose, CA & Dallas, TX
Posts: 20,233
My Ride: 330cic & R6
Send a message via AIM to TKC
Quote:
Originally Posted by petscan View Post
was the fuel filter in there somewhere? if so at what step or is it all one piece?
Quote:
Originally Posted by Twin_Guns18 View Post
Fuel filter is under the car. He did not provide pictures for those steps
Quote:
Originally Posted by petscan View Post
ok i read all the steps and thought is it me or am i just missing it. was thinking of changing mine out but did a search and didnt find a diy on it
I left out the fuel filter replacement steps because there's already tons of DIY's on how to do it.

Here's one to help save you time. Good luck!

http://bimmerinfo.com/diy/fuel-filter/
__________________
EUROPROJEKTZ - Director, NorCal Chapter
TKC is offline   Reply With Quote
Old 08-16-2008, 01:25 AM   #16
Twin_Guns18
Registered User
 
Join Date: Apr 2007
Location: Orange County
Posts: 185
My Ride: 2000 328i
Ordered parts tonight. Going to be doing this. My baby has been giving me some hicups below 1/4 tank
Twin_Guns18 is offline   Reply With Quote
Old 08-16-2008, 04:31 AM   #17
SL Blak Soldier
Registered User
 
Join Date: Oct 2006
Location: Woodland Hills < SFV < LA < SoCal
Posts: 27,359
My Ride: 3 Pedal SG S54B32
Send a message via AIM to SL Blak Soldier
Quote:
Originally Posted by Twin_Guns18 View Post
Ordered parts tonight. Going to be doing this. My baby has been giving me some hicups below 1/4 tank
a quick tip when putting the unit back, put the gasket in first then drop down the sending unit/pump in, otherwise it won't go in.
__________________
SL Blak Soldier is offline   Reply With Quote
Old 08-16-2008, 12:25 PM   #18
Twin_Guns18
Registered User
 
Join Date: Apr 2007
Location: Orange County
Posts: 185
My Ride: 2000 328i
Quote:
Originally Posted by SL Blak Soldier View Post
a quick tip when putting the unit back, put the gasket in first then drop down the sending unit/pump in, otherwise it won't go in.
Thank you.

What should I do to precaution against fires or explosion? I heard people grounding themselves, using concrete tools, etc? Can you please explain.
Twin_Guns18 is offline   Reply With Quote
Old 09-02-2008, 07:34 PM   #19
emg2919
Registered User
 
Join Date: Aug 2007
Location: florida
Posts: 96
My Ride: 2001 BMW 330ci
so is this the fuel pump I assume? I just see fuel sending unit but I didnt see him mention or say fuel pump. Is this what hes talking about?
emg2919 is offline   Reply With Quote
Old 09-05-2008, 05:36 PM   #20
chachi328CI
Registered User
 
Join Date: May 2004
Location: Hartford, CT
Posts: 144
My Ride: 2000 328CI
Send a message via AIM to chachi328CI
Thanks!!

Great write up...piece a cake! 30 minutes - metal retainers a bitc*!
chachi328CI is offline   Reply With Quote
Reply

Tags
diy, fuel pump

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 12:27 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use