E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Suspension & Braking Forum by BimmerWorld

Suspension & Braking Forum by BimmerWorld
Have some questions about suspension or brake setups for your E46 BMW? Get all your answers here!
Sponsored by BimmerWorld

 
 
Thread Tools Search this Thread Rate Thread Display Modes
Prev Previous Post   Next Post Next
Old 10-09-2008, 07:18 AM   #1
Titanium 325
Registered User
 
Join Date: Jul 2007
Location: N. Dallas
Posts: 1,521
My Ride: '01 325Ci
19's rubbing in front on stock sport suspension....

First off I have searched and still cannot find what I am looking for here, so bear with me.

Ok, I just put 19" Miro M6 reps on my car with 235 35 19 fronts and 265 30 19 rears. I am rubbing more often in the front then the rear. I have a wheel well gap with the stock sport suspension, so I am perpelexed as to why it is rubbing.

I do not see any scars on the sides of the tire and I think it must be hitting on the splash guards or something.

Any of you with lowred cars on 19s have this issue? If so, how did you address it? I am afraid to drop the car if I am rubbing now. The offsets are correct for my car, I double checked them before I orderd the wheels. so I don't think it is that.

Please let me know your thoughts. It is only rubbing when the suspension is under load (cornering at speed and some dips) and not when parking or anything like that. It is very odd. It does not rubb all the time, so I am assuming I am hitting the splash guard on the fronts somewhere.

Thoughts? Here are a couple of pics to show that it is not slammed or even all that close to touching. Very odd.

Will have to take a more striaght side shot, but you can still see the wheel gap. The offset is E46 specific and is what the various vendors are carrying. Any thoughts on this issue are apprecaited.

Thanks.

__________________

Mods - M3 Style Lip Spoiler, ACS Replica Roof Spoiler (bowed in the middle), Predator Chromium Angel Eyes, P46 Xenons, Smoked Side, Corners and LED Tails, Blacked out Kidney Grills, Self Painted Bumper Reflectors, K&N Drop-in Filter, 19" Miro M6 Reps in Time Attack

Titanium 325 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
 

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 11:10 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use