E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Forced Induction Forum Sponsored by Active Autowerke

Forced Induction Forum Sponsored by Active Autowerke
Discuss supercharging, turbocharging and even nitrous and water injection here.
Sponsored by Active Autowerke

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 12-16-2008, 02:58 PM   #1
ArmyAV8R
Registered User
 
Join Date: Oct 2005
Location: Colorado Springs
Posts: 20
My Ride: 02 M3 Topaz Blue
Amazing customer service from VF Engineering

I don't typically post here (most of my posting has been done on M3forum) however I wanted to take a few minutes to publicly thank the guys at VF. Roughly a month ago I undertook the project of installing a VF stage 1 kit on my E46 M3. The install went fine but I ended up with some severe idle problems and numerous check engine lights. Over the past month Nik and Sean have been working diligently to help me straighten out my issues. Eventually it was discovered that I had the following problems:
1. My O2 sensor wiring had been spliced and had to be replaced
2. My MAF was bad and had to be replaced
3. My air straightening screen was not installed
4. My lower O2 sensors were reversed (Cyl 1-3 was reading on 4-6, etc...)

Throughout the entire troubleshooting period VF was there for me. I was calling from Germany and Nik even let me call him on weekends and at odd hours. (Sorry about calling on thanksgiving Nik) Whatever the case, every time I was asked to check something it yielded results.

So, long story short, I finally got the kinks all worked out and the car runs like a champ. The customer service at VF is second to none.
ArmyAV8R is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 12-16-2008, 03:04 PM   #2
MachRc
E46Fanatic
 
MachRc's Avatar
 
Join Date: Sep 2002
Location: City of Angels
Posts: 6,471
My Ride: 2003 Technik S1 M3
number 4. happens all the time and puts the car in check, im glad you got your car sorted out!!!
__________________

"We've come a long long way together, through the hard times and the good. I have to celebrate you baby, I have to praise you like I should...
I have to praise you like I should.."
MachRc is offline   Reply With Quote
Old 12-17-2008, 01:08 AM   #3
ArmyAV8R
Registered User
 
Join Date: Oct 2005
Location: Colorado Springs
Posts: 20
My Ride: 02 M3 Topaz Blue
Thanks for the kind words.
ArmyAV8R is offline   Reply With Quote
Old 12-18-2008, 02:40 AM   #4
//ModMaster
Registered User
 
Join Date: Jun 2006
Location: Jerusalem
Posts: 328
My Ride: E46 330ci & E36 328i
Do u think the removal of the air straightening screen caused the idle problems ? cus i had mine removed and my rpm's drop to 400-500 sometimes when i come to a stop . u think i should put it back ?
__________________
//ModMaster is offline   Reply With Quote
Old 12-18-2008, 11:39 AM   #5
ArmyAV8R
Registered User
 
Join Date: Oct 2005
Location: Colorado Springs
Posts: 20
My Ride: 02 M3 Topaz Blue
I was experiencing the same problems when I didn't have it installed. So I would say yes, put it back in, however I should caveat that by saying that I had several problems and they were all probably contributing factors.
ArmyAV8R is offline   Reply With Quote
Old 12-20-2008, 12:23 AM   #6
//ModMaster
Registered User
 
Join Date: Jun 2006
Location: Jerusalem
Posts: 328
My Ride: E46 330ci & E36 328i
Thanks, i guess ill put it back.

btw a friend of mine just finished installing a stage 2 on his M3 , when they installed his s/c they did a mistake with the o2 sensors im not sure what exactly but he had to replace the wiring harness and the four o2 sensors and temp sensor as a result. the mistake cost him around 3000$ in parts only (parts are very expensive here) . i felt bad for him cus im the reason he bought the s/c but anyway his car is fine now and one of the fastest in the country. Enjoy yours.
__________________
//ModMaster is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 04:04 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use