E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Bavarian Soundwerks' Mobile Electronics Forum

Bavarian Soundwerks' Mobile Electronics Forum
Have all your A/V and electronics questions answered here. Ipods, A/V, Radar Detectors Oh My!
Sponsored by Bavarian Soundwerks

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 07-19-2003, 12:27 PM   #1
JPrieur
Registered User
 
Join Date: Dec 1969
Location: Virginia Beach, VA
Posts: 45
My Ride: '02 330Ci
Send a message via AIM to JPrieur
overheating a/d/s amp

I have an a/d/s p850.2 amp that overheats quite frequently, and even shuts off sometimes after 30 min or so of listening at moderate volumes. Does anyone have any thoughts as to the cause or how to illeviate this?
I was wondering since I am still running the stock rear speakers which have a 3 ohm impedence, could this be the cause?

current set up:
330Ci stock HU
345is up front
stock rear deck 6.5" (HK)
kicker 6x9 rear (8ohm speakers, wired in parallel for 4 ohm to amp)
JPrieur is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 07-19-2003, 12:36 PM   #2
daz
Registered User
 
Join Date: Mar 2003
Location: Japan
Posts: 482
My Ride: 2003 Bmw Coupe 330ci
Send a message via AIM to daz
Where and how did you mount your AMP?
__________________
daz is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 05:51 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use