E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Lighting Forum

Lighting Forum
Angel Eyes, DDEs, lighted rings, Clear Turn Signals, LEDs, Xenon, HID, or Bi-Xenon. If it lights up and you want to discuss it, post here!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 02-05-2009, 01:32 PM   #1
Riverbmr3
Registered User
 
Join Date: May 2004
Location: H-town
Posts: 4,012
My Ride: slow 3
Turn signal burned

Hi fanatics,
i installed my depo clear signal light with solaris bulbs for my sedan, after a week, i noticed my inner part of the signal lens closed to the bulb is burned (driver's side), my solaris bulb is working and is seated correctly since it is 180 degrees. what do you think is the problem? did the same thing happened to anyone here? feedbacks or comments will be appreciated. by the way, i called the sponsor, they said it is not replaceable because it is not a leaking problem or whatsoever, so burning is not included in the warranty i guess.
Riverbmr3 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 02-05-2009, 01:36 PM   #2
Riverbmr3
Registered User
 
Join Date: May 2004
Location: H-town
Posts: 4,012
My Ride: slow 3
picture of the burned signal light
Attached Thumbnails
Click image for larger version

Name:	clear signal 1.jpg
Views:	43
Size:	99.8 KB
ID:	301420  
Attached Images
 

Last edited by Riverbmr3; 02-05-2009 at 03:43 PM.
Riverbmr3 is offline   Reply With Quote
Old 02-06-2009, 09:49 AM   #3
Riverbmr3
Registered User
 
Join Date: May 2004
Location: H-town
Posts: 4,012
My Ride: slow 3
looks like nobody experienced the same..
Riverbmr3 is offline   Reply With Quote
Old 02-09-2009, 03:21 PM   #4
djbradle
Registered User
 
Join Date: Dec 2008
Location: Central Ma
Posts: 338
My Ride: 2002 325 xit
Happened to my stock passenger clear but that was the previous owner's problem passed on to me. I assume they did not install it correctly but i can;t be sure. It looked exactly the same as your depo though. I does have moisture because of it now.
djbradle is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 02:59 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use