E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Driveline, Engine & DME Tuning

Driveline, Engine & DME Tuning
Talk about driveline improvements, NA tuning and DME tuning your E46 BMW here. This includes diffs, intakes, exhausts, chips, software and OBD tuning.

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 03-21-2009, 02:59 PM   #1
Acaminero
Registered User
 
Join Date: Mar 2009
Location: Domincan republic
Posts: 4
My Ride: 1999 323i
hesitation on my 1999 323i

Hi guys...I am new to the site and looking for some help on my problem...
have a 323i that runs very good on cold, but after a few minutes of driving, it starts hesitating on take off, like if there is no enough gas beein delivered.
I look at sparks plugs, new gas pump, neww filters, check vacumm hose, ....and still can get to the problem..
any idea where to look for...oh..no gas line are clugged.

iamgine there must be a fuel pressure regulator...but have no idea where it is or if should in other areas...
please can help me out on this...
thanks.
Acaminero is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 03-22-2009, 09:58 PM   #2
Dstn8r
Registered User
 
Join Date: Sep 2005
Location: TAMPA
Posts: 696
My Ride: RIP E46 330Ci
Send a message via AIM to Dstn8r Send a message via MSN to Dstn8r
I had the same problem.......result My cats were clogged and ended up getting ebay headers...it solved the problem and also was a plus because it added some HP......
mine started fine but after a while it fel like you said "as if it got no gas" and its kinda jumped and it took for ever to pick up speed.
D
__________________
Dstn8r is offline   Reply With Quote
Old 03-27-2009, 06:46 PM   #3
Acaminero
Registered User
 
Join Date: Mar 2009
Location: Domincan republic
Posts: 4
My Ride: 1999 323i
Hey, thanks for your reply, I 'l check the cats, also had a scan and is giving me the air flow mass sensor
will check tomorrow see what happens.
Acaminero is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Censor is OFF





All times are GMT -5. The time now is 12:02 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use