E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Bavarian Soundwerks' Mobile Electronics Forum

Bavarian Soundwerks' Mobile Electronics Forum
Have all your A/V and electronics questions answered here. Ipods, A/V, Radar Detectors Oh My!
Sponsored by Bavarian Soundwerks

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 04-20-2009, 08:50 PM   #1
mut2140
Registered User
 
Join Date: Mar 2009
Location: Milwaukee, WI, USA
Posts: 6
My Ride: 2000 BMW 328i
Radia/amp draining battery when car is asleep - please help

Hello,
I am a new owner of a 2000 model 328i. This is my first BMW ever, and I simply love it. I have a little problem with the vehicle and I am trying to troubleshoot; I would love your help with that.

Whenever I turn on the radio or the cassette player I hear a momentary noise as if a capacitor is charging/discharging or something. After the noise the radio plays just fine until I turn off the radio. I hear the same momentary noise when the radio turned off. The noise is heard in all the speakers, so I suspected something wrong with the radio/amplifier system.

On top of that when the car is asleep (i.e. after 15 min of turning off everything and locking the car) there should be only 20mA current draw from the battery. But I measured that it takes almost 400mA from the battery in sleep mode. As a result if I donot use the vehicle even for a day the battery goes dead and I have to jump start it. So I pulled the fuses and determined that fuse #41 (radio amplifier circuit) is the culprit. Then I pulled the amplifier from the trunk to check whether there is anything wrong with the amplifier. My father-in-law who is an electrical engineer found that there is nothing wrong with the amplifier. He also found that there is full voltage (about 10v) at the amplifier even when the radio is turned off. Ideally there should not be any voltage at the amplifier when the radio is off. So he is thinking that there is something upstream that is causing this.
1. did anyone of you had any problem like this?
2. Personally, I am suspecting the radio head unit. I am suspecting that it is providing the power (or the signal to turn on the power) to the amplifier when the radio is off. I am planning to buy a cheap replacement unit and try it.
3. Are you aware of any thing other than the radio head unit that might provide power to the amplifier.. I am imagining some kind of control circuit outside of the head unit here...
4. Do you have any other suggestions on how I can troubleshoot the problem?

thank you very much for your help,
Bal
mut2140 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 04-20-2009, 10:34 PM   #2
albarran9
Registered User
 
Join Date: Feb 2008
Location: Arkansas
Posts: 404
My Ride: E46, E53, E90
hmmm. I'm no expert in this field, but I would suspect a couple of things. Are you using the stock speakers and amp? I would start by checking the alternator. second I'd see if I could go to autozone or the dealership to see if it has stored any codes.
albarran9 is offline   Reply With Quote
Old 04-21-2009, 06:15 AM   #3
mut2140
Registered User
 
Join Date: Mar 2009
Location: Milwaukee, WI, USA
Posts: 6
My Ride: 2000 BMW 328i
Thank you Albarran9. Yes I have stock speakers and amp. I have an OBDII reader; I will check for any stored codes.
mut2140 is offline   Reply With Quote
Old 05-10-2009, 10:43 AM   #4
mut2140
Registered User
 
Join Date: Mar 2009
Location: Milwaukee, WI, USA
Posts: 6
My Ride: 2000 BMW 328i
Issue resolved

Figured out the problem.. It was the radio head unit. I got a used one for $35 in ebay, installed it and the battery drain issue is gone. thanks
mut2140 is offline   Reply With Quote
Reply

Tags
fuse 41 battery drain

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 05:25 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use