E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Bavarian Soundwerks' Mobile Electronics Forum

Bavarian Soundwerks' Mobile Electronics Forum
Have all your A/V and electronics questions answered here. Ipods, A/V, Radar Detectors Oh My!
Sponsored by Bavarian Soundwerks

 
 
Thread Tools Search this Thread Rate Thread Display Modes
Prev Previous Post   Next Post Next
Old 04-29-2009, 05:00 PM   #1
chris98891
Registered User
 
Join Date: Mar 2007
Location: greenville, sc
Posts: 1,718
My Ride: '01 325i
Send a message via AIM to chris98891
For anybody on the fence re the V1

definitely dont let their customer service hold you back. i got my unit a couple months ago to replace my rx65 (speaking of which, reception is no better, you just get the arrows), and i couldn't get it to switch modes.

i figured it was something i was doing wrong so today i finally decided to read up on it, and it says it may be caused by a faulty power cord. well i switch around all my cords, no help. switch cards, no help. call around 3:30, phone picked up by a PERSON within 2 rings. shes knows exactly what shes talking about and helps me troubleshoot.

she finds out there is something wrong with the unit, double checks with a technician, and tells me to ship it out asap, she has a file set up under my name (no rma, personalized enough to use a name) and address. she also said don't worry about shipping, for me just to call after they get it and they'll refund whatever the shipping cost is to my card. they'll also fix it the day they get it and have it shipped out by the time ups gets there.

now THAT is customer service.

i shall add them to my list of great CS:
BSW
Bimmerworld
Valentine Reasearch
Elemental Designs
Sony
Tischer/getbmwparts

no other sponsors have been worth mentioning in my cases
__________________
-Chris





Last edited by chris98891; 04-29-2009 at 05:03 PM.
chris98891 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
 

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 10:18 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use