E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Bavarian Soundwerks' Mobile Electronics Forum

Bavarian Soundwerks' Mobile Electronics Forum
Have all your A/V and electronics questions answered here. Ipods, A/V, Radar Detectors Oh My!
Sponsored by Bavarian Soundwerks

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 05-01-2009, 03:25 PM   #1
HateTheSnow
Registered User
 
Join Date: Apr 2009
Location: Houston, TX
Posts: 53
My Ride: '02 330ci Vert
BSW problems + no customer service = help please

After 2 days of calling BSW and never getting through, I thought I could post my problems on here and hopefully get a response. Just finished installing the Stage 1 upgrade and am about to move on to the Subwoofer install, and everything has been very easy and straightforward so far except two things:

1. When installing the rear midbass drivers, the speakers didn't seem to fit right. Since the magnet on the BSW speakers are much bigger, there was no clearance between the rear face of the magnet and the bare metal of (the inside of) my rear fender. Therefore, when I put the speaker in, the magnet sticks to the fender and there is a very slight clearance between the speaker mounting holes and the corresponding holes in the body. I am afraid to tighten down the screws at all because it seems like this would put a lot of stress on the speaker baffles.

2. When I first picked up the amplifier that was included in the BSW subwoofer system (Rockford Fosgate Punch P200-2) there was a rattling noise, like something was loose inside...not like something was rolling around, but if I turn it over there is definite movement. I'm assuming thats bad? I haven't taken it out of the plastic yet in case I have to return it, but if I don't get a response soon enough I'm just going to hook it up and test it out.
__________________
HateTheSnow is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 05-02-2009, 03:33 AM   #2
///Flash
Banned
 
Join Date: Dec 2008
Location: Elizabeth Town, KY
Posts: 336
My Ride: a donkey
You got PM
///Flash is offline   Reply With Quote
Old 05-02-2009, 09:26 AM   #3
HateTheSnow
Registered User
 
Join Date: Apr 2009
Location: Houston, TX
Posts: 53
My Ride: '02 330ci Vert
Ok, figured out the amplifier was not broken, it was just the wire mounting locations that rattled until I tightened them down. Still looking for help on the first problem... anyone?
__________________
HateTheSnow is offline   Reply With Quote
Old 05-03-2009, 06:25 AM   #4
dido
Registered User
 
Join Date: Dec 2005
Location: United Arab Emirates
Posts: 109
My Ride: E46 318i 2004
for the 1st problem, i faced the same but i tighten the screws and its works without any damages to the speackers baffles. but i still not complete the installation coz i need the crossover for the rest of the speackers since my system not HK.

good luck with the sound
__________________
dido is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 02:54 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use