Steering hard to turn - E46Fanatics E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > The Tire Rack's Tire & Wheel Forum

The Tire Rack's Tire & Wheel Forum
Use this forum to discuss anything in relation to wheels to tires to offsets.
Sponsored by The Tire Rack

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 07-06-2017, 03:38 PM   #1
SiVaE46
Registered User
 
Join Date: Dec 2012
Location: Silicon Valley
Posts: 152
My Ride: 2003 325i
Steering hard to turn

I replaced all belts and pulleys on my 325i - noticed the ps pulley had some play - and am getting a lot of "rattle" from the front of engine when idle.

Screw driver test on pump showed a lot of noise coming from that area - so I replaced the pump with a Napa remanufactured one.

That also has a similar play on the pulley (I pulled a pump from a '99 in the junk yard and it had no play - but does not fit my '03).

Anyway rattle is still there - I think vanos now - but after I refilled pump reservoir and bled (turned lock to lock a few times with cap off) - I get a slight hum from pump when turning the wheel at parking speeds and sometimes the steering is very heavy at park speeds.

Fluid level with BMW ATF is good. Old fluid came out red - and looked fine. Put in redline d4 atf to

Above 10 mph steering is fine (and feels tighter than the old pump - in a good way)

Do I have a bad pump or should I check something else ?
SiVaE46 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 06:03 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
(c) 1999 - VerticalScope Inc. All rights reserved.