E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 07-25-2012, 06:23 PM   #1
napaxcon
Registered User
 
Join Date: Jun 2011
Location: ri
Posts: 66
My Ride: 02 325i
02 325i traction control off and "brake" light on...

SoMy traction control shut itself off and my brake light came on, the one that says "BRAKE", it is illuminated yellow along with the triangle with a !. I didnt know what these ment so i looked around and found some sugestions. So i went to go clean my speed sensors and found out my control arms needed replacement. One of the ball joints was ripping right out of the arm and there was alot of play . So i change one of them 2 days ago and the lights went off. But i changed the other one yesterday and the lights came back on... i dont know what the deal it. i just noticed about 5min ago that when i turn my wheels all the way to the right then start to turn back there is a popping sound. ? also i believe when i had the key in position 2 with the engine off i could turn my wheels but now i cant . it is very tight and feels like ill brake something if i force it. It feels fine driving but im stumped with the lights being back on, the poppin sound and the wheels not turning in position 2. Any sugestions ????
napaxcon is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 07-25-2012, 10:20 PM   #2
zhenkaaaM3
Registered User
 
Join Date: Feb 2011
Location: New york
Posts: 5,868
My Ride: Fst'r then your e46
Theres no way you can turn the wheel smoothly without force in key position 2. Power steering pump works only when the car is started.
zhenkaaaM3 is offline   Reply With Quote
Old 07-25-2012, 11:43 PM   #3
napaxcon
Registered User
 
Join Date: Jun 2011
Location: ri
Posts: 66
My Ride: 02 325i
Ya , well I was turning them when I had my car jacked up on one side and it turned fine without the car being on, maybe cause the was no weight but yet the side that wasn't jacked up tturne too, I dunno, don't really car about that its just annoying I can't remember
napaxcon is offline   Reply With Quote
Reply

Tags
control arms, e46, sound, steering

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 10:24 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
(c) 1999 - 2016 performanceIX Inc - privacy policy - terms of use