E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 10-25-2014, 05:11 PM   #1
BMW Speeder
Registered User
 
Join Date: Sep 2014
Location: Saint Augustine, Fl
Posts: 6
My Ride: 2001 330ci
Exclamation Odd sounds, car acting up. Help!:[

So I just recently bought my 2001 330ci used with 118,000 miles on it. For the first few months it has been running awesome and I've been very happy. Up until this morning when I got in my car to drive home from work. I started my car and it began to thump terribly, putting out little to no RPM's at idle. I had to put gas to it so that it wouldn't shut off. I popped it in reverse and the thumping got worse. I then decided to park and let it warm up a little more and it didn't help. I got it out of the parking lot and it started to thump more, not shifting correctly and not wanting to leave gears until red line. [Automatic Car]. A week before today a deafening squeaky noise has been coming from what I believe to be the fan, idle pulley or the idle tensioner. I am not sure what to do.. Anyone have any suggestions? Thanks guys/gals!!!!

Last edited by BMW Speeder; 10-25-2014 at 05:13 PM. Reason: Grammar
BMW Speeder is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 10-25-2014, 05:44 PM   #2
jdstrickland
Registered User
 
Join Date: Apr 2010
Location: Murrieta, CA
Posts: 9,223
My Ride: '94 325iC & '00 323i
When you say stuff like, I believe to be the fan, my instinct is that you do not own the tools or equipment needed to affect the repairs.

You are having troubles that require you to do some deeper diagnostic work and then give us more details. There should be some lights on on the instrument panel, you need to describe them to us. If one of the lights says SERVICE ENGINE SOON, then you need to pull codes and tell us which ones come up.
jdstrickland is offline   Reply With Quote
Old 10-25-2014, 05:45 PM   #3
lszlszx
Registered User
 
Join Date: Jan 2013
Location: Socal
Posts: 5,345
My Ride: 1.8T, XC70
Post a video, otherwise it's anyone's guess.
__________________


GM No Reverse - posts 427, 439

"Would the codes indicate if it's the carburator?"
lszlszx is offline   Reply With Quote
Old 10-25-2014, 05:51 PM   #4
BMW Speeder
Registered User
 
Join Date: Sep 2014
Location: Saint Augustine, Fl
Posts: 6
My Ride: 2001 330ci
Update

The only codes that come up on the reading are the secondary air flow and bank 1, bank 2 mass air flow codes. I know why those come up, one of the sensors is rewired incorrectly and it has had that problem for years. My neighbor has any tool you can possibly think of if I need to get under the car. Just let me know what to look for please!! P0171 and P0172.

Last edited by BMW Speeder; 10-25-2014 at 05:55 PM.
BMW Speeder is offline   Reply With Quote
Old 10-25-2014, 07:32 PM   #5
mbogosia
Registered User
 
Join Date: May 2004
Location: Nashville
Posts: 125
My Ride: 2001 330i
Secondary air flow might be a busted hose. Look at the hose that comes off the secondary air pump on the front left of tone engine. The hose is short and kinda has a weird bend to it. Feel around it for holes.


http://www.nextdayauto.com/auto_imag...33-1662581.jpg

Last edited by mbogosia; 10-25-2014 at 07:40 PM.
mbogosia is offline   Reply With Quote
Old 11-02-2014, 08:43 PM   #6
BMW Speeder
Registered User
 
Join Date: Sep 2014
Location: Saint Augustine, Fl
Posts: 6
My Ride: 2001 330ci
No

No holes or anything in the hose.
BMW Speeder is offline   Reply With Quote
Reply

Tags
fan, idle pulley, problem, sound, thumping

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 05:41 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
(c) 1999 - 2016 performanceIX Inc - privacy policy - terms of use