E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 03-02-2015, 05:20 PM   #1
ZeusE46
Registered User
 
Join Date: Feb 2014
Location: New York
Posts: 3
My Ride: 2003 Bmw 330CI
2003 E46 330 Lean Codes. Help!

Hi everyone,

First of all I am a newbie to these forums and I want to thank you all in advanced for any help I receive.

I have a 2003 330CI and I am getting lean codes and have a slight misfire. I have a full scanner that gives me all of the bmw codes but the only ones present are P0171 and P0174.

Now I replaced all of the vacuum lines so no vacuum leaks, the intake boots that always crack, the DISA valve, the PCV system is not bad, I have a new fuel pump and the fuel pressure is also good. I replaced the MAF and the oxygen sensors and still I keep getting the lean codes

The codes pops up within a few minutes of start up. The strange part is that when I disconnect the MAF the I no longer have a misfire and I no longer have lean codes, only the code for MAF because it is disconnected. When the MAF is connected I get a steady reading from the upstrem oxygen sensors of close to .07 V That is extremely lean When I disconnect the MAF I fluctuate between .2 to .8 which is about normal. I am stumped I don't know what to do because I've been trying fix this problem for months I need to pass inspection to renew my regi so I'm riding dirty now. Please give me some ideas. Do you think I may have an electrical issue? Thanks!
ZeusE46 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 03-02-2015, 05:51 PM   #2
firehawk
Registered User
 
Join Date: Feb 2014
Location: OC, CA
Posts: 123
My Ride: '03 325CI 5-Speed
I'd say it's either the ccv or valve cover gasket leaking. Best bet would be to do a smoke test since that will show where the vacuum leak is
firehawk is offline   Reply With Quote
Old 03-02-2015, 06:14 PM   #3
ZeusE46
Registered User
 
Join Date: Feb 2014
Location: New York
Posts: 3
My Ride: 2003 Bmw 330CI
Hey firehawk, thanks for the reply. It doesn't seem like it because it runs perfect when the MAF is unplugged. I can also feel a big difference when I unplug the top ccv hose from the valve cover, the car really begins to misfire then and the idle is really rough. I will do a smoke test and see what happens.

Last edited by ZeusE46; 03-02-2015 at 06:14 PM. Reason: 1
ZeusE46 is offline   Reply With Quote
Old 03-02-2015, 08:23 PM   #4
jfoj
OEM ///Member
 
Join Date: Nov 2009
Location: Fairfax, VA USA
Posts: 22,861
My Ride: 330CiC, M5, X5, E93
Disconnecting the MAF put the engine into an Richer fuel map that will mask or cover up a Lean condition. It is not a way to condemn a MAF.

FYI, a lower O2 Voltage is an indication of a Lean condition.

Need to see the warm idle Fuel Trim and any Freeze Frame data and EXACT OBDII trouble codes in Pxxxx format.

If you want to understand the difference between good and bad O2 sensors you should look at this - http://e46fanatics.com/forum/showpos...9&postcount=34

You need to read the first 2 links below in my signature.

Read this thread - http://forum.e46fanatics.com/showthread.php?t=1057387

Read my "BMW 20 Questions" comments in this thread - http://forum.e46fanatics.com/showthread.php?t=1059972

Search YouTube for Scotty Smoke Test. Do what Scotty does or build a tester from related video.
__________________
Solve your misfires, lean codes, rough idle - http://forum.e46fanatics.com/showthread.php?t=897616

Fuel pump failures - http://forum.e46fanatics.com/showthread.php?t=929501

Temp Info - http://forum.e46fanatics.com/showthread.php?t=964491

Hidden OBC Menu - Check Voltage, Temp, Fuel Level - http://forum.e46fanatics.com/showthread.php?t=239619

E46/E39 GM5 Door Lock Info - www.bmwgm5.com

Lower hose temp switch O-ring - BMW #13621743299
jfoj is offline   Reply With Quote
Old 03-04-2015, 10:34 AM   #5
ZeusE46
Registered User
 
Join Date: Feb 2014
Location: New York
Posts: 3
My Ride: 2003 Bmw 330CI
Thank you guys for the help. I ended up changing the MAF sensor and resetting the codes and finally, no more lean codes :banana:

I finally got my inspection and renewed my regi. I had done a smoke test and all was good so I knew it wasn't vacuum related. I am just surprised that both bad MAF sensors did not show a MAF code.

Hope this helps some people with similar issues. Thanks again!
ZeusE46 is offline   Reply With Quote
Reply

Tags
330, lean codes, m54, p0171, p0174

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 07:15 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
(c) 1999 - 2016 performanceIX Inc - privacy policy - terms of use