E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 03-20-2015, 09:10 PM   #1
Scarey1323
Registered User
 
Join Date: Mar 2015
Location: Wisconsin
Posts: 5
My Ride: 2001 325i
Help! 2001 325i m54b25 engine

So my car was leaking oil, gas was dripping under engine as well as making smell like gasoline in the cabin, so I changed the oil filter housing gasket, put a brand new fuel pump in, tried cleaning ccv and tunes connected with it, also put a new serpentine belt on just cause I was already in there, replaced the maf cause car wouldn't run when the old was plugged in. So after all was changed and put back together I tried starting car and it threw eml code and traction control. Also sputters for a few seconds with engine shake then the engine kills. Any help would be appreciated
Scarey1323 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 03-20-2015, 09:21 PM   #2
jfoj
OEM ///Member
 
Join Date: Nov 2009
Location: Fairfax, VA USA
Posts: 22,857
My Ride: 330CiC, M5, X5, E93
Suggest you put the orignal MAF back on the car for now.

Often NUBU's will connect the fuel filter wrong and there will be no fuel to the engine.

You may need to "prime" the fuel pump and purge air out of the system since you had the fuel system open. Cycling the key about 10 times to allow the pump to prime and bleed air out of the system is wise.

You may also have flood the engine if you started the engine to move the car into the garage or only for like 30 seconds. In this case you will need to hold the throttle down while cranking the engine.

See this thread - http://forum.e46fanatics.com/showthread.php?t=1069117
__________________
Solve your misfires, lean codes, rough idle - http://forum.e46fanatics.com/showthread.php?t=897616

Fuel pump failures - http://forum.e46fanatics.com/showthread.php?t=929501

Temp Info - http://forum.e46fanatics.com/showthread.php?t=964491

Hidden OBC Menu - Check Voltage, Temp, Fuel Level - http://forum.e46fanatics.com/showthread.php?t=239619

E46/E39 GM5 Door Lock Info - www.bmwgm5.com

Lower hose temp switch O-ring - BMW #13621743299
jfoj is offline   Reply With Quote
Old 03-21-2015, 11:44 AM   #3
Loaded325i
Registered User
 
Join Date: Aug 2011
Location: oregon
Posts: 491
My Ride: bmw 325i
why would you clean the ccv?? Get a vacuum gauge and connect it to the hose going into the Brake booster line. You might have a vacuum leak. Gas was leaking by the fuel rail and u changed the pump? I'm not sure where your going with your diagnosing man. Sorry.
__________________
A mechanical hobbyist and car enthusiast
1971 Datsun 240z Devil Z red
1999 740il Titanium Silver
2004 BMW 325i CW,PP and Sports Package
1996 toyota avalon-263,000-Sold
2003 Lexus Is300-Sold
2000 Acura TL-Sold
2000 Accord 5 speed-Sold
Loaded325i is offline   Reply With Quote
Old 03-23-2015, 12:34 AM   #4
Scarey1323
Registered User
 
Join Date: Mar 2015
Location: Wisconsin
Posts: 5
My Ride: 2001 325i
Sorry new to bmw's and cars in general I meant fuel filter, figured out the problem, my throttle body plate was stuck so cleaned it up got it running, only problem is as soon as I drove it down the road started steaming from coolant spewing all over engine as well as overheating, changed the expansion tank since it was leaking but still overheating and spraying coolant, ordered a new water pump hoping it will fix. Also just learned that normal coolant isn't good for these cars so if any suggestions on what brands of coolant I should be using
Scarey1323 is offline   Reply With Quote
Old 03-23-2015, 01:26 AM   #5
J_oH
Registered User
 
Join Date: Nov 2014
Location: Fullerton, CA
Posts: 13
My Ride: 2004 325ci
When it comes to your cooling system get oem. That includes coolant.

I admire your determination to fix your ride but do lots of research before tackling the job.

I'm not 100% sure but I don't think coolant would spray everywhere if the water pump was bad? I would imagine it simply wouldn't go anywhere and just overheat.

Let's hope your car wasn't in the red for long or else bye bye motor.

Good luck.
J_oH is offline   Reply With Quote
Old 03-23-2015, 01:44 AM   #6
Scarey1323
Registered User
 
Join Date: Mar 2015
Location: Wisconsin
Posts: 5
My Ride: 2001 325i
I stopped it before it hit the red, don't know what else fix. But yeah I'm trying to do my research been reading a lot. If can't get it fixed may have to take it to a shop, where I live there just isn't any good bmw mechanics or any that even will touch em
Scarey1323 is offline   Reply With Quote
Old 03-23-2015, 02:02 AM   #7
BaliDawg
Keepin' it real stock
 
Join Date: Aug 2012
Location: Riverside, CA
Posts: 5,520
My Ride: E24 E32 E46 E39 E84
How about doing a coolant pressure test when the motor is cold? As you slowly increase the pressure it should be easy to find the leak, since it won't be spraying everywhere like old faithful.

It's pretty common to do a full cooling system refresh as most of those parts have the same life span. You are lucky your overheat didn't go too far. It is really easy to overheat, blow the HG, and toast your motor.
__________________
///Mmmmmm...
BaliDawg is offline   Reply With Quote
Old 03-23-2015, 02:36 AM   #8
StealthLensTinting
Registered User
 
Join Date: Mar 2015
Location: Olympia
Posts: 22
My Ride: E46
As far as the coolant spraying and leaking everywhere and going into the red after, I had that happen awhile back, sounds like a cracked reserve tank. That's what mine turned out to be, it wouldn't hold coolant, so I couldn't drive it otherwise it'd go back into the red, hope this helps, might not be ur problem exactly but oh well.. Good luck
StealthLensTinting is offline   Reply With Quote
Old 03-23-2015, 02:49 AM   #9
Scarey1323
Registered User
 
Join Date: Mar 2015
Location: Wisconsin
Posts: 5
My Ride: 2001 325i
When you say reserve tank is that separate from the expansion tank
Scarey1323 is offline   Reply With Quote
Old 03-23-2015, 04:33 AM   #10
StealthLensTinting
Registered User
 
Join Date: Mar 2015
Location: Olympia
Posts: 22
My Ride: E46
It could be the same thing I'm not entirely sure sorry
StealthLensTinting is offline   Reply With Quote
Old 03-23-2015, 04:34 AM   #11
Scarey1323
Registered User
 
Join Date: Mar 2015
Location: Wisconsin
Posts: 5
My Ride: 2001 325i
Thx for the help guys if I get it running I'll post what it was
Scarey1323 is offline   Reply With Quote
Old 03-23-2015, 10:14 AM   #12
J_oH
Registered User
 
Join Date: Nov 2014
Location: Fullerton, CA
Posts: 13
My Ride: 2004 325ci
What I would do is make sure all hoses are tight, usually it's just a simple fix. Check for leaks before driving off.

When I changed my expansion tank, after I fired her up there was a leak. Turned out the upper house wasn't fully mounted. It took a lil more monkey strength to fully seat the hose, maybe only moved a cm or less but it did the trick.
J_oH is offline   Reply With Quote
Old 03-23-2015, 10:25 AM   #13
glhx
Registered User
 
Join Date: Jan 2012
Location: Nashville, Tennessee
Posts: 2,106
My Ride: 2002 330ci
Would change put the serpentine pulleys as well. They usually last 120k
How good is the vacuum line from the back of the intake to the fuel filter.
glhx is offline   Reply With Quote
Reply

Tags
ccv, eml, m54, maf

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 10:23 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
(c) 1999 - 2016 performanceIX Inc - privacy policy - terms of use