Strange issue Help! - E46Fanatics E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 10-14-2016, 05:10 AM   #1
Aloofmind
Registered User
 
Join Date: Oct 2016
Location: South Carolina
Posts: 6
My Ride: 2003 325i
Strange issue Help!

Hello, I am new to the forum and wondered if anyone has ever had this issue before. I have a 2003 BMW 325i that I bought 3 months ago. Everything is in working order as far as I know. I have an issue where when I have the car off and no key in the ignition. The interior lights, exterior lights. And dash lights will come on at random. I can also hear the fuel pump Come on at times. This is totally random, and everything works fine when the car is on. Its like I have put the key in the ignition and turned it to the on position. It does this every day/night . I have no idea what it is?
Aloofmind is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 10-14-2016, 06:06 AM   #2
e46_txi
Registered User
 
Join Date: Oct 2016
Location: Ger
Posts: 29
My Ride: E46 330
Is your car equipped with an anti theft system? Did you read failure codes? Are you sure with the fuel pump? Check the EWS (immobilizer). You got a pre-heater installed?
e46_txi is offline   Reply With Quote
Old 10-14-2016, 06:12 AM   #3
Aloofmind
Registered User
 
Join Date: Oct 2016
Location: South Carolina
Posts: 6
My Ride: 2003 325i
Quote:
Originally Posted by e46_txi View Post
Is your car equipped with an anti theft system? Did you read failure codes? Are you sure with the fuel pump? Check the EWS (immobilizer). You got a pre-heater installed?
The car doesn't have a preheater. I am wired for a anti theft system but as far as I know it isn't installed. The sound is coming from. The back of the car so I'm assuming fuel pump priming. I'll have to check the EWS.

the only code I get is p0456 I haven't had the chance to track down the culprit of that code, I did replace the gas cap though

Last edited by Aloofmind; 10-14-2016 at 06:15 AM.
Aloofmind is offline   Reply With Quote
Old 10-14-2016, 06:26 AM   #4
e46_txi
Registered User
 
Join Date: Oct 2016
Location: Ger
Posts: 29
My Ride: E46 330
What you describe (I also think the car acts like a iginition step 1 is on) should also switch the radio on (if you left it on), ever seen this? You say exterior lights switch on, do you have automatic light setting available on your LCM and do you use it? If not, exterior light switching on is a strange fact.
e46_txi is offline   Reply With Quote
Old 10-14-2016, 06:33 AM   #5
N95
Registered User
 
Join Date: Aug 2010
Location: BHR
Posts: 66
My Ride: 330i
Symptoms of a failing battery and low system voltage.
Test the battery voltage after running the engine, it should be at least 12.7 volts.
__________________
N95 is offline   Reply With Quote
Old 10-14-2016, 06:33 AM   #6
Aloofmind
Registered User
 
Join Date: Oct 2016
Location: South Carolina
Posts: 6
My Ride: 2003 325i
I do have the auto feature for the lights but I rarely use them. I have the xenon headlights. But yes they come on for about 5-10 seconds then go off.
Aloofmind is offline   Reply With Quote
Old 10-14-2016, 06:40 AM   #7
Aloofmind
Registered User
 
Join Date: Oct 2016
Location: South Carolina
Posts: 6
My Ride: 2003 325i
I just went to check the radio and I can turn it on without the key in at all
Aloofmind is offline   Reply With Quote
Old 10-14-2016, 06:41 AM   #8
jfoj
OEM ///Member
 
Join Date: Nov 2009
Location: Fairfax, VA USA
Posts: 23,192
My Ride: 330CiC, M5, X5, E93
I would start with testing the battery as suggested, then I would consider replacing the ignition switch, these are known for intermittent problems.
__________________
Solve your misfires, lean codes, rough idle - http://forum.e46fanatics.com/showthread.php?t=897616

Fuel pump failures - http://forum.e46fanatics.com/showthread.php?t=929501

Temp Info - http://forum.e46fanatics.com/showthread.php?t=964491

Hidden OBC Menu - Check Voltage, Temp, Fuel Level - http://forum.e46fanatics.com/showthread.php?t=239619

E46/E39 GM5 Door Lock Info - www.bmwgm5.com

Lower hose temp switch O-ring - BMW #13621743299
jfoj is online now   Reply With Quote
Old 10-14-2016, 06:43 AM   #9
Aloofmind
Registered User
 
Join Date: Oct 2016
Location: South Carolina
Posts: 6
My Ride: 2003 325i
Im going to have the battery tested soon, I'll post the results.
Aloofmind is offline   Reply With Quote
Old 10-14-2016, 06:44 AM   #10
e46_txi
Registered User
 
Join Date: Oct 2016
Location: Ger
Posts: 29
My Ride: E46 330
It could be only the lightswitchmodule, next time leave your radio on and see if it switches on, too. If not, its propably "only" the lightmodule.

Its not about the fact, that you can turn it on without key, the question is: when you leave it on when taking the key out it will switch off, but does it switch on when the lights switch on automatically after you locked the car!

Last edited by e46_txi; 10-14-2016 at 06:45 AM.
e46_txi is offline   Reply With Quote
Old 10-14-2016, 06:48 AM   #11
venerated
Registered User
 
Join Date: Jun 2015
Location: Chicagoland
Posts: 346
My Ride: 325xi / Mazda3
I had this issue in my old Mazda after I did some work under the dash. Turned out that some wires were touching under the dash. Just a thought that something could be wired incorrectly.
__________________
Progress Thread / Twitter / Instagram

2003 325xi Jet Black/Brown Leather
2016 Mazda3 s Grand Touring Jet Black Mica/Black Leather

Quote:
Originally Posted by mpvue View Post
a list of parts to replace on these is easy; just replace everything.
venerated is offline   Reply With Quote
Old 10-14-2016, 06:51 AM   #12
Aloofmind
Registered User
 
Join Date: Oct 2016
Location: South Carolina
Posts: 6
My Ride: 2003 325i
Quote:
Originally Posted by e46_txi View Post
It could be only the lightswitchmodule, next time leave your radio on and see if it switches on, too. If not, its propably "only" the lightmodule.

Its not about the fact, that you can turn it on without key, the question is: when you leave it on when taking the key out it will switch off, but does it switch on when the lights switch on automatically after you locked the car!
I've been in the car when it happens many times, and I usually don't turn off the radio when I turn off the car. I've never seen the radio come back on during one of these episodes.
Aloofmind is offline   Reply With Quote
Old 10-14-2016, 08:13 AM   #13
e46_txi
Registered User
 
Join Date: Oct 2016
Location: Ger
Posts: 29
My Ride: E46 330
The get a used light module (look for the correct specs: Xenon yes/no, foglights yes/no, light sensor yes/no) it is changeable within 5min.
e46_txi is offline   Reply With Quote
Reply

Tags
dash guages, fuel pump, lights

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 10:23 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
(c) 1999 - VerticalScope Inc. All rights reserved.