Auto gear change erratic 1.5rpms to 2.5 rpms. - E46Fanatics E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Other BMW Models > General BMW E36 Forum

General BMW E36 Forum
This is the place to get answers, opinions and everything you need related to your E36 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 05-05-2017, 03:11 AM   #1
Nev.72
Registered User
 
Join Date: May 2017
Location: Uk
Posts: 1
My Ride: Bmw 330i sport
Auto gear change erratic 1.5rpms to 2.5 rpms.

Hi. I have an issue with my 2004 330i auto.
It's randomly selecting gears in the low revs range and revs are hunting as well.
It's much better in manual shift and sport mode as the revs stay higher.
It will cruise fine at 60mph and above without any issues.
It idles fine and has no problem selecting reverse etc.
I've had the diagnostic done twice and it's reading no fault codes for the engine and gearbox. I've had the transmission oil and filter changed and it has the latest software on it. I've read on here someone with a similar problem but they did not post if it was ever solved.
I am thinking of changing the transmission pump and torque converter clutch solenoid but I am not convinced that will solve it.
Has anyone any ideas??
Thanks.
Nev.72 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 03:02 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
(c) 1999 - VerticalScope Inc. All rights reserved.