E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rating: Thread Rating: 1 votes, 1.00 average. Display Modes
Old 01-03-2014, 04:12 PM   #1
Jjsa8199
Registered User
 
Join Date: Dec 2013
Location: Las Vegas
Posts: 23
My Ride: 323ci
Need help please on my323ci

So I had to replace my oil separator and hoses . I replaced all my spark plugs & coils & O2 sensor. And it's still misfiring and SEL light is on.. Can some one please help I've spent a lot and I need some piece in mind and help me figure this out..please and thank you..

Last edited by Jjsa8199; 01-03-2014 at 04:13 PM.
Jjsa8199 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 01-03-2014, 04:14 PM   #2
Mango
e46mango.com
 
Mango's Avatar
 
Join Date: Mar 2006
Location: Southern California
Posts: 26,140
My Ride: Lexus
Could be a mechanical fault or simply in need of more maintenance. Check your long term fuel trims
Mango is offline   Reply With Quote
Old 01-03-2014, 04:26 PM   #3
Jjsa8199
Registered User
 
Join Date: Dec 2013
Location: Las Vegas
Posts: 23
My Ride: 323ci
Lightbulb PLEASE HELP ME W/My 323ci


So I had to replace my oil separator and hoses . I replaced all my spark plugs & coils & O2 sensor. And it's still misfiring and SEL light is on.. Can some one please help I've spent a lot and I need some piece in mind and help me figure this out..please and thank you..
Jjsa8199 is offline   Reply With Quote
Old 01-03-2014, 04:28 PM   #4
Stickbuilder
Registered User
 
Join Date: May 2010
Location: Nashville TN/Central FL.
Posts: 1,406
My Ride: Touring, and others
Need help please on my323ci

Check to make sure you didn't accidentally disconnect the intake cam sensor. It is easy to do and easy not to notice. You will have to remove the air box.


Sent from BimmerApp mobile app
__________________
[/SIGPIC]I'm fluent in 3 languages:

English
Sarcasm
Profanity
Stickbuilder is offline   Reply With Quote
Old 01-03-2014, 04:34 PM   #5
Yewzer B Lewzer
Registered User
 
Join Date: Jan 2013
Location: St. Petersburg FL
Posts: 2,255
My Ride: 2003 325i
Need help please on my323ci

What codes?


Sent from BimmerApp mobile app
__________________

^^Blue Ridge Parkway^^ '03 325i. '74 Jeep CJ-5. '93 Sailfish 170XL. '12 Westside SS Longboard. One of these four are sure to be running at any given point in time.
Yewzer B Lewzer is offline   Reply With Quote
Old 01-03-2014, 04:41 PM   #6
Importjunkie
Registered User
 
Join Date: Jun 2009
Location: Lexington, KY
Posts: 341
My Ride: 00 Prelude
Need help please on my323ci

Intake cam sensor maybe


Sent from BimmerApp mobile app
Importjunkie is offline   Reply With Quote
Old 01-03-2014, 04:56 PM   #7
Jjsa8199
Registered User
 
Join Date: Dec 2013
Location: Las Vegas
Posts: 23
My Ride: 323ci
Need help please on my323ci

P1189 p1188 p0305 here are the codes


Sent from BimmerApp mobile app
Jjsa8199 is offline   Reply With Quote
Old 01-03-2014, 04:56 PM   #8
Jjsa8199
Registered User
 
Join Date: Dec 2013
Location: Las Vegas
Posts: 23
My Ride: 323ci
Need help please on my323ci

Sorry p1305


Sent from BimmerApp mobile app
Jjsa8199 is offline   Reply With Quote
Old 01-03-2014, 05:03 PM   #9
Weste46
Registered User
 
Join Date: Dec 2011
Location: Westfield, IN
Posts: 864
My Ride: 2001 330ci
Re: PLEASE HELP ME W/My 323ci

Post all the codes you are getting.
__________________
Corbeau FX1 Pro & CR1, Ultimo front coils, Rob43 9-click rear shocks, Swift 10k rear springs, Meyle FCA's, AKG 95a FCA, 75d rear subframe, Powerflex 95a RTA, 95a RCA, ECS 88a diff., ECS SS brake lines, LTW FW, M3 engine mounts, UUC 5sp black mounts, BMW Performance SSK, open-loop EU2 tune, CAI, headers, x-pipe, minus ~180lbs.
Weste46 is offline   Reply With Quote
Old 01-03-2014, 05:14 PM   #10
Jjsa8199
Registered User
 
Join Date: Dec 2013
Location: Las Vegas
Posts: 23
My Ride: 323ci
1188 fuel control (bank 1sensor 1)
1189 fuel control (bank 2 sensor 1)
0305 misfires on cylinder 5
Jjsa8199 is offline   Reply With Quote
Old 01-03-2014, 05:20 PM   #11
Jjsa8199
Registered User
 
Join Date: Dec 2013
Location: Las Vegas
Posts: 23
My Ride: 323ci
P1189 p1188 p0305
Jjsa8199 is offline   Reply With Quote
Old 01-03-2014, 06:01 PM   #12
Stickbuilder
Registered User
 
Join Date: May 2010
Location: Nashville TN/Central FL.
Posts: 1,406
My Ride: Touring, and others
PLEASE HELP ME W/My 323ci

Did you plug the small vacuum line from the fuel pressure regulator back into the CVV?
Did you replace the O-rings on the air spreader?
You still have a vacuum leak. May need a smoke test to find it.

Sent from BimmerApp mobile app
__________________
[/SIGPIC]I'm fluent in 3 languages:

English
Sarcasm
Profanity

Last edited by Stickbuilder; 01-03-2014 at 06:04 PM.
Stickbuilder is offline   Reply With Quote
Old 01-03-2014, 09:34 PM   #13
Jjsa8199
Registered User
 
Join Date: Dec 2013
Location: Las Vegas
Posts: 23
My Ride: 323ci
Might need to do a smoke test
Jjsa8199 is offline   Reply With Quote
Old 01-03-2014, 09:43 PM   #14
Jjsa8199
Registered User
 
Join Date: Dec 2013
Location: Las Vegas
Posts: 23
My Ride: 323ci
Can anyone figure out my problem
Jjsa8199 is offline   Reply With Quote
Old 01-03-2014, 09:56 PM   #15
Sapote
Registered User
 
Join Date: Jan 2008
Location: southern California
Posts: 550
My Ride: E46 2000 323i wagon
Quote:
Originally Posted by Jjsa8199 View Post
Can anyone figure out my problem
swap out the 5 and 1 coils and see if the code points to 1. if it still point to 5 then not the coil. Moving from here.

Sapote
Sapote is offline   Reply With Quote
Old 01-04-2014, 04:14 AM   #16
Jjsa8199
Registered User
 
Join Date: Dec 2013
Location: Las Vegas
Posts: 23
My Ride: 323ci
Need help please on my323ci

I'll do that


Sent from BimmerApp mobile app
Jjsa8199 is offline   Reply With Quote
Old 01-04-2014, 08:51 AM   #17
Jjsa8199
Registered User
 
Join Date: Dec 2013
Location: Las Vegas
Posts: 23
My Ride: 323ci
Actually have done it that's why I ended up replacing all coils and plugs
Jjsa8199 is offline   Reply With Quote
Old 01-04-2014, 09:25 AM   #18
lszlszx
Registered User
 
Join Date: Jan 2013
Location: Socal
Posts: 5,345
My Ride: 1.8T, XC70
You need to do a smoke test, there is probably a vacuum leak.
Can your code reader display freeze frame? If yes post it.
__________________


GM No Reverse - posts 427, 439

"Would the codes indicate if it's the carburator?"
lszlszx is offline   Reply With Quote
Old 01-07-2014, 08:51 PM   #19
Jjsa8199
Registered User
 
Join Date: Dec 2013
Location: Las Vegas
Posts: 23
My Ride: 323ci
So I did the smoke test and found that my crank case vent hose to oil separator was bad so I replaced that today and still misfiring


Sent from BimmerApp mobile app
Jjsa8199 is offline   Reply With Quote
Old 01-07-2014, 09:08 PM   #20
lszlszx
Registered User
 
Join Date: Jan 2013
Location: Socal
Posts: 5,345
My Ride: 1.8T, XC70
Have you cleared the code and it came back still indicating Cylinder 5 misfire?
__________________


GM No Reverse - posts 427, 439

"Would the codes indicate if it's the carburator?"
lszlszx is offline   Reply With Quote
Reply

Tags
check engine light, misfires, o2 sensors, rough idle

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 05:40 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
(c) 1999 - 2016 performanceIX Inc - privacy policy - terms of use