E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 02-13-2015, 06:50 PM   #1
tommyt34
Registered User
 
Join Date: Jul 2013
Location: Seattle, WA
Posts: 6
My Ride: 2005 330i ZHP
No heat and intermittent coolant light

Recently I have been experiencing two issues with my car. I feel as though they could be related.

1. The heat pretty much does not work at all. Its been a gradual decline over the past month or so to the point that I'm not sure if it works at all. It definitely does not work when the car is heating up, or any time near that, but occasionally it will kick on after I have been driving for 10-15 minutes. Other than that, it doesn't work.

2. My coolant light has been kicking on and off as well, but it mainly stays in the on position for the most part, but it's not consistently on. When I have checked the coolant level, its always low. I'm assuming I must have a leak somewhere or it may be escaping out from the cap..?

I tried bleeding the system today and to be honest, I did not see one bubble come out and I poured for a good 2-4 minutes. I was expecting to find some air in the system, as some previous threads said that air can A. cause the light to come on, and B. prevent the heat from working.

Just wondering if someone has experienced this as well and may have some insight. Looking to fix it myself and avoid taking it in.

Any suggestions or insight is welcome, thanks!

ps. It's worth noting that the car has over heated in the past and I have replaced the expansion tank, the thermostat, and water pump.

Last edited by tommyt34; 02-13-2015 at 06:52 PM.
tommyt34 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 02-13-2015, 07:43 PM   #2
mleindek
Registered User
 
Join Date: Oct 2014
Location: Maryland, USA
Posts: 799
My Ride: 2009 X5
When you bleed it was the heater on? Just in case, check this thread, hope it helps.

http://forum.e46fanatics.com/showthread.php?t=914109

* E46 Cooling Guide (Information w/parts list/bleeding) *
mleindek is offline   Reply With Quote
Old 02-13-2015, 08:07 PM   #3
lllRazorlll
Modded ///Member
 
lllRazorlll's Avatar
 
Join Date: Jul 2012
Location: Philadelphia, PA
Posts: 2,421
My Ride: '00 328i
Your cooling system is going to fail completely and soon. This happened to me in December and I didn't go very far as I noticed that the car started to overheat. You have a leak somewhere.
__________________


>IN SEARCH OF GRAY SEDAN SPORT SEATS<
lllRazorlll is offline   Reply With Quote
Reply

Tags
coolant light, cooling, heat

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 07:16 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
(c) 1999 - 2016 performanceIX Inc - privacy policy - terms of use