E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > E46 Convertible

E46 Convertible
The E46 vert forum. Talk about dropping your E46 top here.

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 04-01-2015, 03:33 PM   #1
Jackob852
Registered User
 
Join Date: Apr 2015
Location: Switzerland/Poland
Posts: 9
My Ride: E46 Cabrio
Unhappy Not latching + not opening.

Hello BMW friends
Im writing becouse I hope that somebody can help me...
Ive got the same problem with my roof as abinley have had.
http://www.m3forum.net/m3forum/showt...post1065032578
I hope its legal, i dont want to make advertisement.
I know he gave the solution but I still cant understand it, maybe Im to gentle with my car, maybe Im just retarded about mechanic but please help me.
Summer is almost in my country and I would really like to open my roof.
Ive made an examination by Original BMW Service and they said that there is a problem witch latch on driver side but they dont know what exacly makes an error (something mechanical or just sensor). Now the red LED blinks all the time, when I push the button only windows go down, nothing more is happening... I dont even know how to get to this latch to try like abinley...hovewer the box with gears under rear seat looks normal. I can naturaly send u pics of this parts, my car...etc.
Ive been earning for this car for a really long time, I love my BMW, when I buyed it, everything was fine, after few months suddenly when I was trying to close the roof,it didnt want to lach to front window...
Of course Ive readed a lot of threads on this forum but i still didnt found the answer, becouse if its simple issue and i can repair it on my own it would be very nice, everything cost incredibly much in Switzerland...
For every mistake Im sorry, especially for the language.
Kindly regards!
Jakub
Jackob852 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 04-01-2015, 04:11 PM   #2
taylor192
Registered User
 
Join Date: Feb 2012
Location: The Best Place on Earth
Posts: 2,445
My Ride: 2003.5 M3
Please try this first:
1. Read your manual, as its likely in your language, for instructions of how to manually close the roof. Use those instructions to open the roof (reverse the instructions!) and let us know if the roof unlatches from the windshield.

The answer to that will dictate the next step. Either you have a broken wire, or a broken latch.
__________________
taylor192 is offline   Reply With Quote
Old 04-02-2015, 07:08 AM   #3
Jackob852
Registered User
 
Join Date: Apr 2015
Location: Switzerland/Poland
Posts: 9
My Ride: E46 Cabrio
Hello Taylor192
1- Thank You very much for so fast answer!
2.Ive did as U ask me to do, firstlly I checked if under the seat tension lines are totally forward, they werent so I pushed the button and used a key to turn a gear a little bit. Then I moved to driver seat and started to moving screw in the ceiling and the roof opened totally normally, without clicking, cracking, actually without sound. now is unlached but it is not very high, just about inch or two over the windshield.
Correct me if I am wrong but does it means that my latches and wire are in good condition?
Strange thing about all this story is that:at the evening when it faild to close, I tried few times to swich my ignition and few times pushing button to close the roof, at about fifh time it closed itselmf normally like always, fully automaticlly so I didnt even thought that something could be broke...
I very appreciate your help!

Last edited by Jackob852; 04-02-2015 at 07:10 AM.
Jackob852 is offline   Reply With Quote
Old 04-02-2015, 10:37 AM   #4
taylor192
Registered User
 
Join Date: Feb 2012
Location: The Best Place on Earth
Posts: 2,445
My Ride: 2003.5 M3
That means your latches are not broken, so the next likely culprit is a broken wire. Read the electrical troubleshooting sticky at the top of this forum for more details.
__________________
taylor192 is offline   Reply With Quote
Old 04-02-2015, 10:55 AM   #5
taylor192
Registered User
 
Join Date: Feb 2012
Location: The Best Place on Earth
Posts: 2,445
My Ride: 2003.5 M3
Please don't send me PMs repeating and questioning what I post.

No-one can be 100% sure what your problem is, that is why you need to investigate. If you search this forum you'll find broken wires are the #1 cause of roof issues. Check this sticky (or as they are called on this forum @chtung): http://forum.e46fanatics.com/showthread.php?t=854059

Weird that this forum sensors the word @chtung.
__________________

Last edited by taylor192; 04-02-2015 at 11:27 AM.
taylor192 is offline   Reply With Quote
Old 04-02-2015, 11:19 AM   #6
Jackob852
Registered User
 
Join Date: Apr 2015
Location: Switzerland/Poland
Posts: 9
My Ride: E46 Cabrio
Ah, ok I thought that maybe its the only reason why the roof isnt working when latches are ok! Im gonna check all the wires today or tomorrow and I will let here know,
Thanks a lot!
Jackob852 is offline   Reply With Quote
Old 04-03-2015, 07:06 AM   #7
maggra2015
Registered User
 
Join Date: Apr 2015
Posts: 13
I've had simular problems and found that to get the roof closed and secure you need to remove ignition key which allows the system to de-pressureize then manually close the softop as far as you can, which should be just sort of the windscreen, then switch ignition back on and it should then finish the closing of the roof automatically! Once you've completed the close/secure cycle you then must reset the car by disconnecting the battery this will allow a complete reboot of the car's electronics which in my case sorted the issue completely.

The removal of the ignition key is the manufacturers way of manually opening and closing the softop in the case of any malfunction happening whilst operating the e46 softop
maggra2015 is offline   Reply With Quote
Old 04-03-2015, 09:28 AM   #8
Jackob852
Registered User
 
Join Date: Apr 2015
Location: Switzerland/Poland
Posts: 9
My Ride: E46 Cabrio
Today i was trying to find this broken electric wire, but i didnt found, everything seems to be find. At the end I was curious how the roof will react on the buttons. I pushed opening but nothing was happaning, then i pushed button to close, roof closed itself without help, without strange sound, just normally like it should but the red LED is blinking all the time. Any ideas? Maggra2015 thank you for help but do you think that in my case taking battery of could also help?
Jackob852 is offline   Reply With Quote
Old 04-03-2015, 10:21 AM   #9
maggra2015
Registered User
 
Join Date: Apr 2015
Posts: 13
With roof closed and windows completely closed does the Red light still flash?
maggra2015 is offline   Reply With Quote
Old 04-03-2015, 10:46 AM   #10
taylor192
Registered User
 
Join Date: Feb 2012
Location: The Best Place on Earth
Posts: 2,445
My Ride: 2003.5 M3
Did you just visually inspect the wires? If so that is NOT good enough. The wires need to be electrically tested as per the instructions in that post.

Alternatively have a shop read the CVM code that is causing the red light to blink. That will narrow the issue.

There is nothing else we can do to help until you do one of the above.
__________________

Last edited by taylor192; 04-03-2015 at 01:08 PM.
taylor192 is offline   Reply With Quote
Old 04-03-2015, 05:14 PM   #11
Jackob852
Registered User
 
Join Date: Apr 2015
Location: Switzerland/Poland
Posts: 9
My Ride: E46 Cabrio
So I went to the garage one more time, roof was closed and secured red was flashing all the time, I went to trunk, disconnected and after a while connected again with battery. I heard the roof and few things making sound after connection. I went to the dashboard red was still blinking but anyway I pushed the button to open the roof, windows go down, roof is opening normally till the moment when the cover from roof trunk should be opening but it didnt, storage cover was tightly latched or just didnt gone up. Roof stopped becouse it havent place to hide. I was pushing buttons close/open but zero reaction. I turned off the ignition, roof goes down(no pressure), I pushed button to close it moved till it touches windshield, now it is an inch over the windshield and dont response for any button, I will try to close it tomorrow manually, then maybe loosen this two wires under the backseat, make trick with battery one more time and try to open once again. What U think?
Maggra2015-yes, this LED blinks all the time, even if my key isnt in ignition it blinks still for about minute then turn off.
Taylor192-yes, shame, I know but only visually, i havent got multimeter... Problem is that I was by BMW dealer, and they found out that is something on driver side, there where latch to windshield is, they didnt told me 100% becouse they would like to earn for repair... The first, fast examination also by BMW didnt show anything, any roof error.
Thank You very much guys for interest, I hope that we are close to solve this problem.

Last edited by Jackob852; 04-03-2015 at 05:46 PM.
Jackob852 is offline   Reply With Quote
Old 04-04-2015, 08:26 AM   #12
Jackob852
Registered User
 
Join Date: Apr 2015
Location: Switzerland/Poland
Posts: 9
My Ride: E46 Cabrio
I did how I writed in previously post. closed the roof, disconnetcting and connecting battery, loosen the two tension cables under back seat and starting to open the roof with button. Everything was working fine, roof goes completly down but at the end the lid didnt latched itself, I looked under the backseat and I found that the button, little spring and two metal balls jumped of from the third gear....Does anybody know how to repair them...?
Taking everything into consideration:
-(opening) roof will be going down fine but after trick with battery.
-(closing) roof stopps everytime over the windshield, but if I move with allen key screw witch is in the ceiling(doesnt matter, one or two turns) then push the close button again it closes itself normally.
Any ideas...? ;(
Edit, Ive almost forget, now the roof is closed and secured to windshield but I think that the lid is closed just becouse the weight of the roof and not lacthed properly...

Last edited by Jackob852; 04-04-2015 at 08:31 AM.
Jackob852 is offline   Reply With Quote
Old 04-04-2015, 12:06 PM   #13
taylor192
Registered User
 
Join Date: Feb 2012
Location: The Best Place on Earth
Posts: 2,445
My Ride: 2003.5 M3
You have a broken wire.

When you use the allen key on the roof you are probably moving the roof enough to get the wires to make contact, so when you push the button again the roof works.

Until you electrically test the wires, or get the codes read, you're on your own. I refuse to guess when you have been given instructions how to investigate.
__________________
taylor192 is offline   Reply With Quote
Old 04-04-2015, 05:04 PM   #14
Jackob852
Registered User
 
Join Date: Apr 2015
Location: Switzerland/Poland
Posts: 9
My Ride: E46 Cabrio
Broken Wire, you mean one of the wires, this electrical wires? Not the one witch connects latches one both sides on the front of the roof? Ok, i will try how fast i can to test the wires .
And my question was also about this lid gears? Spring, two balls, how to repair them? Becouse now only one gear moves under the backseat.
Thanks for interest!
Jackob852 is offline   Reply With Quote
Reply

Tags
cabrio, latch, problem, roof

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 01:11 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
(c) 1999 - 2016 performanceIX Inc - privacy policy - terms of use