E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 09-16-2015, 03:45 PM   #1
omarda325i
Registered User
 
Join Date: Jun 2015
Location: texas
Posts: 75
My Ride: 2002 325i
fuel pump or fuel filter??!!?

325i 2002 159k miles
i;ve got my problem down to 2 things either fuel pump or filter
my car has hesitation on acceleration.
when i floor it it has hard time gaining speed. from 0-60 hiccups and some times get stuck on 40mph. but when i put the throttle 50% it seems to do decent but still not all the power is their. rarely when i floor do does the car clime up speed decently not even smooth.-
it idles okay.
yesterday after driving 20+ miles i was at red light and when it got to green
the car started moving really slowing it would not get over 20mph and it struggles and jerked. until it gained some speed and then started going.

some times when i rev the car while idling it gets stuck on 3000-4000rpm and doesnt clim anymore until i release and push again, but most of the time while idling it revs okay.
---------------------------------------------------------
FUEL TRIMS N INFO FROM OBD2
Fuel trims- from bank 1 and 2 my long fuel trims are at 0.0 and 0.78
and nothing happens when i rev

my short fuel trim is at 27 and gets better as i rev. from both banks

also the engine load shows to be at around 12 and 20 when parked.


can anybody help me pls

Last edited by omarda325i; 09-16-2015 at 05:22 PM.
omarda325i is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 09-16-2015, 03:56 PM   #2
franz
Registered User
 
Join Date: Aug 2006
Location: RDU, NC
Posts: 3,968
My Ride: 03 330i
You should probably do both.
franz is offline   Reply With Quote
Old 09-16-2015, 04:06 PM   #3
DEADF15H
Registered User
 
Join Date: Jul 2012
Location: Boca Raton, FL or Salisbury, NC
Posts: 1,465
My Ride: 2001 325i Auto
Here is the best thread on fuel pumps/filters. http://forum.e46fanatics.com/showthr...ight=fuel+pump
You can do the fuel pump (the biggest culprit), the filter and the relay for under $200, it's a simple DIY, even for a novice (I know this, because I am one).
The pump only takes about 15 minutes of actual work, and is a known weak link on our 10 year + old cars. Find the DIY.
The pump its located under the back seat, the filter under the car on the left side, the relay is behind the glove box and the trickiest part of the R&R. These parts are highly recommended as a preventative maintenance item, because sooner or later, they ARE going to fail.
DEADF15H is offline   Reply With Quote
Old 09-16-2015, 05:20 PM   #4
omarda325i
Registered User
 
Join Date: Jun 2015
Location: texas
Posts: 75
My Ride: 2002 325i
can it still be fuel pump if the car runes fines when low on gas and the gas meter works normal too when low on gas ??!?!?!?!?
omarda325i is offline   Reply With Quote
Old 09-16-2015, 05:24 PM   #5
omarda325i
Registered User
 
Join Date: Jun 2015
Location: texas
Posts: 75
My Ride: 2002 325i
maybe my car is on original fuel filter since 2002.?
i get code p1085-low fuel pressure.

i cant do the fuel filter and fuel pump both at once it'le be way too much money then i can pay out.

Last edited by omarda325i; 09-16-2015 at 05:25 PM.
omarda325i is offline   Reply With Quote
Old 09-16-2015, 05:26 PM   #6
jfoj
OEM ///Member
 
Join Date: Nov 2009
Location: Fairfax, VA USA
Posts: 22,861
My Ride: 330CiC, M5, X5, E93
I would put a fuel pump in before the filter.

Siemens/VDO fuel pump/fuel sender assembly unit delivered is around $135 from www.bmaparts.com using the discount code SPECE30.

You need 1 small worm drive hose clamp and about 30 minutes, it is easier to replace the fuel pump than change a tire IMHO.
__________________
Solve your misfires, lean codes, rough idle - http://forum.e46fanatics.com/showthread.php?t=897616

Fuel pump failures - http://forum.e46fanatics.com/showthread.php?t=929501

Temp Info - http://forum.e46fanatics.com/showthread.php?t=964491

Hidden OBC Menu - Check Voltage, Temp, Fuel Level - http://forum.e46fanatics.com/showthread.php?t=239619

E46/E39 GM5 Door Lock Info - www.bmwgm5.com

Lower hose temp switch O-ring - BMW #13621743299
jfoj is offline   Reply With Quote
Old 09-16-2015, 05:43 PM   #7
omarda325i
Registered User
 
Join Date: Jun 2015
Location: texas
Posts: 75
My Ride: 2002 325i
when i start my car i hear the fuel pump and its kinda loud is that normal?
omarda325i is offline   Reply With Quote
Old 09-16-2015, 06:08 PM   #8
cvx5832
Registered User
 
Join Date: Mar 2009
Location: Walnut Creek, CA
Posts: 4,066
My Ride: 325Ci, 325Cic, C300
Quote:
Originally Posted by omarda325i View Post
325i 2002 159k miles
i;ve got my problem down to 2 things either fuel pump or filter
my car has hesitation on acceleration.
when i floor it it has hard time gaining speed. from 0-60 hiccups and some times get stuck on 40mph. but when i put the throttle 50% it seems to do decent but still not all the power is their. rarely when i floor do does the car clime up speed decently not even smooth.-
it idles okay.
yesterday after driving 20+ miles i was at red light and when it got to green
the car started moving really slowing it would not get over 20mph and it struggles and jerked. until it gained some speed and then started going.

some times when i rev the car while idling it gets stuck on 3000-4000rpm and doesnt clim anymore until i release and push again, but most of the time while idling it revs okay.
---------------------------------------------------------
FUEL TRIMS N INFO FROM OBD2
Fuel trims- from bank 1 and 2 my long fuel trims are at 0.0 and 0.78
and nothing happens when i rev

my short fuel trim is at 27 and gets better as i rev. from both banks

also the engine load shows to be at around 12 and 20 when parked.


can anybody help me pls
I had the same symptoms on my Coupe when it had 89k. Fuel pump solved it although I would follow others' suggestions to replace the filter too.
__________________






cvx5832 is offline   Reply With Quote
Old 09-16-2015, 06:09 PM   #9
omarda325i
Registered User
 
Join Date: Jun 2015
Location: texas
Posts: 75
My Ride: 2002 325i
Quote:
Originally Posted by cvx5832 View Post
I had the same symptoms on my Coupe when it had 89k. Fuel pump solved it although I would follow others' suggestions to replace the filter too.
did it accelerating horribly

Last edited by omarda325i; 09-16-2015 at 06:10 PM.
omarda325i is offline   Reply With Quote
Old 09-16-2015, 07:41 PM   #10
omarda325i
Registered User
 
Join Date: Jun 2015
Location: texas
Posts: 75
My Ride: 2002 325i
i just went on a 6 miles trip to the store and came back.
the car didn't have check engine light but it did pop 3 codes. lean codes p0174 and p0171, also 1351. but no p1085-low fuel pressure. it despaired
can these be fuel pump triggering these codes. because i think my car is not having a vacuum leak.
omarda325i is offline   Reply With Quote
Old 09-16-2015, 08:06 PM   #11
franz
Registered User
 
Join Date: Aug 2006
Location: RDU, NC
Posts: 3,968
My Ride: 03 330i
The short answer is yes, lean is equivalent to having enough air and not enough gas, or enough gas and too much air.
franz is offline   Reply With Quote
Old 09-16-2015, 08:43 PM   #12
omarda325i
Registered User
 
Join Date: Jun 2015
Location: texas
Posts: 75
My Ride: 2002 325i
yes it must be the fuel pump because right now my car's gas light is on and i takes several times to turn on my car and dies on me while trying to reverse out my house
omarda325i is offline   Reply With Quote
Old 09-18-2015, 08:22 AM   #13
omarda325i
Registered User
 
Join Date: Jun 2015
Location: texas
Posts: 75
My Ride: 2002 325i
this morning my car cranks and doesnt start. am thinking its fuel pump. so put in a order on ebay for $44 e46 325i pump with 10 year warranty

http://www.ebay.com/itm/130906114373...%3AMEBIDX%3AIT
omarda325i is offline   Reply With Quote
Old 09-18-2015, 08:51 AM   #14
jfoj
OEM ///Member
 
Join Date: Nov 2009
Location: Fairfax, VA USA
Posts: 22,861
My Ride: 330CiC, M5, X5, E93
Somehow I doubt the pump will outlast the 10 year warranty because many of the OE BMW pumps do not even last 10 years.

But let us know how the fit and performance of the pump works out.

I rarely cut corners too hard when the part failure has a high degree of leaving me stranded.
__________________
Solve your misfires, lean codes, rough idle - http://forum.e46fanatics.com/showthread.php?t=897616

Fuel pump failures - http://forum.e46fanatics.com/showthread.php?t=929501

Temp Info - http://forum.e46fanatics.com/showthread.php?t=964491

Hidden OBC Menu - Check Voltage, Temp, Fuel Level - http://forum.e46fanatics.com/showthread.php?t=239619

E46/E39 GM5 Door Lock Info - www.bmwgm5.com

Lower hose temp switch O-ring - BMW #13621743299
jfoj is offline   Reply With Quote
Old 09-18-2015, 10:54 AM   #15
DEADF15H
Registered User
 
Join Date: Jul 2012
Location: Boca Raton, FL or Salisbury, NC
Posts: 1,465
My Ride: 2001 325i Auto
Scary, they don't even list who the manufacturer is. Hoping you have years of service, but I'm skeptical. Good luck.
DEADF15H is offline   Reply With Quote
Old 09-18-2015, 11:00 AM   #16
omarda325i
Registered User
 
Join Date: Jun 2015
Location: texas
Posts: 75
My Ride: 2002 325i
hahah, scary ik =/ as long as i get my acceleration and hesitation fixed and couple years use out of the pump i think it'l be justified
omarda325i is offline   Reply With Quote
Old 09-18-2015, 09:55 PM   #17
omarda325i
Registered User
 
Join Date: Jun 2015
Location: texas
Posts: 75
My Ride: 2002 325i
do my fuel trims indiacte i have a air leak?
omarda325i is offline   Reply With Quote
Old 09-18-2015, 10:25 PM   #18
wildirish317
Registered User
 
Join Date: Sep 2012
Location: Louisville, KY
Posts: 3,277
My Ride: 2004 325Ci vert
Quote:
Originally Posted by jfoj View Post
I would put a fuel pump in before the filter.
Curious as to why. I replaced both at the same time. No indication of fuel pump failure, but highly fluctuating O2 short and long term fuel trims.

I replaced the fuel pump bc it's prone to failure. The fuel filter was original, 140+k miles, so it was due.

I've seen better fuel trims, and no codes thrown since. I attribute it more to the filter than the pump.

My opinion is that the filter will cause drivability problems before the pump, as long as the filter has not been changed in the past 60k miles.
__________________
“The test of the machine is the satisfaction it gives you. There isn't any other test. If the machine produces tranquility it's right. If it disturbs you it's wrong until either the machine or your mind is changed.”

Quote:
Originally Posted by Mike Miller
I just don't know what I'd do with 560 hp that doesn't involve getting arrested.
wildirish317 is offline   Reply With Quote
Old 09-19-2015, 12:02 AM   #19
Chris951
Registered User
 
Join Date: Mar 2015
Posts: 179
Quote:
Originally Posted by omarda325i View Post
do my fuel trims indiacte i have a air leak?

Your fuel trims at idle shouldn't vary much more than +/- 5%. My car sits normally around +/- .75-2.5% at idle. And high positive trims like you are showing mean the car is running very lean and its adding fuel to compensate. This could indicate a vacuum leak or a low fuel pressure problem.


Sent from my iPhone using Tapatalk
Chris951 is offline   Reply With Quote
Old 09-19-2015, 12:13 AM   #20
Licked
Registered User
 
Join Date: Apr 2015
Location: Reseda, California
Posts: 40
My Ride: 330Ci Vert
hows your fuel level when driving ? is it eating up gas????
Licked is offline   Reply With Quote
Reply

Tags
0-60 slow, fuel pump, slow accerlation

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 09:51 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
(c) 1999 - 2016 performanceIX Inc - privacy policy - terms of use