E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 01-15-2014, 06:07 PM   #1
40gin
Registered User
 
Join Date: Jan 2014
Location: New York
Posts: 2
My Ride: BMW 330xi
Coolant issues after thermostat replacement!

So my thermostat was stuck open and my engine could never maintain heat in this cold NY winter, so I bought one off ebay: http://www.ebay.com/itm/BMW-E39-E46-...item564eefcccf
Yesterday I drained and flushed my coolant, replaced the thermostat, refilled the coolant with 50/50 mix and got my heat back, but my success was short lived. The engine temperature is perfect, but the new thermostat has this little hole in the front that kept squirting coolant into the fan which sprayed it all over the engine bay and caused white smoke. The whole looks like it's supposed to be there, but the original one doesn't have it. I asked the ebay store about it and they weren't much help, just offered a return. So I taped the hole, refilled the coolant, and thought I had temporarily fixed it. Wrong Today the coolant needed to be topped off, and the heat in my car disappeared (the engine temp is normal though). I drive a little bit and white smoke starts coming out of the radiator and my radiator light turns on, so I add more, and this happens over and over. I don't see any more leaks anywhere so I have no idea what the problem can be. Has anyone else experienced this after a thermostat replacement?_a_
40gin is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 01-25-2014, 03:43 PM   #2
MiikeOxlong
Registered User
 
Join Date: Jan 2014
Location: Sacramento
Posts: 49
My Ride: 325i
never buy aftermarket bmw parts. i learned the hard way. you can find cheap oem parts on ebay. but if you have a coolant problem i would check your "heater inlet pipe" and your water pipe, they mold and leak
MiikeOxlong is offline   Reply With Quote
Old 03-23-2014, 09:59 AM   #3
Tacticaluke
Registered User
 
Join Date: Feb 2014
Posts: 2
I would certainly never buy aftermarket parts from eBay. Though they may be cheaper and a lot more affordable, they can't be trusted. Just in case I would check your water pump, it may not be the cause to your problem now, but it could be related someday with a faulty thermostat.
Tacticaluke is offline   Reply With Quote
Old 03-23-2014, 10:37 AM   #4
40gin
Registered User
 
Join Date: Jan 2014
Location: New York
Posts: 2
My Ride: BMW 330xi
Thanks for the responses guys. Turned out it was a faulty thermostat (my fault for buying off ebay) and also it was dripping coolant from the radiator hoses that attach to it. So to anyone doing this replacement, make sure you replace those hoses as well, or apply a sealant to the connections so the coolant doesn't leak out. Got mine from autozone and it did the trick. Been driving for a few months without any issues. Oh also the white smoke was the result from coolant spraying onto the radiator and then evaporating when it heated up. Cheers
40gin is offline   Reply With Quote
Reply

Tags
coolant, cooling system, radiator, thermostat

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 10:32 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
(c) 1999 - 2016 performanceIX Inc - privacy policy - terms of use