E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 05-03-2016, 02:28 PM   #1
panagath
Registered User
 
Join Date: Aug 2015
Location: London
Posts: 105
My Ride: '00 e46 330ci
Fuel pump failing? Or just vacuum leak

Ok, following a previous Thread, I would like to ask with some "cleaner" results and symptoms. I have an e46 330ci

I usually had P0171 & P0174 (lean both banks) errors but could not find the vacuum leak. The car worked great all the time (I think).

Now I notice that when I first start it I might have some vibrations. Then it works fine, after 30+ minutes of driving, when I stop to a traffic light, the idle is a bit rough, or for example if I do a hard acceleration and then go to neutral. (This points me to not enough fuel?) .

If I turn the car off and leave it for half and hour and start it again...then it starts having frequent rough idle. If I leave it for a few hours (when I am at work for example or overnight) then everything goes back to the same as when I first start it.

Since the rough idle is not permanent, I think that it is not a vacuum leak. I tried to disconnect the MAF and spray intake cleaner fluid arround all the hoses etc visible from the top and nothing was noted. Could this be a fuel pump failing?
panagath is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 05-03-2016, 03:30 PM   #2
dmax
Registered User
 
dmax's Avatar
 
Join Date: Aug 2006
Location: NJ
Posts: 23,670
My Ride: '99 328i 300K miles
Not sure of prior thread, but that it happens when it's warmed up more, I'm kind of thinking fuel filter. At start up, it'll have a slightly higher idle.

But, if you haven't looked, it well might be an airleak...and while you're replacing the lower intake boot, I'd clean the ICV really well...and do all I could in that neighborhood....clean TB, replace its gasket...ditto the DISA. The ICV grommet will be fine, though if you want to spend another $20, do that too.

Also...run Techron in two consecutive fills...with super. Read the label...add at gas station before filling.

...and, all that said, it could be the fuel pump too...lots of simple things need to work for the car to work. Don't know the mileage or what you've done preventatively so far. Plugs, VCG. Anyway...a fuel filter will stop the car at 120K miles if not changed, but if it's been a while, you'll get better gas mileage when you change it...in all likelihood.

What maintenance have you done? Fuel pump and filter are both straightforward. For pump, you'll want one helper for about 3 mins. with a hammer and screwdriver to hammer on the opposite side of the locking ring to get it open.
__________________
Upcoming comedy shows: April 23, Tierney's Tavern, Montclair, NJ, 7:00 p.m. See Facebook for other shows and PM me if you can make one...love to see you there!

Facebook.com/DMAXstandup
Mangofy your E46!
dmax is online now   Reply With Quote
Old 05-03-2016, 03:32 PM   #3
Hamsocne
Registered User
 
Join Date: Dec 2009
Location: Williamsburg, Virginia
Posts: 564
My Ride: 2002 330Ci
I think it is a vacuum leak.

Check all your hoses again.

Edit: Damn Doug types fast.
__________________

Last edited by Hamsocne; 05-03-2016 at 03:34 PM.
Hamsocne is offline   Reply With Quote
Old 05-03-2016, 05:31 PM   #4
Hamsocne
Registered User
 
Join Date: Dec 2009
Location: Williamsburg, Virginia
Posts: 564
My Ride: 2002 330Ci
I have re-read your post. I still think you have a vacuum issue. Those codes are the only ones that I have pulled and that was what it was both times. Mine was minor so no idle or other issues.

I am unsure if the SAP hoses will give you those codes, but I did replace mine. I am ready to get flamed but that one with ribs is notorious for hiding flaws.

Do you have maintenance records? I have every record since new and only have 80,000 miles so the very few issues I have had were easy to figure out.

With that being said, sometimes you wait and sometimes you don't. I am going to do my VCG and fuel pump/filter just because.
__________________
Hamsocne is offline   Reply With Quote
Old 05-03-2016, 06:09 PM   #5
panagath
Registered User
 
Join Date: Aug 2015
Location: London
Posts: 105
My Ride: '00 e46 330ci
My car is at 137k miles. I don't have a full service record. I have the car for 8-9 months now. A few days after I bought it I had a huge issue with vacuum leak from the upper intake boot. I changed it and it started working fine, but it throws P0171 & P0174 after driving for like 50miles, then it might turn off after a bit etc. Now It turns on much faster and I also have a bit of rough idle here and there.

I ordered a fuel pressure gauge, hope it will be here by the weekend. I will take a look at the fuel pressure. If it is not ok I will replace the pump and the filter just to be sure. I also booked the car to a garage to do a smoke test and see where the leak comes from if it exists...but that garage is SO BUSY that the nearest appointment they had was on the 25th ( 22days from now :p ). Lets hope it won't die until then.

I sprayed a lot of intake cleaner on the lower hose (especially on the small hose it has) but the idle did not change.

Another symptom I have the last days is that when I start it from cold... initially it revs up to 1000rpm... then a few seconds later it goes to 1200rpm until it drops again down to 700. Before these issues, it wouldn't go above 1000rpm when cold.
panagath is offline   Reply With Quote
Old 05-03-2016, 06:13 PM   #6
All2kool
Registered User
 
Join Date: Mar 2016
Location: Portland, OR
Posts: 750
My Ride: 2002 325Ci
I also had the P0171/P0174 codes recently. I replaced the first boot off the MAF and it has not returned. I inspected the boot I removed and could see nothing wrong with it. Then it dawned on me - I likely created a vacuum leak when I lazily installed a new Air Filter shortly after purchase. I didn't see the clip nearest the engine and pried up the Air Box Lid a little to slide in the new filter. My codes came after I did that. I concluded that when I installed the Air Filter, I created a gap in the boot. I could be wrong but I'm sticking with it.
All2kool is offline   Reply With Quote
Old 05-03-2016, 06:43 PM   #7
panagath
Registered User
 
Join Date: Aug 2015
Location: London
Posts: 105
My Ride: '00 e46 330ci
Quote:
Originally Posted by All2kool View Post
I also had the P0171/P0174 codes recently. I replaced the first boot off the MAF and it has not returned. I inspected the boot I removed and could see nothing wrong with it. Then it dawned on me - I likely created a vacuum leak when I lazily installed a new Air Filter shortly after purchase. I didn't see the clip nearest the engine and pried up the Air Box Lid a little to slide in the new filter. My codes came after I did that. I concluded that when I installed the Air Filter, I created a gap in the boot. I could be wrong but I'm sticking with it.
I had a similar issue after I installed the new upper intake boot. The clamp after the MAF to the upper intake boot was not that "strong" and If I screwed it a bit more it jumped from its teeth. So there was a small leak from there. I changed it to a reenforced clamp :p :p and now I am sure there is no leak from there
panagath is offline   Reply With Quote
Old 05-04-2016, 08:17 AM   #8
markusmarkus
Registered User
 
Join Date: Jul 2008
Location: USA
Posts: 5,767
My Ride: 2001 330Ci
OP, those codes are classic for vacuum leaks! Have the intake smoke tested. Visual inspections won't find the leaks.
markusmarkus is offline   Reply With Quote
Old 05-04-2016, 10:42 AM   #9
panagath
Registered User
 
Join Date: Aug 2015
Location: London
Posts: 105
My Ride: '00 e46 330ci
Quote:
Originally Posted by markusmarkus View Post
OP, those codes are classic for vacuum leaks! Have the intake smoke tested. Visual inspections won't find the leaks.
I tried to disable the MAF and used Air Intake cleaner fluid...sprayed a lot of it around all the possible hoses and places I can see from the top of my engine but I couldn't detect any changes in the rpms. I will try to buy starting fluid and see if that does any difference.

I also ordered a "snake" telescopic camera so I can put it and see everything under my engine without having to lift my car and see for anything very obvious. If nothing of that helps...I will wait until the 25th when I have the smoke test booked.
panagath is offline   Reply With Quote
Old 05-04-2016, 11:15 AM   #10
jfoj
OEM ///Member
 
Join Date: Nov 2009
Location: Fairfax, VA USA
Posts: 22,405
My Ride: 330CiC, M5, X5, E93
Classic case of someone not listening or searching.

ALMOST ALL the E46 vacuum leaks are from the underside of the engine/hoses. Spray do not usually work for locating them. Some cannot even be located with smoke testing.

If you are not willing to get dirty and under the car, take it to a shop.

I do not check fuel pressure on cars over 8-10 years old, just replace the fuel pump.

Otherwise read these threads -

http://forum.e46fanatics.com/showthread.php?p=16727145

http://forum.e46fanatics.com/showthread.php?t=929501
__________________
Solve your misfires, lean codes, rough idle - http://forum.e46fanatics.com/showthread.php?t=897616

Fuel pump failures - http://forum.e46fanatics.com/showthread.php?t=929501

Temp Info - http://forum.e46fanatics.com/showthread.php?t=964491

Hidden OBC Menu - Check Voltage, Temp, Fuel Level - http://forum.e46fanatics.com/showthread.php?t=239619

E46/E39 GM5 Door Lock Info - www.bmwgm5.com

Lower hose temp switch O-ring - BMW #13621743299

Last edited by jfoj; 05-04-2016 at 11:16 AM.
jfoj is online now   Reply With Quote
Old 05-04-2016, 04:05 PM   #11
panagath
Registered User
 
Join Date: Aug 2015
Location: London
Posts: 105
My Ride: '00 e46 330ci
Quote:
Originally Posted by jfoj View Post
Classic case of someone not listening or searching.

ALMOST ALL the E46 vacuum leaks are from the underside of the engine/hoses. Spray do not usually work for locating them. Some cannot even be located with smoke testing.

If you are not willing to get dirty and under the car, take it to a shop.

I do not check fuel pressure on cars over 8-10 years old, just replace the fuel pump.

Otherwise read these threads -

http://forum.e46fanatics.com/showthread.php?p=16727145

http://forum.e46fanatics.com/showthread.php?t=929501
Of course I have searched. I have spent a lot of hours trying to find people with similar symptoms. I have read BOTH the threads from you signature, the one for the vacuum leaks and the other for the fuel pumps...How do you think I got the idea that the fuel pump could be causing the lean codes?

The car is driven daily, I leave early and come back late, there is not enough time to get under the car during weekdays and sometimes there is not enough time even at weekends. I do not have all the tools to lift the car and get under it properly (yet) and I do not have a closed garage, everything has to be done on the street.

The shop I booked the appointment does not have an available appointment before the 25th of this month...So I am trying to gather as much information as I can and display all the symptoms I have discovered in case I am lucky and I manage to find the problem in time before the car stops being drivable if it happens before the 25th. Its all I can do with limited resources in a city with limited space.
panagath is offline   Reply With Quote
Old 05-04-2016, 04:50 PM   #12
D.javier17
Registered User
 
Join Date: Jul 2015
Posts: 191
I had these codes and symptoms on cold starts, replaced my disa and the two codes have not returned.
D.javier17 is offline   Reply With Quote
Old 05-04-2016, 10:09 PM   #13
dwebb99
Registered User
 
Join Date: Sep 2006
Location: houston
Posts: 242
My Ride: 330ci
Search....fuel pump, fuel filter, disa valve, idle control valve (clean it!), throttle body (clean it), intake boots (they crack...replace), CCV valve replacement. At this mileage it's time for all these things "assuming" they have not yet been done. Trust me on this. Plenty of youtube video's and DIY's on all these things. Also, become VERY familiar with BMW COOLING SYSTEMS! Welcome to the club....now.....Git-er-done.....
dwebb99 is offline   Reply With Quote
Old 05-04-2016, 11:49 PM   #14
Megalocnus
Registered User
 
Join Date: Oct 2008
Location: Los Angeles, CA
Posts: 2,982
My Ride: 05 330i ZHP/MT
Quote:
Originally Posted by panagath View Post
Of course I have searched. I have spent a lot of hours trying to find people with similar symptoms. I have read BOTH the threads from you signature, the one for the vacuum leaks and the other for the fuel pumps...How do you think I got the idea that the fuel pump could be causing the lean codes?

The car is driven daily, I leave early and come back late, there is not enough time to get under the car during weekdays and sometimes there is not enough time even at weekends. I do not have all the tools to lift the car and get under it properly (yet) and I do not have a closed garage, everything has to be done on the street.

The shop I booked the appointment does not have an available appointment before the 25th of this month...So I am trying to gather as much information as I can and display all the symptoms I have discovered in case I am lucky and I manage to find the problem in time before the car stops being drivable if it happens before the 25th. Its all I can do with limited resources in a city with limited space.
Can't work on your car where you live and can't get an appointment at the shop earlier than April 25? It can be especially tough to own an old car in some cities, i.e. London UK, Manahttan NY and such.

A lot of people were able to get rid of these codes after finding tears in the intake boot and/or elbow, but others have less luck. I guess in your situation it is worth to check for vacuum leaks at the more obvious places, then just give up and let the shop find them. The fuel pump is something you can easily do on your own, but at this age it will be worth to replace the fuel filter as well, which is a bit more involved job...

Have you considered getting a newer car that will better fit your lifestyle?

Last edited by Megalocnus; 05-04-2016 at 11:52 PM.
Megalocnus is offline   Reply With Quote
Old 05-05-2016, 05:19 AM   #15
panagath
Registered User
 
Join Date: Aug 2015
Location: London
Posts: 105
My Ride: '00 e46 330ci
Quote:
Originally Posted by dwebb99 View Post
Search....fuel pump, fuel filter, disa valve, idle control valve (clean it!), throttle body (clean it), intake boots (they crack...replace), CCV valve replacement. At this mileage it's time for all these things "assuming" they have not yet been done. Trust me on this. Plenty of youtube video's and DIY's on all these things. Also, become VERY familiar with BMW COOLING SYSTEMS! Welcome to the club....now.....Git-er-done.....
I have already searched for all these. I will start checking one by one from this weekend until I find my problem. For the cooling system I am ok for now, the previous owner had replaced the radiator and had serviced it (800pounds service If I remember well that I saw in the receipts). Hope it will last a little more.

Quote:
Originally Posted by Megalocnus View Post
Can't work on your car where you live and can't get an appointment at the shop earlier than April 25? It can be especially tough to own an old car in some cities, i.e. London UK, Manahttan NY and such.

A lot of people were able to get rid of these codes after finding tears in the intake boot and/or elbow, but others have less luck. I guess in your situation it is worth to check for vacuum leaks at the more obvious places, then just give up and let the shop find them. The fuel pump is something you can easily do on your own, but at this age it will be worth to replace the fuel filter as well, which is a bit more involved job...

Have you considered getting a newer car that will better fit your lifestyle?
Yes, being a petrolhead in a big city like London is not that easy. I have considered changing my car...BUT
- I can't change it before my current insurance contract ends because I need to get my 1st year of No Claims Discount (as I am new in the UK) and it is very important to reduce the next insurance quote
- With the same money I have I can get like a Toyota Yaris, or a Nissan Micra, or a Mercedes C180 etc... The e46 330 is the best car you can buy BUT you need to be able to work on it.
- I would like to get the M3 but it is much more expensive and I guess it will have the same or similar problems :p
panagath is offline   Reply With Quote
Old 05-05-2016, 06:01 AM   #16
markusmarkus
Registered User
 
Join Date: Jul 2008
Location: USA
Posts: 5,767
My Ride: 2001 330Ci
Have the intake system smoke tested!?? You can have 20/20 vision and you won't "see" vacuum leaks. The only sure way to find vacuum leaks is to smoke test the intake. Stop doing half measures and pull the trigger: smoke test! Jssssh!
markusmarkus is offline   Reply With Quote
Old 05-05-2016, 06:39 AM   #17
panagath
Registered User
 
Join Date: Aug 2015
Location: London
Posts: 105
My Ride: '00 e46 330ci
Quote:
Originally Posted by markusmarkus View Post
Have the intake system smoke tested!?? You can have 20/20 vision and you won't "see" vacuum leaks. The only sure way to find vacuum leaks is to smoke test the intake. Stop doing half measures and pull the trigger: smoke test! Jssssh!
I have already booked an appointment to do a smoke test, but the shop was full until the 25th of this month...so the smoke test will be done in 20 days. I am just trying to find the main cause of the problem and fix it before that as the car is a daily driver and in 20 days a lot can happen...
panagath is offline   Reply With Quote
Old 05-08-2016, 10:49 AM   #18
panagath
Registered User
 
Join Date: Aug 2015
Location: London
Posts: 105
My Ride: '00 e46 330ci
Hello all again. Today I worked a bit on the car. These are my findings. Any suggestions will be very appreciated. Also, all the checks I did were from the "top" of the car as I do not have any stands yet.

1 - DISA valve looks ok, pin in position, flap is strong and you need to press it to move, no play etc. I only had to put a seal as it did not have one. Probably the previous owner replaced the DISA but did not put any seal.

2 - I removed to engine caps. The one hose that goes from the front of the intake manifold to the back, shown in the photos below looks in a very bad condition. I don't know if this is the protector only or the hose itself. I tried to pour some starting fluid on but did not have any change in RPM. Can someone help detect this hose in realoem? I can't find it. Could this be causing my vacuum leaks?

3 - Oily intake. After removing the DISA, all the intake inside was oily. Could this justify my excessive oil loss? Does it mean a bad CCV? Could it be related to the hose on top?

4 - Fuel pressure. I checked the fuel pressure. Before starting the engine (overnight engine off) pressure was almost 0. After I turned the key to pos. ON the pressure went to around 44 PSI (but no more). After a few minutes I started the engine, fuel pressure was again 44 PSI. During revving the engine pressure went like 10 psi more (could not see clear from inside the car) and when I stopped revving the pressure dropped to 35 psi. Is my fuel pump in soft fail mode?

5 - Upper intake boot is new ( I replaced it a few months ago) lower intake boot looks quite fresh too.




















Last edited by panagath; 05-08-2016 at 10:50 AM.
panagath is offline   Reply With Quote
Old 05-08-2016, 05:48 PM   #19
panagath
Registered User
 
Join Date: Aug 2015
Location: London
Posts: 105
My Ride: '00 e46 330ci
anyone?
panagath is offline   Reply With Quote
Reply

Tags
e46 330, fuel pump

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 06:45 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
(c) 1999 - 2016 performanceIX Inc - privacy policy - terms of use