E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > New Member Introductions

New Member Introductions
New members check-in, introduce yourselves, and post a picture of your BMW here!

Reply
 
Thread Tools Search this Thread Display Modes
Old 03-20-2017, 11:52 PM   #1
mewnyah
Registered User
 
Join Date: Mar 2017
Location: zimbabwe
Posts: 4
My Ride: 320i
hie guys

hie guys
mewnyah is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 03-20-2017, 11:55 PM   #2
mewnyah
Registered User
 
Join Date: Mar 2017
Location: zimbabwe
Posts: 4
My Ride: 320i
cluster instruments out

hie all my cluster intruments are off what could be the cause it started after starting my vehicle on Saturday
mewnyah is offline   Reply With Quote
Old 03-26-2017, 08:51 AM   #3
Solidjake
Zero. Leaks.
 
Solidjake's Avatar
 
Join Date: May 2008
Location: NYC
Posts: 31,060
My Ride: '02 330i 6MT
What do you mean by off? The needles don't move? There's no power to the cluster?

Always check fuses first.
__________________
Solidjake is offline   Reply With Quote
Old 03-27-2017, 12:20 AM   #4
mewnyah
Registered User
 
Join Date: Mar 2017
Location: zimbabwe
Posts: 4
My Ride: 320i
there seem to be no power to the needles nd all lights are dead

there is no power on all needles .and the cluster unstruments are all off

this started after i switched of my car and it would not power on .but the lights and blinkers are functional .....just not displaying on the cluster instruments console
mewnyah is offline   Reply With Quote
Old 03-27-2017, 12:22 AM   #5
mewnyah
Registered User
 
Join Date: Mar 2017
Location: zimbabwe
Posts: 4
My Ride: 320i
i checked fuses they are all ok
mewnyah is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 01:40 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
(c) 1999 - 2016 performanceIX Inc - privacy policy - terms of use