E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 03-03-2009, 01:50 PM   #1
slal325
Registered User
 
Join Date: Mar 2009
Location: san jose, california
Posts: 3
My Ride: 2003 325i
Exclamation DME replacement or shop trying to make money off warranty?

I have a 2003 325i automatic, stock.

When driving yesterday in heavy rain and commuter traffic, my DSC, ABS and brake lights all came on and my car jumped a little, felt like I was rear-ended (I wasn't) and slowed (downshifted). I pulled over, turned off the car. Tried to restart it, engine cranked but didn't start. Tried again, no crank, nothing. Hazard lights worked, radio worked. Battery only 1 yr old. Got it jumped, red battery light came on then went off. So not the alternator.

Shop says it needs a new DME. After reading posts here it seems like it might just be a sensor issue, faulty wheel speed sensors. My car is covered by an extended warranty which the shop says will cover the DME replacement. I'm thinking this is overkill and the shop may be trying to make money off the warranty.

If it's no money out my pocket, should I be concerned about replacing the DME? What issues can result (or should I look for) from replacing the DME? If it is the speed sensors, would a new DME detect this? I was completely surprised when I was told the DME needed replaced, not expecting that. Any advice is appreciated.
slal325 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 03-03-2009, 01:58 PM   #2
GoingNuts
Just Nuts
 
Join Date: Jul 2008
Location: London
Posts: 7,253
My Ride: 2004 330Ci
Sounds like the battery to me, even if it is only 1 year old. It's also possible the rain water short circuit something.
GoingNuts is offline   Reply With Quote
Old 03-03-2009, 04:34 PM   #3
jbeurotech
Regional Sponsor
 
Join Date: Aug 2006
Location: New Brighton MN
Posts: 5,018
My Ride: 2000 E46 with 254K
I make alot more money off other parts DME's are dealer only and have little to no profit. Trust me I don't replace a DME for fun or profit!!!! Anyways the DME is covered by BMW for 10 year 100k
__________________

Seth Thorson
Service Manager/BMW Tech
JB Eurotech Service "Your Reasonable Dealer Alternative"

General Questions can be sent to appointment@jbeurotech.com

1. Do not argue with an idiot. He will drag you down to his level and beat you with experience.
2. Light travels faster than sound. This is why some people appear bright until you hear them speak.
jbeurotech is offline   Reply With Quote
Old 03-03-2009, 10:12 PM   #4
slal325
Registered User
 
Join Date: Mar 2009
Location: san jose, california
Posts: 3
My Ride: 2003 325i
Thanks jbeurotech! That is the kind of information that I was hoping to receive.
slal325 is offline   Reply With Quote
Old 03-03-2009, 10:16 PM   #5
slal325
Registered User
 
Join Date: Mar 2009
Location: san jose, california
Posts: 3
My Ride: 2003 325i
Well the tow truck driver checked this out already and said it wasn't the battery, he suggested alternator. The shop already ruled out both of these possibilities, which is why I thought it might be a speed sensor. thanks for your input.
slal325 is offline   Reply With Quote
Reply

Tags
abs, dme, dsc, speed sensor

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 05:38 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
(c) 1999 - 2016 performanceIX Inc - privacy policy - terms of use