E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Lighting Forum

Lighting Forum
Angel Eyes, DDEs, lighted rings, Clear Turn Signals, LEDs, Xenon, HID, or Bi-Xenon. If it lights up and you want to discuss it, post here!

Reply
 
Thread Tools Search this Thread Rating: Thread Rating: 1 votes, 5.00 average. Display Modes
Old 12-25-2014, 12:36 AM   #1
rodneyjames
Registered User
 
Join Date: Dec 2014
Location: california
Posts: 4
My Ride: '03 330i
both low beam and high beam dont work both sides

I just bought a 2003 330i and its my first bmw. It has the xenon hid lights i guess is what they're called and also the automatic light option i do believe. My problem is both low beam and high beam do not work on both sides. I have very limited electrical knowledge. Does anyone know if this is going to be a bulb or ballast or switch problem? I do have a p.asoft 1.4 scanner tool but dont really know how to read the codes on it. any help would be great. thanx in advance. Also my fog lights dont work. Its weird my headlight switch does not have a fog light button or buttons yet i have fog lights. any ideas?
rodneyjames is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 12-25-2014, 02:33 AM   #2
Mikesmith2939
Registered User
 
Join Date: Jul 2014
Location: Reading UK
Posts: 29
My Ride: 330d
Try the fuses and relays first.

It's unusual for both sides to stop working if the ballasts or igniters go as each side has it's own of both.

Also the main beam uses a different switch.

The other cause could be the light module.
Mikesmith2939 is offline   Reply With Quote
Old 12-25-2014, 02:18 PM   #3
rodneyjames
Registered User
 
Join Date: Dec 2014
Location: california
Posts: 4
My Ride: '03 330i
i dont think that my car has headlight relays if so can u tell me where they are cuz i cant find anywhere or anyone that can point them out to me or at least point me in the right direction. i'm thinking that they are integrated with the lcm
rodneyjames is offline   Reply With Quote
Old 12-25-2014, 02:29 PM   #4
Mikesmith2939
Registered User
 
Join Date: Jul 2014
Location: Reading UK
Posts: 29
My Ride: 330d
Have a look at this wiring diagram it may help

http://www.bmw-planet.com/diagrams/release/en/
Mikesmith2939 is offline   Reply With Quote
Old 12-25-2014, 03:20 PM   #5
jdstrickland
Registered User
 
Join Date: Apr 2010
Location: Murrieta, CA
Posts: 9,081
My Ride: '94 325iC & '00 323i
I'm confused.

You said, "both low beam and high beam do not work on both sides," and this means to that you have no headlamps at all.

You can pull the turn signal stalk towards the steering wheel to momentarily activate the high beams to flash other drivers. Does this feature work? If yes, then the lights are okay. At least the high beams are okay. If you can flash other drivers but the lights do not work when you turn them on, then there is a problem with the main lighting switch. Is it possible that you have the light switch set wrong?
jdstrickland is offline   Reply With Quote
Old 12-25-2014, 03:24 PM   #6
BaliDawg
Keepin' it real stock
 
Join Date: Aug 2012
Location: Riverside, CA
Posts: 5,233
My Ride: E24 E32 E46 E39 E84
Check the switch

Did someone replace the headlight switch with one from a different car? It should have the fog light button below the dimmer, like this.
Attached Thumbnails
Click image for larger version

Name:	image.jpg
Views:	92
Size:	83.5 KB
ID:	584763  
__________________
///Mmmmmm...

Last edited by BaliDawg; 12-25-2014 at 03:24 PM.
BaliDawg is offline   Reply With Quote
Old 12-28-2014, 08:44 AM   #7
rodneyjames
Registered User
 
Join Date: Dec 2014
Location: california
Posts: 4
My Ride: '03 330i
YES when i drive the car i pull the blinker switch towards me and the passing lights do work. so what i do is jam a pencil in between the dash and the blinker thing when i drive at night oh yeah and i removed fuse for adaptive headlights and pointed them almost straight down but still blinding some people. I hate being the asshole guy with his brights on thats driving right behind u but this has been me for like the last month. so my xenon lights are my low beams only and the two halogen ones that are my passing lights are also high beams?
rodneyjames is offline   Reply With Quote
Old 12-28-2014, 08:50 AM   #8
rodneyjames
Registered User
 
Join Date: Dec 2014
Location: california
Posts: 4
My Ride: '03 330i
thats a good question cuz when i first took the lcm out there was only one screw holding it in one was missing. mine does not have the foglight button below the dimmer switch which i find odd since i have fog lights and lastly when i hook it up to pa soft it does have the right vin but the mileage is different on the two columns on the first screen when it runs the first check and tells u what car u have what motor and all the stuff it came from the factory with the mileage is off like by like 18 miles are something like that. do u think that the lcm was changed?
rodneyjames is offline   Reply With Quote
Old 12-28-2014, 01:15 PM   #9
BaliDawg
Keepin' it real stock
 
Join Date: Aug 2012
Location: Riverside, CA
Posts: 5,233
My Ride: E24 E32 E46 E39 E84
Quote:
Originally Posted by rodneyjames View Post
thats a good question cuz when i first took the lcm out there was only one screw holding it in one was missing. mine does not have the foglight button below the dimmer switch which i find odd since i have fog lights and lastly when i hook it up to pa soft it does have the right vin but the mileage is different on the two columns on the first screen when it runs the first check and tells u what car u have what motor and all the stuff it came from the factory with the mileage is off like by like 18 miles are something like that. do u think that the lcm was changed?
Post your PA Soft log file here and let's see what is up.
__________________
///Mmmmmm...
BaliDawg is offline   Reply With Quote
Reply

Tags
330i, headlight

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 05:39 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
(c) 1999 - 2016 performanceIX Inc - privacy policy - terms of use