E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 01-02-2015, 08:14 PM   #1
kcarr0088
Registered User
 
Join Date: Jun 2013
Location: Ft. Worth, Texas
Posts: 26
My Ride: 2003 BMW 325i
Xenon Igniter Issues

I replaced my igniter after the original melted. I was waiting on bulbs and when I went to install them, my new igniter seems to be doing the same as the last! Could it be the Control Unit? I'm freaking out a bit since I need to fix my inspection that expired in September..
kcarr0088 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 01-02-2015, 08:40 PM   #2
VMRWheels
Sponsor
 
VMRWheels's Avatar
 
Join Date: Sep 2004
Location: Anaheim, CA
Posts: 10,786
My Ride: Anything with VMRs!
Send a message via AIM to VMRWheels Send a message via Yahoo to VMRWheels
Firstly, are your Xenon's OEM? If so, what do you mean by melting? Is the plastic housing of the igniter burning or are the wires fraying? If it's the housing/connector, I would double check to make sure that everything is seated properly and everything is locked in.
__________________
Tracy @ VMR | Wheels
tracy@velocitymotoring.com | (714) 442-7916 Ext. 103
www.velocitymotoring.com | | | Blog | Instagram

Winter Wheel/Tire Sale!
VMRWheels is offline   Reply With Quote
Reply

Tags
igniter, xenon

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 03:51 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
(c) 1999 - 2016 performanceIX Inc - privacy policy - terms of use