Need Help! 06 M3 Vanos Problems - E46Fanatics E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > ///M3 Forum

///M3 Forum
The BMW E46 ///M3 is the M version E46 and puts out an amazing 333 HP and 262 lb-ft of torque at stock specs! There are an amazing amount of modifications for both the coupe and convertible models so read up and get started modifying your cars today!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 06-04-2015, 09:25 PM   #1
nickritzer
Registered User
 
Join Date: Jun 2015
Location: frederick
Posts: 3
My Ride: e46 m3
Question Need Help! 06 M3 Vanos Problems

I need some help and opinions here. I just purchased a 2006 M3 with 31k miles on it. I did a lot of research on this car which seemed to be well taken care of at the time. I had a car fax which indicated a one owner- car that was serviced at the place where it was purchased. All services and recalls were up to date. The chevy dealer where the car was for sale gave me the car-fax. I called the bmw dealer in Columbus oh, and inquired about the car, they were helpful and gave all details, and gave me a good to go, no services need at this time, per the car fax and bmw dealer, the car was just in there on 5/15/15 for an oil change. I inquired about a service 1 and they said it wasn't needed but wansnt done yet either. I spoke to the chevy dealer about the car and they said everything was good but since I was coming from Maryland, they said the car sometimes has a rough idle when started cold and some ticking noises all until the car was warmed up, then it was fine. I called the bmw dealer and they said it was normal for m3's, unitl the lifters warm up, they make that noise. that being said, drove the car loved it, bought it, also bought an allstate warranty for the engine and trans to the tune of 2400.00. got it to Maryland sunday. Drove it to work on Tuesday and the check engine light came on. Took it to Rockville bmw yesterday for a md inspection and diagnostic code reading. spoke to the service rep and he is telling me vanos issues, camshaft position sensor and few numerous things. I only got 80 miles before the light came on and it was only 250 miles since the service at the OH bmw dealer. Car is in great shape and I want to take it to someone in the Wash-Baltimore area to do the work. can anyone recommend someone where they have had this done around here. I went to the beisan website and will use their parts if that is what is recommended. Looking for input here.
Thanks
nickritzer is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 06-04-2015, 10:38 PM   #2
djdonis
Registered User
 
Join Date: May 2009
Location: Charlotte
Posts: 484
My Ride: e39 540i M, 330i 6sp
Just replace the CPS, use genuine BMW parts, and stay away from M3 VANOS.
__________________
Diagnosis - BMW...
djdonis is offline   Reply With Quote
Old 06-05-2015, 12:54 AM   #3
Rhumb
Registered User
 
Join Date: Apr 2007
Location: Virginia
Posts: 129
My Ride: 2001 M3 Coupe
Hard to tell without specific codes, but yeah, might just be the cam position sensor. Relatively cheap part held on by a single hex bolt, but a bear to access (need hands the size of a small five-year old's).
Rhumb is offline   Reply With Quote
Old 06-05-2015, 02:46 PM   #4
nickritzer
Registered User
 
Join Date: Jun 2015
Location: frederick
Posts: 3
My Ride: e46 m3
Got the report back from BMW, 3 issues noted.

Fault code for o2 sensor, bank 2, pre-cat that is bad. They want to replace the sensor $493.50
Fault code for Crank Sensor, They want to replace the sensor $518.00
Fault code for the Vanos Unit. They want to take it apart an see what is wrong with it. Also, they said the engine is making a noise and they are not sure if its the vanos or deeper in the motor, they want to take the valve cover off. $1,209.00 just to look.

Has any one been here with this?

Please let me know thanks
nickritzer is offline   Reply With Quote
Old 06-06-2015, 05:13 AM   #5
Alex323Ci
Registered User
 
Join Date: Jan 2005
Location: Huntington Beach -Surf City USA
Posts: 20,464
My Ride: M3 & 323Ci (sold)
wait a minute. so you got a check engine light, but you didn't say how the car is driving? is it bad, like huge loss of power like when in limp mode or just the light?

clear codes, drive it and see what's up.

I mean you do have the warranty, but what will it cover?
__________________
OE CSL WHEELS - OE CSL BRAKES - OE AUTOFLD MIRRORS - CSL RACK - CSL TRUNK - CSL DIFFUSER - AA TUNE - AA PULLEYS - AS 40% SSK - BILSTEIN PSS9s
CF CSL LIP - NAV- BMWP CF STRUT BAR - BMW GROUP N MNTS - GRUPPE M CF INTAKE - SUPERSPRINT - UUC S/S LINES, RTABs - H&R SWAYS - 4.10 M-SPORT DIFF
Alex323Ci is offline   Reply With Quote
Old 06-06-2015, 06:21 AM   #6
nickritzer
Registered User
 
Join Date: Jun 2015
Location: frederick
Posts: 3
My Ride: e46 m3
The car has a little bit of a rough idle when started. It also makes a tapping noise that can be heard at idle. But it drives fine. No loss of power through the range. I haven't stomped on or anything but it feels fine, no hesitation. As for the warranty, I bought one that just covers the engine and trans only. If I wanted the warranty for everything to be covered it would have been more than 5k. I just wanted a total loss coverage since I owned an 02 back in 2002 and blew the motor at 120mph. Fought with bmw to get it fixed. The repair bill was $27,000 plus, but bmw just gave me a new car after everything was said and done.
nickritzer is offline   Reply With Quote
Reply

Tags
e46, m3, vanos

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 09:27 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
(c) 1999 - VerticalScope Inc. All rights reserved.