E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 11-17-2015, 08:41 AM   #21
markusmarkus
Registered User
 
Join Date: Jul 2008
Location: USA
Posts: 5,902
My Ride: 2001 330Ci
I wonder if the oil temp data (changes in resistance actually) are actually getting to the ECU. I'd check the wiring closely.
markusmarkus is offline   Reply With Quote
Old 11-17-2015, 09:32 AM   #22
jfoj
OEM ///Member
 
Join Date: Nov 2009
Location: Fairfax, VA USA
Posts: 22,856
My Ride: 330CiC, M5, X5, E93
Loose connector, loose female terminals inside the connector, broken wire inside the wiring harness.
__________________
Solve your misfires, lean codes, rough idle - http://forum.e46fanatics.com/showthread.php?t=897616

Fuel pump failures - http://forum.e46fanatics.com/showthread.php?t=929501

Temp Info - http://forum.e46fanatics.com/showthread.php?t=964491

Hidden OBC Menu - Check Voltage, Temp, Fuel Level - http://forum.e46fanatics.com/showthread.php?t=239619

E46/E39 GM5 Door Lock Info - www.bmwgm5.com

Lower hose temp switch O-ring - BMW #13621743299
jfoj is online now   Reply With Quote
Old 05-15-2016, 10:46 AM   #23
fazalabbas
Registered User
 
Join Date: Apr 2016
Location: Colorado
Posts: 1
My Ride: 2002 E46 330xi
Oil pressure sensor

I just want to share how my P0198 got fixed.

I dont agree with this big tall picture in this thread. According to my very limited youtube base knowledge, Oil pressure Sensor (short/fat) is the Temperature Sensor. Or at least I thought it was oil temperature sensor.

Anyhow, I changed the oil pressure sensor of this picture calling it temperature sensor and my code is gone. I've driven for couple of days and it did not come back. It was a short/fat sensor that needed 24mm wrench

Just an FYI, I have changed oil sender unit or oil level sensor unit before above but that did not fix it
fazalabbas is offline   Reply With Quote
Reply

Tags
oil temperature, sensor

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 06:39 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
(c) 1999 - 2016 performanceIX Inc - privacy policy - terms of use