E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 01-30-2016, 08:31 PM   #1
Nolan_R
Registered User
 
Join Date: Dec 2015
Location: Indiana
Posts: 50
My Ride: 2005 TiAg 330i ZHP
Power mirrors acting odd.

Hey everyone, I bought a 2004 325 coupe not too long ago and the power mirrors didn't work. Today I tried to fix it. I tested the switch on the drivers side door and it worked. I looked in the fuse box next. Fuse 31 wasn't blown, but fuse 57 was missing completely. I put a new fuse in the 57 slot and now the mirrors move, but they only move all the way. To clarify, if I tap the 'joystick' to the left, the mirror will traverse all the way to the left even though I only briefly touched the joystick. It does this in the up, down, and right directions too. Any advice is greatly appreciated! Thanks!
Nolan_R is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 07-21-2016, 11:10 AM   #2
mwk4Jesus
Registered User
 
Join Date: Dec 2010
Location: North Carolina
Posts: 71
My Ride: 2004 330Ci 6M
Mine are doing the same thing, even after replacing the switch. I would also appreciate any help that can be given.
__________________


Romans 8:28
mwk4Jesus is offline   Reply With Quote
Old 07-22-2016, 05:12 AM   #3
Landlorder
Registered User
 
Join Date: Aug 2012
Location: London and Bristol
Posts: 409
My Ride: 330CI Sport
I took apart the switch and cleaned the pins inside with a Stanley knife... scraping at it to make it shinier - solved problem with power fold button not working. Can't remember if the mirror control was working or not at the time. Also try crimping pins inside plug to make tighter maybe?
__________________
Landlorder is offline   Reply With Quote
Reply

Tags
fuse 31, fuse 57, mirror, mirror motor

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 05:23 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
(c) 1999 - 2016 performanceIX Inc - privacy policy - terms of use