E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > ///M3 Forum

///M3 Forum
The BMW E46 ///M3 is the M version E46 and puts out an amazing 333 HP and 262 lb-ft of torque at stock specs! There are an amazing amount of modifications for both the coupe and convertible models so read up and get started modifying your cars today!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 12-10-2016, 08:39 PM   #1
anonymousM3
Registered User
 
Join Date: Dec 2016
Location: earth
Posts: 1
My Ride: m3
Strange Squeal? SMG?

Before I start tearing my car apart, I want knowledgeable individuals to weigh in. So short back story of the issue. This is my wife's daily. 02 M3 SMG. Approx 146k miles. She called me one day, said the car had a strange smell and started to die or shudder, something. And the SMG cog light came on. She pulled over and shut it off. I went to go get the car and it wouldn't start. A couple days of headaches later, I cleared all codes, and the error 59 stayed. I unplugged the GPS, and the car started, but it has a high pitched squeal. Think of a slipping belt next to a megaphone. I took the car to a local shop and they said SMG pump needed to be replaced. It's a reputable shop, but I have heard of shops misdiagnosing pumps before since it's the go to. My only concern before I go through changing it is the loud squeal and burning smell. I cannot find anything from anyone else who has this issue. The shop said it was the pump "going crazy".

Additional info: the pump primes on unlocking the door, I changed the salmon relay, the 40 amp fuse is fine.

I just want other opinions. I have already accepted replacing the pump, but I would like to hear other opinions or confirmations before I go through the trouble.
anonymousM3 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 12-12-2016, 07:46 AM   #2
Commando
Registered User
 
Join Date: Sep 2011
Location: Western Australia
Posts: 925
My Ride: '02 325Ci MT '04 M3
Ok so is the squeal coming from the SMG hydraulic pump?
__________________
Commando is offline   Reply With Quote
Old 12-12-2016, 11:15 AM   #3
mooninite
Registered User
 
Join Date: May 2006
Location: Texas
Posts: 415
My Ride: M3, X5
Error 59? 59 what? Unplugged the GPS? The BMW GPS? Your personal GPS?

Too many random statements in your post.

If the pump is activating it is NOT the "salmon relay". You wasted $15 there. Gets your codes read with INPA or Rheingold.
mooninite is offline   Reply With Quote
Old 12-12-2016, 11:33 AM   #4
crazyazz
Registered User
 
Join Date: Mar 2014
Location: Australia
Posts: 115
My Ride: 2002 M3
GPS = gear position sensor

CODE 59 clutch actuator dynamic

Wonder if something has gone bad with your clutch and or its actuation? Could explain the smell?

Google found this:

M3 has 58k miles.

Complaint: M3 started making loud grinding noise..stalled while driving...engine has no crank/no start. SMG light is lit up. FC 59 or 3B for actuation, clutch, dynamic.

Cause: Plastic ball pin at one end of clutch fork broke causing the piston to push further on the fork thus hitting the pressure plate. Spinning pressure plate grinded some metal off of the clutch fork making it thin enough for the piston to punch a hole through it. Clutch is now inop.

Correction: Removed transmission and replace ball pin, spring clip, clutch fork, and new clutch assembly.

I have done over 100 launch control functions and numerous HPDE events and the clutch still looks good. Not going to take any chances and just replace the pressure plate and disc.

Last edited by crazyazz; 12-12-2016 at 11:35 AM.
crazyazz is offline   Reply With Quote
Old 12-19-2016, 08:00 PM   #5
Simann
Registered User
 
Join Date: Jul 2009
Location: Tennessee
Posts: 73
My Ride: 2005 E46 M3
Good find! It's always the small stuff that breaks and causes catastrophic failures. LOL
__________________
2005 Silvergrau E46 M3 SMG
Simann is offline   Reply With Quote
Reply

Tags
smg, smg pump, transmission

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 06:39 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
(c) 1999 - 2016 performanceIX Inc - privacy policy - terms of use