E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 01-16-2017, 11:37 AM   #1
imallthewayup
Registered User
 
Join Date: Mar 2016
Location: Orlando
Posts: 18
My Ride: 330i
Alternator, Or Batter?

Hey guys,
So i drove my car about 10 miles and started and drove good. Then i stopped at the store and when i went to turn my car on it stuttered, was about to start but died. I jumped it and it drove good, went to autozone and they said it was a bad alternator. Next day i jumped it and it drove fine so i was wondering if it is really the alternator or the battery or something else. Just want some advice before i get a new alternator or battery

Basically:
- Car not running: 9 v
- Car running: 14 v
- When jumped it starts right up and when i shut it off it starts right up. Doesnt start after sitting after an hour
- Dont drive the car much, maybe 30-50 miles per week
- When driving car runs fine

Also not sure if its related or not but ac only works when i drive on higher speeds it starts blowing cold but other than that nothing blows out, and i have the brake light on and exclamation on dash but those have happened a month or two ago.

Thanks!!

Last edited by imallthewayup; 01-16-2017 at 11:38 AM.
imallthewayup is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 01-16-2017, 11:42 AM   #2
Clovett
Registered User
 
Join Date: Jul 2016
Location: South Carolina
Posts: 195
My Ride: 330ci
Quote:
Originally Posted by imallthewayup View Post
Hey guys,
So i drove my car about 10 miles and started and drove good. Then i stopped at the store and when i went to turn my car on it stuttered, was about to start but died. I jumped it and it drove good, went to autozone and they said it was a bad alternator. Next day i jumped it and it drove fine so i was wondering if it is really the alternator or the battery or something else. Just want some advice before i get a new alternator or battery

Basically:
- Car not running: 9 v
- Car running: 14 v
- When jumped it starts right up and when i shut it off it starts right up. Doesnt start after sitting after an hour
- Dont drive the car much, maybe 30-50 miles per week
- When driving car runs fine

Also not sure if its related or not but ac only works when i drive on higher speeds it starts blowing cold but other than that nothing blows out, and i have the brake light on and exclamation on dash but those have happened a month or two ago.

Thanks!!
Sounds like a bad battery to me. If it jumps to 14 volts from 9 volts when it's running it appears to be charging. If it's charging to 14 volts check the battery voltage when you first park it and see if it's not 12+ volts. If it is and drops to 9 volts over night either the battery is done or you have something draining the battery.

At that point check it when you park it for the 12+ volts then you need to be able to disconnect the battery and see if it's 9 or 12 volts the next day. Others can tell you the best way to do this and not lock yourself out of your car.
Clovett is offline   Reply With Quote
Old 01-17-2017, 03:51 PM   #3
imallthewayup
Registered User
 
Join Date: Mar 2016
Location: Orlando
Posts: 18
My Ride: 330i
imallthewayup

Quote:
Originally Posted by Clovett View Post
Sounds like a bad battery to me. If it jumps to 14 volts from 9 volts when it's running it appears to be charging. If it's charging to 14 volts check the battery voltage when you first park it and see if it's not 12+ volts. If it is and drops to 9 volts over night either the battery is done or you have something draining the battery.

At that point check it when you park it for the 12+ volts then you need to be able to disconnect the battery and see if it's 9 or 12 volts the next day. Others can tell you the best way to do this and not lock yourself out of your car.
Thanks I will keep an eye on my battery. I have it full charged now and will see if something is draining my battery. This maybe a dumb question but are the windows supposed to roll down when the keys are out
imallthewayup is offline   Reply With Quote
Old 01-17-2017, 04:57 PM   #4
M_3_X
Registered User
 
Join Date: Sep 2009
Location: Memphis, TN
Posts: 132
My Ride: E46M, 330Xi, E30, X3
Quote:
Originally Posted by imallthewayup View Post
- Car not running: 9 v
- Car running: 14 v
^^There's your answer.
__________________
2002 ///M3 Coupe, Steel Gray, black leather, HK, 6MT.(01/2015-current)
2005 X3 3.0i ZPP, Htd seats, Htd strng whl, Black Sapphire on Terracotta.(08/2008-current)
1991 325i Convertible, 5MT, htd seats
2004 330Xi Orient Blue, 6MT, Sport, Premium - Son
1995 ///M3 Coupe, Luxury, MT, Htd seats, Cosmos Black.(11/2011-01/2015)
2003 325Cic Orient Blue, Premium (03/2007- 03/2010)
River City Bimmers - BMW CCA Chapter
M_3_X is offline   Reply With Quote
Old 01-17-2017, 05:45 PM   #5
imallthewayup
Registered User
 
Join Date: Mar 2016
Location: Orlando
Posts: 18
My Ride: 330i
Quote:
Originally Posted by M_3_X View Post
^^There's your answer.
Im a little retarded, does that mean it is the battery? I charged my battery and today it was running good, staying at about 12.4 V
imallthewayup is offline   Reply With Quote
Old 01-17-2017, 05:48 PM   #6
tommy d
Registered User
 
Join Date: Nov 2012
Location: Lehigh Valley, PA
Posts: 336
My Ride: 2005 330i
yes, battery needs to be min. 12V
tommy d is offline   Reply With Quote
Old 01-17-2017, 05:50 PM   #7
imallthewayup
Registered User
 
Join Date: Mar 2016
Location: Orlando
Posts: 18
My Ride: 330i
Quote:
Originally Posted by tommy d View Post
yes, battery needs to be min. 12V
ok thank you
imallthewayup is offline   Reply With Quote
Old 01-18-2017, 11:02 PM   #8
imallthewayup
Registered User
 
Join Date: Mar 2016
Location: Orlando
Posts: 18
My Ride: 330i
Today I was driving it around and when I went to park it within 2 seconds the battery light flashed on and I died. Then I waited about 2 hours and was able to drive it home, without stopping on any lights. Now I'm sitting in my drive way and the volts are constantly jumping all over the place woth the car staying on from 13-14.5 v, my lights are lightly flashing and the engine is slightly bogging but staying running. When the car is parked it's at 11.4 v and I'm able to turn it on.

Also I do notice that if I turn off the car with the lights on and stuff and let it drop to about 11.5 when I turn on the car it drops to 9v then jumps to 14 v. Im provably over thinking this, anyway I just bought an alternator hope that fixes it.

Last edited by imallthewayup; 01-18-2017 at 11:02 PM.
imallthewayup is offline   Reply With Quote
Old 01-18-2017, 11:09 PM   #9
shiftyshadow17
Registered User
 
Join Date: Dec 2016
Location: Ottawa
Posts: 241
My Ride: 2003 325xi
Quote:
Originally Posted by imallthewayup View Post
Today I was driving it around and when I went to park it within 2 seconds the battery light flashed on and I died. Then I waited about 2 hours and was able to drive it home, without stopping on any lights. Now I'm sitting in my drive way and the volts are constantly jumping all over the place woth the car staying on from 13-14.5 v, my lights are lightly flashing and the engine is slightly bogging but staying running. When the car is parked it's at 11.4 v and I'm able to turn it on.

Also I do notice that if I turn off the car with the lights on and stuff and let it drop to about 11.5 when I turn on the car it drops to 9v then jumps to 14 v. Im provably over thinking this, anyway I just bought an alternator hope that fixes it.


you should charge your battery too.
shiftyshadow17 is offline   Reply With Quote
Old 01-18-2017, 11:11 PM   #10
imallthewayup
Registered User
 
Join Date: Mar 2016
Location: Orlando
Posts: 18
My Ride: 330i
Quote:
Originally Posted by shiftyshadow17 View Post
you should charge your battery too.
Yeah I just charged my battery overnight but not full
imallthewayup is offline   Reply With Quote
Reply

Tags
alternator, battery

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 12:11 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
(c) 1999 - 2016 performanceIX Inc - privacy policy - terms of use