E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 01-31-2017, 03:03 PM   #1
rako92
Registered User
 
Join Date: Jun 2016
Location: Bulgaria
Posts: 42
My Ride: E46 318i M43
E46 Cruise Control Does not Work

Hey guys. I have issue with my cruise control (E46 old style, mechanical). Until couple of weeks ago it was working fine. Now, the green light on the dash stays on until I press the + button. Then it does not keep the speed and some seconds later the light turns off. I cannot switch it on with the I/O button until I stop the engine and start it again (or turn the ignition). Any ideas?
rako92 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 02-01-2017, 09:24 AM   #2
markusmarkus
Registered User
 
Join Date: Jul 2008
Location: USA
Posts: 5,642
My Ride: 2001 330Ci
The DME/ECU controls the cruise control. The DME/ECU won't allow the cruise control to operate when the MAF is acting up. Have the DME/ECU scanned for codes and post them.
markusmarkus is offline   Reply With Quote
Old 02-01-2017, 09:28 AM   #3
rako92
Registered User
 
Join Date: Jun 2016
Location: Bulgaria
Posts: 42
My Ride: E46 318i M43
Okay. I had my MAF replaced as it was faulty and was showing as an error code, since then I never got that error again and the cruise was working fine. I will try to scan tonight in case there is something new and will reply. Thanks
rako92 is offline   Reply With Quote
Old 02-01-2017, 10:05 AM   #4
rako92
Registered User
 
Join Date: Jun 2016
Location: Bulgaria
Posts: 42
My Ride: E46 318i M43
P0420 is what appeared as error code (pending) and I cleared it. Now there are no faults logged or pending, but the situation is the same. It is the only diagnostics I have available to use today.
rako92 is offline   Reply With Quote
Old 02-01-2017, 11:38 AM   #5
Geo31
Ironman
 
Join Date: Mar 2003
Location: Willis, TX, USA
Posts: 2,953
My Ride: 98 M-Z3, 01 325iT
I am not sure about the E46, but my E36/7 will not allow the cruise control to operate if there are any codes. Check your codes again and see if it came back. Some codes you have to drive a while to completely clear them IIRC.
__________________
George Roffe

Swim: 2.4 Miles
Bike: 112 Miles
Run: 26.2 Miles
Brag: For the rest of your life


Geo31 is online now   Reply With Quote
Old 02-01-2017, 03:50 PM   #6
rako92
Registered User
 
Join Date: Jun 2016
Location: Bulgaria
Posts: 42
My Ride: E46 318i M43
Actually, after a couple ot starts and stops of the engine (and after the initial clearof the fault), the cruise seems to work again :-) I will have a look what is this code and will have the car serviced in case it is something important, but as it causes the cruise to stop working, I suppose it is something important. Thanks, both.
rako92 is offline   Reply With Quote
Old 02-01-2017, 04:56 PM   #7
Geo31
Ironman
 
Join Date: Mar 2003
Location: Willis, TX, USA
Posts: 2,953
My Ride: 98 M-Z3, 01 325iT
The code is CAT efficiency (I looked it up before I responded earlier). Yeah, I think some codes need to be cycled something like 3x before it's completely clear.
__________________
George Roffe

Swim: 2.4 Miles
Bike: 112 Miles
Run: 26.2 Miles
Brag: For the rest of your life


Geo31 is online now   Reply With Quote
Old 02-12-2017, 04:37 AM   #8
rako92
Registered User
 
Join Date: Jun 2016
Location: Bulgaria
Posts: 42
My Ride: E46 318i M43
Update, guys. Since the cruise worked twice I never had the opportunity to drive with thos car on a road that I can test it again, only urban. Now it does not work again... Checked it with INPA yesterday, no fault codes at all. The brake lights are fine. The MAF is fine as well. No pending faults... The light comes on (although the cruise does not work, the speed just drops) but when I press brakes it goes off and never switches on again before I start the engine again. Found other topics with this issue, but I have checked all the reasons discussed and it seems it's neither of them. Any further options?

Last edited by rako92; 02-12-2017 at 04:38 AM.
rako92 is offline   Reply With Quote
Old 02-12-2017, 08:56 AM   #9
Geo31
Ironman
 
Join Date: Mar 2003
Location: Willis, TX, USA
Posts: 2,953
My Ride: 98 M-Z3, 01 325iT
What were the other issues you checked out? It helps to narrow things down.
__________________
George Roffe

Swim: 2.4 Miles
Bike: 112 Miles
Run: 26.2 Miles
Brag: For the rest of your life


Geo31 is online now   Reply With Quote
Old 02-12-2017, 09:01 AM   #10
rako92
Registered User
 
Join Date: Jun 2016
Location: Bulgaria
Posts: 42
My Ride: E46 318i M43
As I said, there are no fault codes (no pending as well), the MAF is new and seems it is ok as well. The brake lights work so this is not the cause as well. As it is 2000 model it is not electronic and uses the mechanism to physically control the throttle, I checked this and nothing is stuck, for example. However, when I use brake, the cruise light goes off. And it does not work even when the light is on. I dont know what other issues may be the cause to check them out as well
rako92 is offline   Reply With Quote
Old 02-12-2017, 09:25 AM   #11
Geo31
Ironman
 
Join Date: Mar 2003
Location: Willis, TX, USA
Posts: 2,953
My Ride: 98 M-Z3, 01 325iT
Sounds like the electronics are working correctly, as least on the surface. I've not looked at our cruise control closely, but is the 2000 unit a vacuum controlled unit (my older cars had vacuum controlled units).
__________________
George Roffe

Swim: 2.4 Miles
Bike: 112 Miles
Run: 26.2 Miles
Brag: For the rest of your life


Geo31 is online now   Reply With Quote
Old 02-13-2017, 07:51 AM   #12
markusmarkus
Registered User
 
Join Date: Jul 2008
Location: USA
Posts: 5,642
My Ride: 2001 330Ci
What brand is the new MAF?
markusmarkus is offline   Reply With Quote
Reply

Tags
cruise control, e46, tempomat

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 12:29 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
(c) 1999 - 2016 performanceIX Inc - privacy policy - terms of use