DIY E46 Media Centre: MP3, videos, Digital Radio, Digital TV? - Page 72 - E46Fanatics E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > BAVSOUND Mobile Electronics Forum

BAVSOUND Mobile Electronics Forum
Have all your A/V and electronics questions answered here. Ipods, A/V, Radar Detectors Oh My!
Sponsored by BAVSOUND

Reply
 
Thread Tools Search this Thread Rating: Thread Rating: 69 votes, 4.99 average.
Old 03-20-2017, 04:46 AM   #1421
WazKid
Registered User
 
Join Date: Mar 2016
Location: CA
Posts: 24
My Ride: E83
Has anyone got a DAB+ solution working with the beautiful pibus system?

My government are shutting down the FM broadcast in my country so i'll soon be without radio in the car.

Last edited by WazKid; 03-20-2017 at 04:46 AM.
WazKid is offline   Reply With Quote
Old 03-20-2017, 05:35 PM   #1422
Shled
Registered User
 
Join Date: Apr 2008
Location: Boston
Posts: 3
My Ride: Dinan s3 e38 740i
Quote:
Originally Posted by WazKid View Post
Has anyone got a DAB+ solution working with the beautiful pibus system?

My government are shutting down the FM broadcast in my country so i'll soon be without radio in the car.
Here

Last edited by Shled; 03-20-2017 at 05:35 PM.
Shled is offline   Reply With Quote
Old 03-21-2017, 02:33 AM   #1423
BMW 740iL NL
Registered User
 
Join Date: Feb 2016
Location: NL
Posts: 48
My Ride: 1998 BMW 740iL
Quote:
Originally Posted by WazKid View Post
Has anyone got a DAB+ solution working with the beautiful pibus system?

My government are shutting down the FM broadcast in my country so i'll soon be without radio in the car.
I play the radio station on my iPhone with the TuneIn Radio app and then use airplay to stream the audio to Kodi on my Pibus. Works very good. All you need is a wifi router attached to your raspberry Pibus. I use a TP-Link TL-MR3020 and before also the cheaper TL-WR802N

Last edited by BMW 740iL NL; 03-21-2017 at 02:35 AM.
BMW 740iL NL is offline   Reply With Quote
Old 03-21-2017, 02:45 AM   #1424
PeteAU
Registered User
 
Join Date: Oct 2011
Location: Melbourne
Posts: 475
My Ride: 330i
Quote:
Originally Posted by WazKid View Post
Any progress with this, getting data from the ibus? Sounds really interesting.
Ahhh no. I didn't get any help with the Kodi side of it.
PeteAU is offline   Reply With Quote
Old 03-21-2017, 06:01 AM   #1425
bmwdud121
Registered User
 
Join Date: Nov 2015
Location: Melbourne
Posts: 85
My Ride: 2002 330i
Sorry, my bad.
I got distracted at work and it fell to the wayside. I'll have another go soon
bmwdud121 is offline   Reply With Quote
Old 03-21-2017, 01:04 PM   #1426
WazKid
Registered User
 
Join Date: Mar 2016
Location: CA
Posts: 24
My Ride: E83
Quote:
Originally Posted by BMW 740iL NL View Post
I play the radio station on my iPhone with the TuneIn Radio app and then use airplay to stream the audio to Kodi on my Pibus. Works very good. All you need is a wifi router attached to your raspberry Pibus. I use a TP-Link TL-MR3020 and before also the cheaper TL-WR802N
Tnx man. You tipped me about this a while ago. What setup do you use? I pressume you are streaming the radio channel through 3G/4G on your phone and you airplay this to the pi. Is it possible to use 3G/4G on the phone and at the same time have the phone connected to the wifi (nano router)?
WazKid is offline   Reply With Quote
Old 03-21-2017, 01:05 PM   #1427
WazKid
Registered User
 
Join Date: Mar 2016
Location: CA
Posts: 24
My Ride: E83
Quote:
Originally Posted by bmwdud121 View Post
Sorry, my bad.
I got distracted at work and it fell to the wayside. I'll have another go soon
I'm sorry I can't be any help in this. No skillz
WazKid is offline   Reply With Quote
Old 03-21-2017, 05:30 PM   #1428
BMW 740iL NL
Registered User
 
Join Date: Feb 2016
Location: NL
Posts: 48
My Ride: 1998 BMW 740iL
Quote:
Originally Posted by WazKid View Post
Is it possible to use 3G/4G on the phone and at the same time have the phone connected to the wifi (nano router)?
Hmm, good point! That is actually why I switched to the TL-MR3020 router with a 3G data stick, a huawei E3533.
BMW 740iL NL is offline   Reply With Quote
Old 03-21-2017, 05:31 PM   #1429
MM007
Registered User
 
Join Date: Sep 2016
Location: Melbourne
Posts: 38
My Ride: E46 M3
Quote:
Originally Posted by WazKid View Post
Tnx man. You tipped me about this a while ago. What setup do you use? I pressume you are streaming the radio channel through 3G/4G on your phone and you airplay this to the pi. Is it possible to use 3G/4G on the phone and at the same time have the phone connected to the wifi (nano router)?
If you're using Openelec 7 and an rpi3 or wifi-enabled rpi2 you can switch on the tethered AP more in settings. You can then connect your phone to the AP, however this will stop you from using 3G/4G. To use both the wifi & 3G/4G
you will have to set a static IP address & appropriate subnet mask (usually 255.255.255.0) and leave the default router & DNS entries blank on your phone.

I use it this way with Apple Music and it works flawlessly.

This probably works the same way on other distros but since I only use openelec I can't comment on the others.

More info here: http://forum.e46fanatics.com/showthr...=#post17068373

Last edited by MM007; 03-21-2017 at 09:54 PM.
MM007 is offline   Reply With Quote
Old 03-22-2017, 02:29 PM   #1430
WazKid
Registered User
 
Join Date: Mar 2016
Location: CA
Posts: 24
My Ride: E83
Quote:
Originally Posted by MM007 View Post
If you're using Openelec 7 and an rpi3 or wifi-enabled rpi2 you can switch on the tethered AP more in settings. You can then connect your phone to the AP, however this will stop you from using 3G/4G. To use both the wifi & 3G/4G
you will have to set a static IP address & appropriate subnet mask (usually 255.255.255.0) and leave the default router & DNS entries blank on your phone.

I use it this way with Apple Music and it works flawlessly.

This probably works the same way on other distros but since I only use openelec I can't comment on the others.

More info here: http://forum.e46fanatics.com/showthr...=#post17068373
Great info! Running OpenElec 6.0.3 and rpi2 with TP-Link nano 802N Router. My iphone 6 is connected to the wifi and recognizes that wifi has no internet connection with the static setup and therfore uses 4G. But I can't seem to Airplay to Kodi? Can't even find it in the Airplay to selection. Read it could be because of ios 10.2.1 and that someone got it working by changeing the Airplay settings in kodi to just audio, not video and picture with expert settings? I changed to expert(left bottom) but can't seem to fint the "just audio" option under the Airplay settings, just a choice of iOS 8 mode which is already selected. Will try unselecting that later. Maybe I need to upgrade to OE 7. Does anyone have choises to select just audio under Airplay on OE 7? I have annoucing selected in Zeroconf. Other suggestions?

Last edited by WazKid; 03-22-2017 at 02:31 PM.
WazKid is offline   Reply With Quote
Old 03-22-2017, 07:10 PM   #1431
MM007
Registered User
 
Join Date: Sep 2016
Location: Melbourne
Posts: 38
My Ride: E46 M3
Quote:
Originally Posted by WazKid View Post
But I can't seem to Airplay to Kodi? Can't even find it in the Airplay to selection. Read it could be because of ios 10.2.1 and that someone got it working by changeing the Airplay settings in kodi to just audio, not video and picture with expert settings? I changed to expert(left bottom) but can't seem to fint the "just audio" option under the Airplay settings, just a choice of iOS 8 mode which is already selected. Will try unselecting that later. Maybe I need to upgrade to OE 7. Does anyone have choises to select just audio under Airplay on OE 7? I have annoucing selected in Zeroconf. Other suggestions?
I'll take a look at my setup and take some photos, hopefully that will help you get it working. I do remember that "just audio" should be on (no video). More info shortly.
MM007 is offline   Reply With Quote
Old 03-23-2017, 12:19 AM   #1432
MM007
Registered User
 
Join Date: Sep 2016
Location: Melbourne
Posts: 38
My Ride: E46 M3
Quote:
Originally Posted by MM007 View Post
I'll take a look at my setup and take some photos, hopefully that will help you get it working. I do remember that "just audio" should be on (no video). More info shortly.
This is what I have on OpenElec 7: (sorry about the poor quality..)
MM007 is offline   Reply With Quote
Old 03-23-2017, 02:40 AM   #1433
MM007
Registered User
 
Join Date: Sep 2016
Location: Melbourne
Posts: 38
My Ride: E46 M3
Quote:
Originally Posted by WazKid View Post
But I can't seem to Airplay to Kodi? Can't even find it in the Airplay to selection.
Are you referring to not being able to see the airplay icon on the iPhone? Or after touching the airplay icon you cannot see the Kodi as a target?
MM007 is offline   Reply With Quote
Old 03-23-2017, 04:27 AM   #1434
WazKid
Registered User
 
Join Date: Mar 2016
Location: CA
Posts: 24
My Ride: E83
Quote:
Originally Posted by MM007 View Post
Are you referring to not being able to see the airplay icon on the iPhone? Or after touching the airplay icon you cannot see the Kodi as a target?
I have the airplay option in Spotify, Musicplayer etc. but after touching the airplay icon I can't see the Kodi as a target.

Great pic! I don't have that option in OE6.0.3, instead it is an option to select support for ios8. Seems like I have to try upgrading to OE7

Last edited by WazKid; 03-23-2017 at 04:28 AM.
WazKid is offline   Reply With Quote
Old 03-23-2017, 08:02 AM   #1435
BMW 740iL NL
Registered User
 
Join Date: Feb 2016
Location: NL
Posts: 48
My Ride: 1998 BMW 740iL
Quote:
Originally Posted by MM007 View Post
If you're using Openelec 7 and an rpi3 or wifi-enabled rpi2 you can switch on the tethered AP more in settings. You can then connect your phone to the AP, however this will stop you from using 3G/4G. To use both the wifi & 3G/4G
you will have to set a static IP address & appropriate subnet mask (usually 255.255.255.0) and leave the default router & DNS entries blank on your phone.

I use it this way with Apple Music and it works flawlessly.

This probably works the same way on other distros but since I only use openelec I can't comment on the others.

More info here: http://forum.e46fanatics.com/showthr...=#post17068373
Does your Kodi then also get to use the internet connection from your phone?

@MM007 I managed to get airplay working with your set up. It took a while though as Kodi was immediately available as an airplay speaker but airplay would not connect. It took a couple of minutes but then it started playing. Very nice! It also displays the music info and picture on-screen

@Wazkid I think airplay should also work on 6.0.3. I remember using it at home on my tv while connected to my home network

Last edited by BMW 740iL NL; 03-23-2017 at 09:54 AM.
BMW 740iL NL is offline   Reply With Quote
Old 03-23-2017, 01:25 PM   #1436
WazKid
Registered User
 
Join Date: Mar 2016
Location: CA
Posts: 24
My Ride: E83
Quote:
Originally Posted by BMW 740iL NL View Post
@Wazkid I think airplay should also work on 6.0.3. I remember using it at home on my tv while connected to my home network
What iOS version are you on?

Last edited by WazKid; 03-23-2017 at 01:25 PM.
WazKid is offline   Reply With Quote
Old 03-23-2017, 01:28 PM   #1437
BMW 740iL NL
Registered User
 
Join Date: Feb 2016
Location: NL
Posts: 48
My Ride: 1998 BMW 740iL
Quote:
Originally Posted by wazkid View Post
what ios version are you on?
10.2
BMW 740iL NL is offline   Reply With Quote
Old 03-23-2017, 03:54 PM   #1438
MM007
Registered User
 
Join Date: Sep 2016
Location: Melbourne
Posts: 38
My Ride: E46 M3
Quote:
Originally Posted by BMW 740iL NL View Post
Does your Kodi then also get to use the internet connection from your phone?
No, unfortunately not. The AP is Kodi and that doesn't have an internet connection. The phone is just a client. The other downside to using Kodi as an AP is that it will no longer connect to your home network to download updates, sync music, etc.
Maybe someone has has managed to use something like IFTTT to switch wifi modes on Kodi. (Ie. when geolocation = home then switch off AP)

Quote:
Originally Posted by BMW 740iL NL View Post
@MM007 I managed to get airplay working with your set up. It took a while though as Kodi was immediately available as an airplay speaker but airplay would not connect. It took a couple of minutes but then it started playing.
Does this happen every time or just the first time you set it up? Mine connects straight away.
AirPlay over wifi also has two other disadvantages: it won't pause when you switch off your BMW and it won't automatically reconnect and start playing when you get back into the car. Bluetooth does both of these things, but I'm having trouble with mine. Bluetooth is another can of worms for me and I'll have to ask on the forum for help!

We should all put together a FAQ!

Last edited by MM007; 03-23-2017 at 04:29 PM.
MM007 is offline   Reply With Quote
Old 03-23-2017, 04:15 PM   #1439
MM007
Registered User
 
Join Date: Sep 2016
Location: Melbourne
Posts: 38
My Ride: E46 M3
Has anyone got bluetooth streaming working successfully on a an rpi 3 with an external bluetooth dongle? I could have sworn mine was working but at the moment my iPhone connects to the rpi, sees it as a bluetooth device but when I stream to it no sound comes out the Kodi.
I'm not sure if it is connecting to the internal bluetooth or to the dongle. I'm drawing a blank at the moment on where and how to check.
Everything else is working fine, including Airplay streaming over wifi.
Any ideas?
MM007 is offline   Reply With Quote
Old 03-23-2017, 05:28 PM   #1440
WazKid
Registered User
 
Join Date: Mar 2016
Location: CA
Posts: 24
My Ride: E83
Quote:
Originally Posted by BMW 740iL NL View Post
10.2
Hmm. This is strange. Now I have connected both a MacBook Air and an iPhone6 to the TL-WR802N and I should be able to airplay from the phone to the mac except it is not listed in the airplay menu on the phone. When I disconnect the phone and the macbook and reconnect them to my home wifi airplay works fine.

Did you use a special setup on the TL-WR802N?

Last edited by WazKid; 03-23-2017 at 05:33 PM.
WazKid is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 06:37 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
(c) 1999 - VerticalScope Inc. All rights reserved.