E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 05-03-2016, 12:29 AM   #1
MV330xi
Registered User
 
Join Date: May 2016
Location: Mill Valley, CA
Posts: 2
My Ride: 330xi
Occasional P1345 after warm and under load, clears after restart

Hi - 2002 330xi with 99k miles. Occasionally when engine is warm and running under load (going up a moderate hill on hwy), the car suddenly runs very rough and throws the CEL and a P1345 code (Misfire Cylinder 2 with Fuel Cut-off). When I shut off the engine and restart, the car runs fine and the CEL shuts off (with the P1345 show as pending when pulled with code reader). This is the third time it has happened over a span of a few months, but not sure which cylinder it was last time b/c didn't pull the code. Runs fine between occurrences. Any ideas?

Spark plugs were changed 1k miles ago with NGK Laser Platinums (at 25k from last change) and didn't fix the issue - all plugs looked fine, but cyl 6 had a small amount of oil on threads. All coils+boots were replaced with OEM Brembi at 93k miles. All 4 O2 sensors were replaced at 98k. Replace fuel pump with OEM and fuel filter at 80k. Replaced DISA valve, lower intake boot, vanos line and PCV system at 81k, if it matters.

Thank you for any thoughts...

Last edited by MV330xi; 05-03-2016 at 12:47 AM. Reason: (added fuel pump+filter replacement detail)
MV330xi is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 05-03-2016, 12:39 AM   #2
swordsman11868
Registered User
 
Join Date: Aug 2006
Location: Las Vegas
Posts: 1,323
My Ride: 2003 325i
1. Fuel pump/filter

2. Maybe a vacuum leak.
__________________
I'm just here to change the world.
BMW Wiki: http://www.bimmerfest.com/wiki/index.php

E46Fanatics inspiration Robolop: http://forum.e46fanatics.com/showthr...87566&page=101

2016 Beheadings in Saudi Arabia: 92.
swordsman11868 is offline   Reply With Quote
Old 05-03-2016, 04:29 AM   #3
jfoj
OEM ///Member
 
Join Date: Nov 2009
Location: Fairfax, VA USA
Posts: 22,986
My Ride: 330CiC, M5, X5, E93
Need data, Freeze Frame and Fuel Trim info

Load related misfires are not usually vacuum leak related and I see the fuel pump has been replaced.

I would be inspecting the DISA and cylinder #2 worries me a bit due to some DME related problem.

But would like to see some data before we go any further.
__________________
Solve your misfires, lean codes, rough idle - http://forum.e46fanatics.com/showthread.php?t=897616

Fuel pump failures - http://forum.e46fanatics.com/showthread.php?t=929501

Temp Info - http://forum.e46fanatics.com/showthread.php?t=964491

Hidden OBC Menu - Check Voltage, Temp, Fuel Level - http://forum.e46fanatics.com/showthread.php?t=239619

E46/E39 GM5 Door Lock Info - www.bmwgm5.com

Lower hose temp switch O-ring - BMW #13621743299
jfoj is online now   Reply With Quote
Old 05-04-2016, 12:29 AM   #4
MV330xi
Registered User
 
Join Date: May 2016
Location: Mill Valley, CA
Posts: 2
My Ride: 330xi
Thanks for the initial thoughts. I tried to pull the freeze data, but there wasn't any. Although the CIL turned on when it initially faulted, when I restarted the light went out and when I pulled the codes it says it was 'pending' and there wasn't any freeze frame and fuel trim data. The next time it happens, I'll try to pull the data before I restart and post what I find.
MV330xi is offline   Reply With Quote
Old 05-04-2016, 08:06 AM   #5
markusmarkus
Registered User
 
Join Date: Jul 2008
Location: USA
Posts: 6,041
My Ride: 2001 330Ci
Done load OBDFusion and buy the proper interface from Amazon.
markusmarkus is offline   Reply With Quote
Reply

Tags
330xi, misfire, p1345, warm

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 06:14 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
(c) 1999 - 2016 performanceIX Inc - privacy policy - terms of use