E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 11-07-2016, 09:19 PM   #1
Niko0128
Registered User
 
Join Date: Nov 2016
Location: Toronto, Canada
Posts: 3
My Ride: 2005 e46 330ci Zhp
Bmw 330ci Duncan cold air intake not working properly

So I installed a dinan cold air intake on my 2005 bmw 330ci, the long tube one that goes all the way down. I know someone who has the exact same one on his 323, and when he revs his engine you can instantly hear the deep sound the intake gives off. Mine only makes a similar sound above 4000rpm while driving. It'll only make a slight air suction sound while I'm driving it below 4000rpm or if I rev it in neutral. I don't think this is normal, I obviously want it to be working 100%. Does anyone know what the issue could be?

Last edited by Niko0128; 11-07-2016 at 10:23 PM.
Niko0128 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 11-07-2016, 10:13 PM   #2
generalvp
Registered User
 
Join Date: Sep 2013
Location: Twin Cities
Posts: 747
My Ride: 05 330ci ZHP
I think your problem is because its a duncan intake.
generalvp is offline   Reply With Quote
Old 11-07-2016, 10:22 PM   #3
Niko0128
Registered User
 
Join Date: Nov 2016
Location: Toronto, Canada
Posts: 3
My Ride: 2005 e46 330ci Zhp
Haha!! Holy I didn't even notice that!! It's obviously a typo!
Niko0128 is offline   Reply With Quote
Old 11-08-2016, 02:31 AM   #4
randy72877
Registered User
 
Join Date: Apr 2015
Location: Chicago
Posts: 159
My Ride: 01 330 sport 5m sil/
Maybe the other car has different exhaust. Or it has the muffler exhaust flap disconnected and the vacuum line capped.

Sent from my SAMSUNG-SM-G870A using Tapatalk
randy72877 is offline   Reply With Quote
Old 11-08-2016, 04:52 AM   #5
Niko0128
Registered User
 
Join Date: Nov 2016
Location: Toronto, Canada
Posts: 3
My Ride: 2005 e46 330ci Zhp
Quote:
Originally Posted by randy72877 View Post
Maybe the other car has different exhaust. Or it has the muffler exhaust flap disconnected and the vacuum line capped.

Sent from my SAMSUNG-SM-G870A using Tapatalk
I believe the other car has everything stock with the exhaust, while I have a muffler and res delete
Niko0128 is offline   Reply With Quote
Old 11-08-2016, 07:31 AM   #6
matt270avian
Registered User
 
Join Date: Nov 2015
Location: Keymar
Posts: 169
My Ride: 2002 325XI
Could just be the fact that you have different motors. Just double check all of your connections, and if you're really that worried you can smoke test it.
matt270avian is offline   Reply With Quote
Reply

Tags
330ci, bmw, cold air intake, dinan

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 03:57 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
(c) 1999 - 2016 performanceIX Inc - privacy policy - terms of use