E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 12-11-2016, 03:08 PM   #1
ryuutakenaka
Registered User
 
Join Date: Dec 2016
Location: USA
Posts: 1
My Ride: 325i
Intermittent transmission error

Hi everyone. This forum helped me on multiple occasions to fix my 325i However this time I can't find any relevant info.

My car (2005 325i) occasionally goes into the "limp mode". I would be driving (random speeds, sometimes happens at 60 mph, sometimes at 5 mph) and the transmission warning light ([!]) next to the gear selector (P,R,D) lights up. The car becomes sluggish when accelerating and is jerky when coming to a stop. When I turn the car off, wait ~30s and turn it back on the light disappears. It can reappear later after 10 miles or 500 miles (random). Once the light was accompanied by "service engine soon" but this light also went away after ~10 miles.

I read transmission codes with INPA, this is what I get:

2 errors in error memory. Error frequency: 3

- 145 CAN Moment reduction
- 146 CAN Moment interface

The errors say that they happened when upshifting 3->4 or 4->5. However, in one case when it says 3->4 I am certain it happened when I was pulling into my driveway at ~5 mph, so I don't know how accurate this is.

I found no other errors present that would be relevant to this.

Any help?
ryuutakenaka is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 12-11-2016, 07:29 PM   #2
RJLynn
Registered User
 
Join Date: Feb 2014
Location: Jersey Shore, PA
Posts: 66
My Ride: '01 330Ci 'vert
The transmission's control unit will ask the DME to reduce torque when shifting over the CAN bus. I'd be checking the CAN lines between the GKE and the DME in the E-Box before I went too nuts on anything else. I've noticed INPA to be slightly inaccurate in my experience, but I'm running the Alpina software on my ZF 5HP19. These transmissions default to 4th gear when errored out, so maybe that's why.
RJLynn is offline   Reply With Quote
Reply

Tags
can bus, inpa, transmission alert, transmission indicator, transmission light

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 09:02 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
(c) 1999 - 2016 performanceIX Inc - privacy policy - terms of use