E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 04-19-2017, 01:18 PM   #1
TWR
Registered User
 
Join Date: Jun 2016
Location: Lanc's UK
Posts: 45
My Ride: E46
2004 E46 Petrol

Hi all
There has been many tips / remedy's / advise tips on this issue & the problem still exits, the car has a Pulling away Surge/ hesitation, ever check has been done regards the Codes, I've had a Auto Electrician Vat Reg System ECU Check with a Code reader costing 2000, " NO FAULTS" where I take my car for the yearly MOT ( UK ) Check, the reader cost under 5000 " NO FAULTS" I have checked every flex pipe ( OK) Connections ( OK) Cleaned the MAF (DONE) No difference) replace with a used sensor, cleaned ( NO CHANGE) A full service with Bosch Plugs and checked the Leads, Coil Packs, Earth Connectors ( OK) the car has not long gone through a UK MOT, C/0, 100% no Issues, I use the best fuel for my car with a fuel Injection additive added each month on a full fill up, every possible bloody thing you can think of, the problem is still there, what the feck is it? the car is checked without fail every W/End, I don't go knocking the rse off the car & go at a steady speed road speed permitting, I have as read from this site, reset the Accelerator just in case some old boy has been a steady driver, the car has covered 130,000 miles, I would be grateful for a positive answer to this problem, Cheers from a P----sed off BMW Owner.
TWR is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 04-19-2017, 01:26 PM   #2
Spannerhead
Save the Manuals!
 
Spannerhead's Avatar
 
Join Date: Jan 2016
Location: Chattanooga, TN
Posts: 2,026
My Ride: '02 330i/5 slicktop
Have you read jfoj's threads?

Quote:
Solve your misfires, lean codes, rough idle - http://forum.e46fanatics.com/showthread.php?t=897616

Fuel pump failures - http://forum.e46fanatics.com/showthread.php?t=929501

Timing problem - forum.e46fanatics.com/showthread.php?t=966614
Also consider a smoke test. Time to learn to DIY, or prepare to shell out!
__________________

Current: '02 330i/5 '10 Mazda5 '72 240Z
Past: '85 GSL-SE '95 540i/6 '95 525i/5 '86 635CSi/5 '88 JZA70 '86 4K quattro '85 RX-7 S
Spannerhead is offline   Reply With Quote
Old 04-19-2017, 01:46 PM   #3
SSchwab
Registered User
 
Join Date: Jan 2015
Location: Oregon City Oregon
Posts: 411
My Ride: 99 328i, 00 Z3 2.8
Have you inspected your DISA, or replaced VANOS seals?
SSchwab is offline   Reply With Quote
Old 04-19-2017, 05:53 PM   #4
armenh7
Registered User
 
Join Date: Dec 2016
Location: California
Posts: 180
My Ride: 2002 325i
Quote:
Originally Posted by TWR View Post
Hi all
There has been many tips / remedy's / advise tips on this issue & the problem still exits, the car has a Pulling away Surge/ hesitation, ever check has been done regards the Codes, I've had a Auto Electrician Vat Reg System ECU Check with a Code reader costing 2000, " NO FAULTS" where I take my car for the yearly MOT ( UK ) Check, the reader cost under 5000 " NO FAULTS" I have checked every flex pipe ( OK) Connections ( OK) Cleaned the MAF (DONE) No difference) replace with a used sensor, cleaned ( NO CHANGE) A full service with Bosch Plugs and checked the Leads, Coil Packs, Earth Connectors ( OK) the car has not long gone through a UK MOT, C/0, 100% no Issues, I use the best fuel for my car with a fuel Injection additive added each month on a full fill up, every possible bloody thing you can think of, the problem is still there, what the feck is it? the car is checked without fail every W/End, I don't go knocking the rse off the car & go at a steady speed road speed permitting, I have as read from this site, reset the Accelerator just in case some old boy has been a steady driver, the car has covered 130,000 miles, I would be grateful for a positive answer to this problem, Cheers from a P----sed off BMW Owner.
As recommended by others, check your fuel pump, timing, disa, and for vacuum leaks. If your fuel pump is original, replace it. Also, once a week you should take your car out and drive it hard. For example, going on the highway and keeping your rpms around 3,000 rpms to help "clean" the internals. BMW made these engine in a way that they have to be driven hard.
armenh7 is offline   Reply With Quote
Old 04-20-2017, 03:34 AM   #5
TWR
Registered User
 
Join Date: Jun 2016
Location: Lanc's UK
Posts: 45
My Ride: E46
Hi all

Thank for your tips, I shall log them but still keep looking on here, the Issue is more annoying than anything else but like us all I want the car running perfect.

TWR
TWR is offline   Reply With Quote
Old 04-20-2017, 03:47 AM   #6
Landlorder
Registered User
 
Join Date: Aug 2012
Location: London and Bristol
Posts: 424
My Ride: 330CI Sport
Try not using the fuel additive.
__________________
Landlorder is offline   Reply With Quote
Old 04-20-2017, 03:52 AM   #7
GRD
Registered User
 
Join Date: Oct 2014
Location: Australia
Posts: 65
My Ride: 330ci convertible
Can you elaborate on what your problem is?
Do you mean the car responds very slowly to depressing the accelerator pedal from a standing start, so you then naturaly press it a little harder
and then suddenly the car wakes up and your passenger thinks your a wanabe grand prix driver?
GRD is offline   Reply With Quote
Old 04-20-2017, 04:14 AM   #8
GRD
Registered User
 
Join Date: Oct 2014
Location: Australia
Posts: 65
My Ride: 330ci convertible
Canyou elaborate on your issue?
Is it that the car responds slowly to depressing the pedal from a standing start
and then all of a sudden comes to life and your passenger thinks your a wanabe
grand prix driver?
GRD is offline   Reply With Quote
Old 04-20-2017, 07:11 AM   #9
markusmarkus
Registered User
 
Join Date: Jul 2008
Location: USA
Posts: 5,785
My Ride: 2001 330Ci
2004 E46 Petrol

First step: replace the spark plugs with NGK BKR6EQUP plugs. That's the plug BMW installed in your engine at the factory. These engines seem to be sensitive to spark plug differences.

Is the fuel pump original? The pump is good for about 5000 hours of operation. Yours may be soft failing in that it may not be producing the required volume at the proper pressure of 50psi.

Last edited by markusmarkus; 04-20-2017 at 07:12 AM.
markusmarkus is offline   Reply With Quote
Old 04-20-2017, 01:41 PM   #10
TWR
Registered User
 
Join Date: Jun 2016
Location: Lanc's UK
Posts: 45
My Ride: E46
GRD, On staring the car, no problem, tick over, no problem, 1st gear No Problem, from 1 >>2nd gear Hesitant / Surge, If I put my foot to the Floor it flies of like Sht off a shovel (Very Fast), If I ride the Clutch I can over ride the surge, this is where the issue is,


Mark, I replaced the last set of Plugs, they were NGK BKR6EQUP, the problem was still the same so I give the Bosch a try as a lot of sites state that the Bosch Plugs are Perfect.

The Pump is the Original as far as I know, I've had the car 14 Months, I've had all the previous Service details / reports, nothing has been indicated regards fuel issues, this I think would have shown up on the Emission Test (UK)
TWR is offline   Reply With Quote
Old 04-20-2017, 02:28 PM   #11
cvx5832
Registered User
 
Join Date: Mar 2009
Location: Walnut Creek, CA
Posts: 4,018
My Ride: 325Ci, 325Cic, C300
Quote:
Originally Posted by TWR View Post
GRD, On staring the car, no problem, tick over, no problem, 1st gear No Problem, from 1 >>2nd gear Hesitant / Surge, If I put my foot to the Floor it flies of like Sht off a shovel (Very Fast), If I ride the Clutch I can over ride the surge, this is where the issue is,


Mark, I replaced the last set of Plugs, they were NGK BKR6EQUP, the problem was still the same so I give the Bosch a try as a lot of sites state that the Bosch Plugs are Perfect.

The Pump is the Original as far as I know, I've had the car 14 Months, I've had all the previous Service details / reports, nothing has been indicated regards fuel issues, this I think would have shown up on the Emission Test (UK)
Not necessarily.
__________________






cvx5832 is online now   Reply With Quote
Old 04-20-2017, 02:31 PM   #12
armenh7
Registered User
 
Join Date: Dec 2016
Location: California
Posts: 180
My Ride: 2002 325i
Quote:
Originally Posted by TWR View Post
GRD, On staring the car, no problem, tick over, no problem, 1st gear No Problem, from 1 >>2nd gear Hesitant / Surge, If I put my foot to the Floor it flies of like Sht off a shovel (Very Fast), If I ride the Clutch I can over ride the surge, this is where the issue is,


Mark, I replaced the last set of Plugs, they were NGK BKR6EQUP, the problem was still the same so I give the Bosch a try as a lot of sites state that the Bosch Plugs are Perfect.

The Pump is the Original as far as I know, I've had the car 14 Months, I've had all the previous Service details / reports, nothing has been indicated regards fuel issues, this I think would have shown up on the Emission Test (UK)
Change your fuel pump and filter. They are way past replacement and they can fail without any signs. Plus, you'll get better mpgs
armenh7 is offline   Reply With Quote
Old 04-21-2017, 12:49 AM   #13
TWR
Registered User
 
Join Date: Jun 2016
Location: Lanc's UK
Posts: 45
My Ride: E46
Fuel filter was changed on Service Armenh7, gives out 32 MPG now. Cheers.
TWR is offline   Reply With Quote
Old 04-21-2017, 01:00 AM   #14
armenh7
Registered User
 
Join Date: Dec 2016
Location: California
Posts: 180
My Ride: 2002 325i
Quote:
Originally Posted by TWR View Post
Fuel filter was changed on Service Armenh7, gives out 32 MPG now. Cheers.
Those are great numbers
Now, check your DISA and see if it's bad. It will cause a loss in power if it's bad

Last edited by armenh7; 04-21-2017 at 01:01 AM.
armenh7 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 01:31 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
(c) 1999 - 2016 performanceIX Inc - privacy policy - terms of use