Engine oil level light comes on unexpectedly - E46Fanatics E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 10-14-2016, 08:36 AM   #1
mammadovadil
Registered User
 
Join Date: Oct 2016
Location: Baku, Azerbaijan
Posts: 13
My Ride: BMW E46 330i
Engine oil level light comes on unexpectedly

Hi everyone.

First of all, this is my first post here, so this may not be perfect.

I have 2002 BMW E46 330i. As many others, I also have to top of engine oil time-to-time. When engine oil is low, generally yellow engine oil light came on so I added about 1 litters of oil.

Previously, I used 5W-40 Castrol Magnatec and 5W-40 Castrol edge. Last time, I gave a try to 5W-30 Shell Helix Ultra. As I usually top-off engine oil, 0.5l Castrol Magnatec and 0.5l Castrol Edge left in my trunck. So, when last time yellow engine oil light came on, I poured Castrols on top of Shell. Because according to, my cars manual I can do this, I can even use other oils which are not "BMW High Performance Synthetic Oil".

Quote:
If you are unable to obtain an approved
"BMW High Performance Synthetic
Oil," you may use small volumes of
other approved synthetic oils for
topping up between oil changes. Use
only oils with the specification API SH
or higher.
The issue:

After doing this I have problem whith engine oil light. Now, when I start the warmed-up engine, afer approximatelly 10 seconds yellow engine oil light comes on, stays for about 10 seconds and goes out. I checked oil level manually and it is normal. Please, pay attention that, this does not happen when I start the engine when it's cold (i.e. in the morning), it only happens when I drive car for some time, shut down car (i.e. go to store) and when I re-start warmed-up engine it happens.

Have anybody experienced situation like that? Is my oil level senser malfunctioning? How can this issue be solved?

B.t.w: I absolutely love my car . Thanks in advance.
mammadovadil is offline   Reply With Quote
Old 10-14-2016, 09:08 AM   #2
markusmarkus
Registered User
 
Join Date: Jul 2008
Location: USA
Posts: 6,839
My Ride: 2001 330Ci
The oil level sensor is located in the bottom of the oil pan. Buy a new Hella sensor and change it the next time you change the oil. Your engine is, in BMWeze, an M54B30 engine. They burn oil as the oil control rings require a consistent crankcase vacuum. The crankcase ventilation system (CCV) is a piece of crap. The only real solution is an oil catch can.
markusmarkus is offline   Reply With Quote
Old 10-14-2016, 09:11 AM   #3
Solidjake
Radar Specialist
 
Solidjake's Avatar
 
Join Date: May 2008
Location: NYC
Posts: 31,294
My Ride: '13 328i Msport 6MT
https://www.fcpeuro.com/products/bmw...-12617508003-1
Solidjake is online now   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-14-2016, 09:23 AM   #4
mammadovadil
Registered User
 
Join Date: Oct 2016
Location: Baku, Azerbaijan
Posts: 13
My Ride: BMW E46 330i
Quote:
Originally Posted by markusmarkus View Post
The oil level sensor is located in the bottom of the oil pan. Buy a new Hella sensor and change it the next time you change the oil. Your engine is, in BMWeze, an M54B30 engine. They burn oil as the oil control rings require a consistent crankcase vacuum. The crankcase ventilation system (CCV) is a piece of crap. The only real solution is an oil catch can.
Quote:
Originally Posted by Solidjake View Post
markusmarkus and Solidjake, thank you for reply. I have replaced CCV in the past and decreasing of oil was not resolved.

Do you think that, my issue is according to oil sensor? But it began to happen after a day I mixed 5W-40 Castrol and 5W-30 Shell. Also, it does not show up when engine is cold. I do not want to change oil sensor, beacuse I do not think that it is because of it. How can I be sure that the reason is oil sensor itslef or something different?

Last edited by mammadovadil; 10-14-2016 at 09:24 AM.
mammadovadil is offline   Reply With Quote
Old 10-14-2016, 09:28 AM   #5
markusmarkus
Registered User
 
Join Date: Jul 2008
Location: USA
Posts: 6,839
My Ride: 2001 330Ci
Check the engine oil level after the engine has been off for 5 minutes after reaching full temperature. That's the "gold standard" for determining the actual oil level. If the yellow oil light comes on even though the oil level is fine the sensor is bad. It's a typical failure. Mixing oils won't hurt the engine as long as both oils are synthetic.
markusmarkus is offline   Reply With Quote
Old 10-14-2016, 09:36 AM   #6
Manolito
Registered User
 
Join Date: Feb 2014
Location: Sacramento CA
Posts: 293
My Ride: '04 325iT Manual
If you have an e46, your oil level sensor will fail. It is important to make sure the electrical connection to the sensor is clean and tight, but the sensor will eventually fail.

My experience agrees with Marcus. The Hella sensor I put in the 330i seems to be working OK after six months. The cheaper sensor I put in the 325i started throwing false low oil level lights almost immediately after being installed. Unfortunately, I did not make a note of what brand it was.

I doubt that mixing oil brands contributed to your sensor failure.
Manolito is offline   Reply With Quote
Old 10-14-2016, 10:13 AM   #7
Spannerhead
Save the Manuals!
 
Spannerhead's Avatar
 
Join Date: Jan 2016
Location: Chattanooga, TN
Posts: 2,786
My Ride: '02 330i/5 slicktop
Quote:
Originally Posted by mammadovadil View Post
It's a typical failure.
^This. Very common problem.

Don't rely on the sensor to tell you when you need oil, even when it's working properly. It's good practice to check the oil level via the dipstick at least once a week.
__________________

Current: '02 330i/5 '10 Mazda5 '72 240Z
Past: '85 GSL-SE '95 540i/6 '95 525i/5 '86 635CSi/5 '88 JZA70 '86 4K quattro '85 RX-7 S
Spannerhead is offline   Reply With Quote
Old 10-14-2016, 10:19 AM   #8
juslookin
Registered User
 
Join Date: Jan 2008
Location: yonkers
Posts: 1,237
My Ride: 05 330ci ZHP
And when you change the sensor be very gentle of the 3 nuts/studs holding it in. They will snap. Ask me how i know. Still only have 2 nuts holding mine in until i can get the stud out. No leak tho!
juslookin is offline   Reply With Quote
Old 10-14-2016, 01:53 PM   #9
mammadovadil
Registered User
 
Join Date: Oct 2016
Location: Baku, Azerbaijan
Posts: 13
My Ride: BMW E46 330i
Thanks everyone for reply.

Quote:
Originally Posted by markusmarkus View Post
Check the engine oil level after the engine has been off for 5 minutes after reaching full temperature. That's the "gold standard" for determining the actual oil level. If the yellow oil light comes on even though the oil level is fine the sensor is bad. It's a typical failure. Mixing oils won't hurt the engine as long as both oils are synthetic.
Yes, I know that. I let the engine to stay about 10 minutes on even place then I check oil with dipstick.

Quote:
Originally Posted by juslookin View Post
And when you change the sensor be very gentle of the 3 nuts/studs holding it in. They will snap. Ask me how i know. Still only have 2 nuts holding mine in until i can get the stud out. No leak tho!
Thanks for the tip.

I will wait until next oil change. If the problem persist then I will consider replacing oil sensor. Because, as it began immediately after mixing oils I am a bit suspicious about this situation. I will let you know about the results, in case someone needs it.
mammadovadil is offline   Reply With Quote
Old 10-14-2016, 02:41 PM   #10
das_autobahn
Registered User
 
Join Date: Aug 2016
Location: asheville
Posts: 533
My Ride: 2004 330ci coupe
surprised fruity guy didnt chime in saying replace engine...
das_autobahn is offline   Reply With Quote
Reply

Tags
330i, bmw, e46 2002, engine oil, engine oil light

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON



All times are GMT -5. The time now is 11:07 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
(c) 1999 - VerticalScope Inc. All rights reserved.