Biggest MS43 tuning thread ever! Incl software... - Page 187 - E46Fanatics E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Driveline, Engine & DME Tuning

Driveline, Engine & DME Tuning
Talk about driveline improvements, NA tuning and DME tuning your E46 BMW here. This includes diffs, intakes, exhausts, chips, software and OBD tuning.

Reply
 
Thread Tools Search this Thread Rating: Thread Rating: 20 votes, 4.95 average.
Old 07-18-2017, 10:21 AM   #3721
Antwan64
Registered User
 
Join Date: Jul 2017
Location: Uk
Posts: 4
My Ride: E46, 1.8t, bikes
Great resource Daniel, thank you!

This so more straightforward than Bosch systems to meAl.
Antwan64 is offline   Reply With Quote
Old 07-18-2017, 08:21 PM   #3722
wchetcuti
Registered User
 
Join Date: Jul 2017
Location: Canada
Posts: 5
My Ride: 2003 E46
Hoping to get some help with what I believe is an issue with software versions. I have flashed full 512kb file (EWS delete) and pulled 64kb file with Galletto, all seemed to work well. When 64kb file is opened in TunerPro and viewed with MS430056_64kb_Final_Eng definition file I'm getting odd numbers.

Is there anything required before 512kb flash to clear previous programming on DME? My understanding is that the full 512kb EWS flash should work and be MS430056.

Thanks!
wchetcuti is offline   Reply With Quote
Old 07-18-2017, 08:21 PM   #3723
wchetcuti
Registered User
 
Join Date: Jul 2017
Location: Canada
Posts: 5
My Ride: 2003 E46
Hoping to get some help with what I believe is an issue with software versions. I have flashed full 512kb file (EWS delete) and pulled 64kb file with Galletto, all seemed to work well. When 64kb file is opened in TunerPro and viewed with MS430056_64kb_Final_Eng definition file I'm getting odd numbers.

Is there anything required before 512kb flash to clear previous programming on DME? My understanding is that the full 512kb EWS flash should work and be MS430056.

Thanks!
wchetcuti is offline   Reply With Quote
Old 07-18-2017, 11:55 PM   #3724
sda2
Registered User
 
Join Date: Feb 2015
Location: Germany
Posts: 176
My Ride: BMW E46 330i Touring
Open the pulled file in a hex editor and search for either .DAT or MS4300 and post your result.

Last edited by sda2; 07-18-2017 at 11:56 PM.
sda2 is offline   Reply With Quote
Old 07-19-2017, 12:22 AM   #3725
Paul_13
Registered User
 
Join Date: Sep 2016
Location: Basingstoke
Posts: 25
My Ride: E46 330i touring
What's the full name of the file you're using for the xdf?
Paul_13 is offline   Reply With Quote
Old 07-19-2017, 12:40 AM   #3726
Antwan64
Registered User
 
Join Date: Jul 2017
Location: Uk
Posts: 4
My Ride: E46, 1.8t, bikes
why not Just use the 64kb for your engine off of the google drive and the .xdf?
Antwan64 is offline   Reply With Quote
Old 07-19-2017, 01:18 AM   #3727
wchetcuti
Registered User
 
Join Date: Jul 2017
Location: Canada
Posts: 5
My Ride: 2003 E46
Here is a screenshot from hex editor (shows ca430056.DAT??);
http://photobucket.com/gallery/user/...DUucG5n/?ref=1

Full name of definition file is MS430056_64kb_Final_Eng.xdf. Could use 64kb from google drive but I'd like to get things setup correctly first.

Thanks for your help!!
wchetcuti is offline   Reply With Quote
Old 07-19-2017, 01:34 AM   #3728
Paul_13
Registered User
 
Join Date: Sep 2016
Location: Basingstoke
Posts: 25
My Ride: E46 330i touring
Just to double check but how are you loading everything into tuner pro?

Are you loading the full 512kb file by accident?
Paul_13 is offline   Reply With Quote
Old 07-19-2017, 10:58 AM   #3729
valtteri
Registered User
 
Join Date: Aug 2009
Location: Helsinki,Finland
Posts: 3
My Ride: E46 x2
First of all, big up to Daniel & the rest of the guys for the impressive reverse engineering job with IDA
Being a little bit professionally involved with automotive ECU software, it's easy to tell what a massive load of work it must've been starting from a scratch.

To the topic: What would be the right mindset to start putting together a base tune for an M54B30 with a centrifugal supercharger? First edit all relative injection maps to suit the larger injectors and then edit both injection and ignition map load axis's last columns to match the new max cylinder charge (in this case roughly about 800mg/stroke), tune the cells in this specific column accordingly and let everything else more or less as it was from the factory? Tweak VANOS a bit, slightly lower the target ECT, tune full load enrichment... Something else important?

In most of the MS43 FI tunes I've seen the load axis's have been untouched while the ignition for example has been significantly retarded through out the whole map.

I'm also looking for an IAT based ignition retard map, can someone point me in the right direction?

Any view or/and experience is highly appreciated, thanks in advance

Last edited by valtteri; 07-19-2017 at 11:06 AM.
valtteri is offline   Reply With Quote
Old 07-19-2017, 02:07 PM   #3730
okeefe325ci
Registered User
 
Join Date: Jul 2015
Location: New hampshire
Posts: 6
My Ride: 325ci
2001 325ci monitors

hi all im hoping theres a guru here that can figure out a problem for me. I have a 2001 325ci with an EWS deleted ECU that has been euro2 tuned (catless,sapless) and running catless headers and sap delete. there are still 2 post o2 sensors plugged into the headers with 90 degree foulers that are no longer needed with the euro tune. What i am trying to do is set some monitors in hopes to maybe help said car pass inspection in NH. Currently the 3 monitors reading incomplete are Cat, o2, and o2 heater. i only need 1 of these to pass for a good obd inspection. Is there a way to manually set the o2 heater monitor on (or to N\a) or the other 2? i have tried setting the switches that ms43wiki suggested and the SAP portion has worked but my CAT monitor and o2 monitor still read incomplete. any help is much appriciated!
okeefe325ci is offline   Reply With Quote
Old 07-19-2017, 04:32 PM   #3731
Pole position
OEM ///Member
 
Join Date: Dec 2012
Location: Detroit
Posts: 1,119
My Ride: E46 330ci
Biggest MS43 tuning thread ever! Incl software...

So I m dialing in the new engine in my turbo car, however sometime it randomly has a fit and throws a bunch of codes. The fit included rough running, misfires, lean, dies sometimes when idling, and maybe a no start. It's happened twice, and is fixed by clearing codes and adaptations (I do at the same time).

Not sure how I can get the EWS code with the EWS delete 512 bin?

Anybody ever seen this? Also all my sensors are new (o2, cam, crank)






Sent from my iPhone using E46Fanatics mobile app
__________________
Shut up and drive

Last edited by Pole position; 07-19-2017 at 04:33 PM.
Pole position is offline   Reply With Quote
Old Yesterday, 12:31 AM   #3732
wchetcuti
Registered User
 
Join Date: Jul 2017
Location: Canada
Posts: 5
My Ride: 2003 E46
I'm loading 64kb file in Tunerpro and definitions file as provided and getting software version 34-33-30-30-33-37. I have flashed 512kb EWS delete file to two seperate DMEs (and read 64kb in Galletto) and am getting similar results. Both 64kb files are showing as caMS430056.DAT in hex editor.
wchetcuti is offline   Reply With Quote
Old Yesterday, 01:27 AM   #3733
franksidebike
Registered User
 
Join Date: Jun 2016
Location: Germany
Posts: 8
My Ride: E46
Hello
Quote:
Originally Posted by wchetcuti View Post
I'm getting odd numbers.
Wich Nummbers odd?
Frank
franksidebike is offline   Reply With Quote
Old Yesterday, 03:11 AM   #3734
Paul_13
Registered User
 
Join Date: Sep 2016
Location: Basingstoke
Posts: 25
My Ride: E46 330i touring
Have you changed the parameter offset from working on a 512kb file previously?
Paul_13 is offline   Reply With Quote
Old Yesterday, 01:09 PM   #3735
Antwan64
Registered User
 
Join Date: Jul 2017
Location: Uk
Posts: 4
My Ride: E46, 1.8t, bikes
Quote:
Originally Posted by Pole position View Post
So I m dialing in the new engine in my turbo car, however sometime it randomly has a fit and throws a bunch of codes. The fit included rough running, misfires, lean, dies sometimes when idling, and maybe a no start. It's happened twice, and is fixed by clearing codes and adaptations (I do at the same time).

Not sure how I can get the EWS code with the EWS delete 512 bin?

Anybody ever seen this? Also all my sensors are new (o2, cam, crank)






Sent from my iPhone using E46Fanatics mobile app
Is the file corrupted?

I know it should be cheksum free.....
Antwan64 is offline   Reply With Quote
Old Yesterday, 11:58 PM   #3736
wchetcuti
Registered User
 
Join Date: Jul 2017
Location: Canada
Posts: 5
My Ride: 2003 E46
Would someone be able to verify that my 64kb file looks OK and is the correct MS430056 software version, I'm getting an odd software version showing in TunerPro? I've uploaded it at the upload link.

I have flashed two DMEs with the 512kb EWS delete file (from google drive) and pulled two 64kb files using Galletto from each DME that both look the same but neither are lining up with the definitions correctly.

Thanks.
wchetcuti is offline   Reply With Quote
Old Yesterday, 11:58 PM   #3737
wchetcuti
Registered User
 
Join Date: Jul 2017
Location: Canada
Posts: 5
My Ride: 2003 E46
delete-double post

Last edited by wchetcuti; Today at 12:05 AM.
wchetcuti is offline   Reply With Quote
Old Today, 12:45 AM   #3738
Antwan64
Registered User
 
Join Date: Jul 2017
Location: Uk
Posts: 4
My Ride: E46, 1.8t, bikes
Does the car run with the ecu?

The different engines use a different 64kb file anyway so use the one for your engire and check it flashes and works ok in the car.
Antwan64 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Censor is OFF





All times are GMT -5. The time now is 04:56 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
(c) 1999 - VerticalScope Inc. All rights reserved.