E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Lighting Forum

Lighting Forum
Angel Eyes, DDEs, lighted rings, Clear Turn Signals, LEDs, Xenon, HID, or Bi-Xenon. If it lights up and you want to discuss it, post here!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 08-31-2013, 04:29 PM   #1
North Coast Cab
Registered User
 
Join Date: Feb 2011
Location: Ohio
Posts: 15
My Ride: Porsche
Factory HID Headlight Issue

My '04 330 has the factory HID lights.
The passenger one went out, no light out indication on dash.
I swapped the bulb, nothing.
I swapped the red/blk square ballast(?) side to side and no luck.
Is there an ignitor or something else I can check?
Also, wiring is very very brittle and I have been taping and insulating bits of it the last year or so as the insulation has broken off.

Thanks!
North Coast Cab is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 08-31-2013, 05:32 PM   #2
eneka
Registered User
 
Join Date: May 2007
Location: SoCal
Posts: 1,668
My Ride: 2003 325i
yes there is an ignitor within the headlight. It the part the twists onto the bulb. Do you have ZKW projectors? If so they might be burnt out as well.
__________________
eneka is offline   Reply With Quote
Old 08-31-2013, 06:29 PM   #3
afstud
Registered User
 
Join Date: Jun 2010
Location: NE Wisconsin
Posts: 999
My Ride: 02 & 04 325xi sports
It's probably easier to take the faulty headlight completely out and plug it into the side with the working headlight. Then determine what's wrong
__________________

02' 325i sport/premium pkgs zhp wheels & shift knob, euro clears, painted lip, Eonon Nav unit.
afstud is offline   Reply With Quote
Old 09-02-2013, 06:56 AM   #4
North Coast Cab
Registered User
 
Join Date: Feb 2011
Location: Ohio
Posts: 15
My Ride: Porsche
Thanks. Not sure what the ZKW projector is.
The bulb is a D2S.
So the ignitor is the black ring with the small metal contact area?
North Coast Cab is offline   Reply With Quote
Old 09-02-2013, 05:19 PM   #5
North Coast Cab
Registered User
 
Join Date: Feb 2011
Location: Ohio
Posts: 15
My Ride: Porsche
So I swapped bulbs and they are both good. I swapped Red/Blk ballasts and they are both good.
I went through the wiring and checked all the connections and heat shrinked the wires so everything looks well insulated.
Not sure where to look now?
North Coast Cab is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 10:51 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use