E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > Forced Induction Forum Sponsored by Active Autowerke

Forced Induction Forum Sponsored by Active Autowerke
Discuss supercharging, turbocharging and even nitrous and water injection here.
Sponsored by Active Autowerke

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 09-17-2013, 05:45 AM   #1
Martyc
Registered User
 
Join Date: Dec 2012
Location: UK
Posts: 31
My Ride: '02 M3 Coupe, PY/ IR
Vortech V3 charger rebuild

Guys,

After finally installing my ESS kit I'm gutted to find that there's an issue with the v3 charger unit itself.
It was sold as new (circ 2k miles) and I had stored away for some time (18 months). I drained the oil as the charger had effectively been run in and filled it up with a bottle of the Vortech oil it came with, checked the oil level and all was good then preceded to fire the car up and a strange noise was present from the charger. I then removed the intake pipe from the unit so as I could check the impeller blades/ shaft and there was a very slight bit of rotational movement followed by a clicking/ clunking noise, gutted is an understatement.

Spoken with the seller and he is adamant it was all perfect when he removed it and sold it to me as you'd expect and very hard to argue the toss but we will discuss etc in due course as no reason to not trust him particularly as we get on quite well tbf.

I've contacted Vortech via email and await their reply but as I'm based in the UK I'm considering whether I'd be better off acquiring a rebuild kit (http://www.928motorsports.com/parts/...ebuild_kit.php) and either rebuilding myself and/ or get a local engineering firm to do so for me in part or complete.

Does anyone have any experience of doing the same, are they any special tools required eg: press for the bearings etc any potential upgrade at the same time etc?

Any help or guidance would be greatly appreciated.

Just a little update:

Hopefully this is a better link to the video:
[YOUTUBE]

I've tried the following with no joy -
www.turbodynamics.co.uk/
www.essexautosport.com/
www.cplracing.co.uk/

Still to try the following amongst others plus some engineering firms I spotted a while back on some VAG forums:
www.turbotechnics.com/
http://www.midlandturbo.com/

BR

Marty
__________________
Mods are truly underway just I'm too lazy to detail them all for now.....

Last edited by Martyc; 09-17-2013 at 05:45 AM.
Martyc is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 10-03-2013, 03:05 AM   #2
s14realm3
Registered User
 
Join Date: May 2012
Location: suwanee, ga
Posts: 63
My Ride: 03 ZHP, 95 M3, 91 M3
I am in the process of rebuilding my V2 myself. I have taken apart the housing and pressed the output shaft out so all the gears and impeller are out. I got the oil seals off also. The only thing left on the housing is 1 of the big bearing that I need to rent a blind bearing puller to remove. I am looking at ordering a bearing kit BUT before I do that, I need to see which company includes a DIY video on how to press out the other old bearings and install it. I saw on youtube a mustang place that said they will include a DIY video with bearing kit purchase. I will check with them. My housing is currently out for powder coating, once I get it back next week, I can begin the bearing job.
s14realm3 is offline   Reply With Quote
Old 10-03-2013, 03:13 AM   #3
s14realm3
Registered User
 
Join Date: May 2012
Location: suwanee, ga
Posts: 63
My Ride: 03 ZHP, 95 M3, 91 M3
hey, i just watched your video, is that your car? If it is, I would check the pulleys, maybe a bad bearing in the pulleys and not the SC unit itself. Have you removed the drive belt and hand spin the SC to see if the noise is from the inside of the SC?
s14realm3 is offline   Reply With Quote
Old 10-03-2013, 04:41 PM   #4
Martyc
Registered User
 
Join Date: Dec 2012
Location: UK
Posts: 31
My Ride: '02 M3 Coupe, PY/ IR
Quote:
Originally Posted by s14realm3 View Post
I am in the process of rebuilding my V2 myself. I have taken apart the housing and pressed the output shaft out so all the gears and impeller are out. I got the oil seals off also. The only thing left on the housing is 1 of the big bearing that I need to rent a blind bearing puller to remove. I am looking at ordering a bearing kit BUT before I do that, I need to see which company includes a DIY video on how to press out the other old bearings and install it. I saw on youtube a mustang place that said they will include a DIY video with bearing kit purchase. I will check with them. My housing is currently out for powder coating, once I get it back next week, I can begin the bearing job.
Great feedback buddy, I have a guide of sorts for undertaking the repair albeit they suggest getting an engineering firm to press the shaft out etc?? Theres also a slight concern with ensuring the new one is installed correctly as tolerances for verticallity etc?? are minimal but maybe an element of scaremongery lol???

Where did you get your rebuild kit from and did you opt for he v2 upgraded to v3si??

I know of one at least one other (now in addition to yourself) who has the same issue with a v2 and looking at options to rebuild so we'd both be really appreciative for any guide, feedback etc etc you can in respect of the rebuild, issues, what you required in addition (blind bearing puller?), every little detail please

Quote:
Originally Posted by s14realm3 View Post
hey, i just watched your video, is that your car? If it is, I would check the pulleys, maybe a bad bearing in the pulleys and not the SC unit itself. Have you removed the drive belt and hand spin the SC to see if the noise is from the inside of the SC?
I haven't as this was sort of suggested but I was sure it was the unit itself I will actually do that and take another vid of my actions as keen to get the car sorted and road worthy but not at the costs of repair I've been quoted to date.

Really appreciate your post and input dude.

BR
Marty
__________________
Mods are truly underway just I'm too lazy to detail them all for now.....
Martyc is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 02:20 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use