E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > DIY: Do It Yourself

DIY: Do It Yourself
Post here to share or improve your wrench turning skills! All BMW E46 DIY tips, tales, and projects discussed inside. Learn to work on your car and know the right BMW parts you will need!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 09-24-2013, 02:14 PM   #1
dnerve
Registered User
 
Join Date: Sep 2013
Location: Ireland
Posts: 3
My Ride: 2004 E46 320td
2004 E46 320td - Multifunction Retrofit not working

Greetings to all!

Reading this forums for over 2 months, this has been a source for inspiration and information for my e46. Now is the time for my 1st post:

A little background story 1st:

A couple of months back, I bought my 1st bimmer as I was looking for a vehicle and got a pretty sweet deal while I was not eyeing this kind of car.

After some research, I started bringing upgrades (already had sports steering and knob and sports suspensions):OBC, coding AKMB and GM5 to switch to km and lt and locking behaviour with NCS Expert. So far so good!

Went on with retrofitting multifunctions buttons on the steering wheel. Checked all connectors, slip ring etc, they wont light up and are unresponsive (horn works well and no airbag light on)

While ordering the OBC stalk got a cheap deal and came with a slip ring so I decided to swap thinking existing slip ring would be faulty: Same results.

I decided to check further the wiring behind DSC button and Radio/Fan controls but saw nothing but there were some remnants of a non-operational Hands Free kit (Nokia FHU-5) which I removed alongside with a single yellow cable running from it to the back of the radio.

I cannot see any of the nokia cables messing with the harness from the steering wheel behind the slip ring or the central console just a couple of black leads running on the lower console, past the OBD port, probably to the speakers?

In any case, the buttons wont light-up or work just as disconnected (trying turning the wheel to check slip rings). I've checked the fuses but unsure where to look. I also checked with a multimeter the continuity of both slip rings connectors and they check out fine!

Any ideas what I could be missing and where to look?

Thanks for reading & the help!
dnerve is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 09-25-2013, 03:05 AM   #2
ocellatus
Registered User
 
Join Date: Apr 2013
Location: Tehran, Iran
Posts: 34
My Ride: 325i 2005
Multifunction Retrofit includes a cable set and wiring job to activate the radio/cruise control buttons, I guess you have missed this part. With help of the many threads and videos on it the wiring is kind of a straight forward procedure.

http://forum.e46fanatics.com/showthr...160&highlight=
__________________
ocellatus is offline   Reply With Quote
Old 09-25-2013, 07:44 PM   #3
dnerve
Registered User
 
Join Date: Sep 2013
Location: Ireland
Posts: 3
My Ride: 2004 E46 320td
Cool thanks,

Yeah figured that much, got the loom already so will be installing on my next day off!

Was confused as the seller told me it's plug and play except for cruise control (that why I got the loom in the first place, was planning on adding that later).

Thanks again for the reply!
dnerve is offline   Reply With Quote
Old 09-26-2013, 12:16 PM   #4
ocellatus
Registered User
 
Join Date: Apr 2013
Location: Tehran, Iran
Posts: 34
My Ride: 325i 2005
No problem.
Seller has been wrong since the buttons won't even light up before the wiring from steering wheel to LCM is done. Then one more wire to DME to activate cruise control.

Good luck with wiring.
__________________
ocellatus is offline   Reply With Quote
Old 10-02-2013, 02:44 PM   #5
ruikarel
Registered User
 
Join Date: Oct 2013
Location: Portugal
Posts: 4
My Ride: e46 330d Touring
hello there, just made this mod today, but only had the cable that connect the multifunction to slip ring..
the cable set to activate everything im still going to buy it for 25euros on Bmw Portugal..
so the lights of the buttons don't light up right? radio doesn't work either, and no cruise control.... all this because missing the cable set an the all the wiring, after install this, it's going to work right?
ruikarel is offline   Reply With Quote
Old 10-04-2013, 08:26 AM   #6
ocellatus
Registered User
 
Join Date: Apr 2013
Location: Tehran, Iran
Posts: 34
My Ride: 325i 2005
Yes that's right. None of them work before wiring.
I purchased the cable set too but I believe some people here made it themselves, it is just a set of 3 wires and some connectors.
And in case you don't have it, here I have attached the official BMW guide for the wiring.
Attached Files
File Type: pdf Multifunction steering wheel and cruise retrofit.pdf (470.9 KB, 43 views)
__________________
ocellatus is offline   Reply With Quote
Old 10-05-2013, 07:10 AM   #7
dnerve
Registered User
 
Join Date: Sep 2013
Location: Ireland
Posts: 3
My Ride: 2004 E46 320td
So I just installed the harness, everything cool except one thing:

My car has a M47TU engine. I used the pdf manual here.

According to it for my engine I need to use a white A8-A7 branch to go to PIN 37 in the DDE X60002 connector.

Instead in the kit I got 2 more contact branches one blue, one black. ----->see HERE the exact kit I got (61120016012)

None of the contacts I have seem to fit this connector: the long blue A6 of the harness and either of the black and blue additional branches.

What's the size of X60002's contact pins, where can I find them? Went to BMW and they where clueless...:s

Last edited by dnerve; 10-05-2013 at 07:11 AM.
dnerve is offline   Reply With Quote
Old 10-06-2013, 12:53 AM   #8
ocellatus
Registered User
 
Join Date: Apr 2013
Location: Tehran, Iran
Posts: 34
My Ride: 325i 2005
Well I have no idea since mine is M54 so I just used the long blue wire and it fits fine in corresponding connector.
May be you can remove one of the wires from your X60002 connector to see what kind of connector pin you need. I believe those X6000x connectors have a sliding lock you have to release to get the wires out.
__________________
ocellatus is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 01:37 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use