E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rating: Thread Rating: 2 votes, 5.00 average. Display Modes
Old 10-16-2013, 03:08 AM   #1
Ugur Ekim
Registered User
 
Join Date: Oct 2013
Location: The Netherlands
Posts: 136
My Ride: 325Ci 2001
Car vibrates short time but rough @ 1600 rpm

Hello,

Im pretty new here, and i dind't introduce myself on this forum. My name is Ugur Ekim and i own a BMW E46 325Ci coupe from 2001 with a milage of 200.000 kilometers.

Car is in great shape, no rust, no damage, almost nothing at all except a broken park sensor, heated seats is immediatly going off and since yesterday night i discoverd when i drive at normal speed, higher gear @ 1600 rpm (50 km/h roads) my car shakes rough and drops 200 rpm, then a second later back to 1600 rpm.

I can do it all the time if i want, i just drive on 1600 rpm and mather of seconds that he will do it again. I dind't have this problem on higher rpm (continues rpm) only at 1600... that's the strange part.

Also i have INPA software installed on my laptop including a usb to obd2 kabel wich worked fine for my old E39 523i but when i try to read out my E46 it can't find the correct engine (its a M54B25 for sure, USA drivers have M56B25) but when i choose this option it says engine version doesn't match but it does continue to the "read errors" menu (the next menu).

I have made a video while i was driving:


I always drive like i bought it today, to see if anything is wrong. Not this saturday, but next saturday i go to my friend's garage the whole day to inspect all the rubbers (also engine mounts) and im thinking to replace the gaskets since arround this mileage those things should be replaced, im not a moneysaver either, i always spend allot of money trying to perfectionize my car that will never happen, haha.

Besides those little things, the car runs great, it shifts superb, got nice wheels with new tires on it, and also new brake pads and rotators including new shock absorbers on the back.

For a price of 4200 euro +- 5600 dollars. Decent deal? Its completly damage free, and rust free (my friend is an expert on those, he has hes own company that repairs cars who had a accident and also a big painting area, i can get my car painted completly to a new color for less then 1300 euros +- 1700 dollars by hes company)

And also, im happy to join this forum, i dind't show myself here but i've read like every topic in this section _a_
Ugur Ekim is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 10-17-2013, 08:52 AM   #2
Ugur Ekim
Registered User
 
Join Date: Oct 2013
Location: The Netherlands
Posts: 136
My Ride: 325Ci 2001
bump
Ugur Ekim is offline   Reply With Quote
Old 10-18-2013, 11:19 AM   #3
Ugur Ekim
Registered User
 
Join Date: Oct 2013
Location: The Netherlands
Posts: 136
My Ride: 325Ci 2001
anyone that can help me?
Ugur Ekim is offline   Reply With Quote
Old 10-19-2013, 12:07 AM   #4
NumbaOneNewb
Registered User
 
Join Date: Jul 2012
Location: Portland, OR
Posts: 3,164
My Ride: 2003 330CI Silver
as long as it can read it, ignore the version mismatch message. have you checked your spark plugs? see if they are covered in oil.
__________________
Portland Metro: ECU updates, Euro tune, euro corner delete, air bag light, DSC light, cluster and any led color change, soldering work, transponders for keys, and all custom work related to computer or electronics.DIY AK90 A walk through on coding your mcu and transponders EWS3 How to make your own key (ak90 review)
NumbaOneNewb is offline   Reply With Quote
Old 10-20-2013, 03:49 AM   #5
Ugur Ekim
Registered User
 
Join Date: Oct 2013
Location: The Netherlands
Posts: 136
My Ride: 325Ci 2001
Re: Car vibrates short time but rough @ 1600 rpm

Hey, not het how will this fix the problem?

Sent from my Galaxy Nexus using BimmerApp mobile app
Ugur Ekim is offline   Reply With Quote
Old 10-20-2013, 03:52 AM   #6
ApolloTheGod
Registered User
 
Join Date: Mar 2012
Location: Everywhere
Posts: 461
My Ride: E92, E46, E36, Caddy
Quote:
Originally Posted by Ugur Ekim View Post
Hey, not het how will this fix the problem?

Sent from my Galaxy Nexus using BimmerApp mobile app
Worry about fixing the problem when you know exactly what the problem is. How will it help? It will help you identify the problem.
ApolloTheGod is offline   Reply With Quote
Old 10-21-2013, 09:57 AM   #7
Ugur Ekim
Registered User
 
Join Date: Oct 2013
Location: The Netherlands
Posts: 136
My Ride: 325Ci 2001
Hi, just to remind people who can help me (like the 2 above), this saturday i will put the car on a professional reader and also look for the spark plugs if they are not coverd in oil, check the gaskets etc.
Ugur Ekim is offline   Reply With Quote
Old 10-27-2013, 01:32 PM   #8
Ugur Ekim
Registered User
 
Join Date: Oct 2013
Location: The Netherlands
Posts: 136
My Ride: 325Ci 2001
Sparkplugs are clean, no oil.. still viberating @ 1600 rpm...
Ugur Ekim is offline   Reply With Quote
Old 10-27-2013, 02:07 PM   #9
lucke3er
Registered User
 
Join Date: Sep 2012
Location: Kokomo IN USA
Posts: 81
My Ride: 2003 BMW 330XI
Send a message via Skype™ to lucke3er
Could have a axle starting to fail, if its anything like this.

__________________
lucke3er is offline   Reply With Quote
Old 10-27-2013, 02:10 PM   #10
Ugur Ekim
Registered User
 
Join Date: Oct 2013
Location: The Netherlands
Posts: 136
My Ride: 325Ci 2001
Re: Car vibrates short time but rough @ 1600 rpm

Thank god it doesnt viberate like that. It doesnt always viberate either... Occassionaly when i drive arround with 1600 rpm..

Sent from my Galaxy Nexus using BimmerApp mobile app
Ugur Ekim is offline   Reply With Quote
Old 10-27-2013, 02:17 PM   #11
lucke3er
Registered User
 
Join Date: Sep 2012
Location: Kokomo IN USA
Posts: 81
My Ride: 2003 BMW 330XI
Send a message via Skype™ to lucke3er
Well my car would vibrate at an idle after driving for awhile, fixing the axles nearly made my car feel perfect.
I used to have to drive 30+ or more miles before It would even start to act up. Maybe check inner and outter cv boots,.

Now I got vibrating under braking (control arms I think).


Also I am forgetting mines awd and if your cars heating up faster than you think it should, thermostat repair asap!
__________________
lucke3er is offline   Reply With Quote
Old 10-27-2013, 02:27 PM   #12
Ugur Ekim
Registered User
 
Join Date: Oct 2013
Location: The Netherlands
Posts: 136
My Ride: 325Ci 2001
Well, mine does heat up fast i think for a car like this. I think it takes up like 3 minutes to get the car on 90 degrees celcius.

I think there are some bad sensors on the car, since i don't have it always. I've heard about something called O2 sensors. They decide the timing on the cilinders or something, and if one is malfunctioning, the timings get changed and that can make the car viberate.

Greetings
Ugur Ekim
Ugur Ekim is offline   Reply With Quote
Old 10-27-2013, 02:30 PM   #13
Ugur Ekim
Registered User
 
Join Date: Oct 2013
Location: The Netherlands
Posts: 136
My Ride: 325Ci 2001
@ 3:30 on the youtube video you can see what kind of viberation i talk about. It drops several hundred rpm's and viberates.
Ugur Ekim is offline   Reply With Quote
Old 11-04-2013, 03:54 PM   #14
Ugur Ekim
Registered User
 
Join Date: Oct 2013
Location: The Netherlands
Posts: 136
My Ride: 325Ci 2001
Still nobody knows what these problems are ?

I've searched more about it, it just drops 200 rpm +- and surge (little shaking, not extreme). Could this be the fuel pomp maybe not giving the neccesary fuel? I've readed out my car with inpa software saying camshaft sensor error but after removing the error (with professional tools from garage, not mine) it dind't came back up. Maybe it will come back up when i try to start my car in the early mornings (doesn't want to start on first try, mostly, maybe thats why the camshaft error like it was on my previous 523i. Dind't want to start because of bad sensors).

Most searched resulted in bad fuel pump, filter. That's like a 250 euro fix here in my country so that's why im asking for better advice
Ugur Ekim is offline   Reply With Quote
Old 11-04-2013, 06:23 PM   #15
David McMahon
Registered User
 
Join Date: Feb 2013
Location: Suffolk, UK
Posts: 1,435
My Ride: 15/Dec/98 E46 328i
I'd try to read codes every day, any that come back are likely
__________________
David McMahon is offline   Reply With Quote
Old 11-04-2013, 07:43 PM   #16
rizwan1377
Registered User
 
Join Date: Nov 2010
Location: Rockland county, NY
Posts: 1,785
My Ride: 04 M56,LC 100,RX300
Send a message via AIM to rizwan1377 Send a message via MSN to rizwan1377 Send a message via Yahoo to rizwan1377
Re: Car vibrates short time but rough @ 1600 rpm

It can be a bad torque converter. I had the same vibration around 1600 rpm and around 40mph. I thought it was a bad driveshaft bearing and guibo but after replacing those 2 I still had the vibration. 1 week after that I was on driving on the highway when the transmission light came on and car started smoking, when I pulled over it had leaked all the fluid. When we took out the transmission at my dad's shop, the torque converter had spun on to the bearing for transmission pump.


Sent from my SCH-I545 using BimmerApp mobile app
Attached Thumbnails
Click image for larger version

Name:	1383611955366.jpg
Views:	36
Size:	77.3 KB
ID:	533387  
__________________
rizwan1377 is offline   Reply With Quote
Old 11-05-2013, 02:48 AM   #17
Ugur Ekim
Registered User
 
Join Date: Oct 2013
Location: The Netherlands
Posts: 136
My Ride: 325Ci 2001
Re: Car vibrates short time but rough @ 1600 rpm

End this month i will replace the fuel pump and filter + camshaft sensor. If the problem stil occure i will flush my transmission including the converter. I will do this a month after the fuel pump change. I notice also that my car is using more petrol then it should... So maybe it has something to do with the fuel pump.

Sent from my Galaxy Nexus using BimmerApp mobile app
Ugur Ekim is offline   Reply With Quote
Old 11-05-2013, 02:56 AM   #18
323i2011Y
Registered User
 
Join Date: Nov 2011
Location: Virginia
Posts: 105
My Ride: BMW
Car vibrates short time but rough @ 1600 rpm

Using more gas than it should makes me think o2 sensors. Do that before a fuel pump...


Sent from BimmerApp mobile app
__________________
Steel Blue
3 Pedals, 4 Doors
323i2011Y is offline   Reply With Quote
Old 11-06-2013, 04:01 PM   #19
Ugur Ekim
Registered User
 
Join Date: Oct 2013
Location: The Netherlands
Posts: 136
My Ride: 325Ci 2001
very strange, the problem occures more today. Now not only @ 1600 but on random rpm's. This really scares me, it does not happen when i accelerate but only when im on a steady rpm.. I felt some heavy viberation on the rear also.. How can i troubleshoot my fuel pump, transmission..

What else could be the problem you guys thing? I really need advice.
Ugur Ekim is offline   Reply With Quote
Old 11-06-2013, 09:16 PM   #20
323i2011Y
Registered User
 
Join Date: Nov 2011
Location: Virginia
Posts: 105
My Ride: BMW
Car vibrates short time but rough @ 1600 rpm

Check guibo also known as flex disc. Mine went bad once before and the entire car shook like a wheel was loose.


Sent from BimmerApp mobile app
__________________
Steel Blue
3 Pedals, 4 Doors
323i2011Y is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 11:44 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use